Increasing font size

X.Org on FreeBSD installation & configuration.

Increasing font size

Postby Poincare » 17 Jul 2009, 23:21

I installed xorg and it working great except for one very crucial thing. The font size is miniscule. My eyes have almost popped out trying to read the letters! Any tips on how to increase the font size?
Poincare
Junior Member
 
Posts: 24
Joined: 13 Jul 2009, 03:09

Postby aragon » 18 Jul 2009, 00:51

It would be helpful if you tell us what window manager and/or desktop environment you're running.
aragon
Giant Locked
 
Posts: 2031
Joined: 16 Nov 2008, 17:04
Location: Cape Town, South Africa

Postby phoenix » 18 Jul 2009, 03:02

Also, what size of monitor, and what screen resolution you are using.

Most likely, all you need to do is change the DPI settings in X to match the real dimensions of your monitor/resolution.
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
User avatar
phoenix
MFC'd
 
Posts: 3349
Joined: 17 Nov 2008, 05:43
Location: Kamloops, BC, Canada

Postby setti » 18 Jul 2009, 10:47

Yah great question, I want also know how can we increase font. Actually I am under freebsd 7.1 release that running X11R6 + motif WM.

Best regards
User avatar
setti
Junior Member
 
Posts: 65
Joined: 19 Jun 2009, 20:53
Location: Oujda City, Morocco

Postby aragon » 18 Jul 2009, 13:31

It's a fairly open ended question. Different X11 toolkits, Window managers, and applications handle fonts differently. For example, with GTK 2 the default font can be set in ~/.gtkrc-2.0 as follows:

Code: Select all
gtk-font-name="Tahoma 8"


Which would set the default font to Tahoma at 8pt size. Only GTK apps would follow that, and a GTK theme might override it.

In Firefox, you can setup your fonts in Preferences/Content.

In desktop environments like Gnome and KDE there'll be a control panel app that lets you specify this.

There are ways of creating overrides low down in the font rendering engine by setting up fonts.conf appropriately. See fonts-conf(5) for more information.

Unfortunately I can't help with Motif.
aragon
Giant Locked
 
Posts: 2031
Joined: 16 Nov 2008, 17:04
Location: Cape Town, South Africa

Postby Poincare » 18 Jul 2009, 15:58

I don't have a window manager or desktop manager. Just xorg to open firefox and wireshark. I think my monitor is 19'' but I can't be sure since I bought from a yard sale and I never got a handbook or anything.
Poincare
Junior Member
 
Posts: 24
Joined: 13 Jul 2009, 03:09

Postby vermaden » 18 Jul 2009, 16:08

Poincare wrote:Just xorg to open firefox and wireshark.


Type about:config in Firefox address bar and search for DPI setting, I use 75/72, but if you need bigger sizes try increasing it to something like 96.

Also you can select default X11 DPI by starting it like that: xinit -- -dpi 75
Religions, worst damnation of mankind.
"FreeBSD has always been the operating system that GNU/Linux should have been." Frank Pohlmann, IBM
[FILE][color="DarkSlateBlue"]http://vermaden.blogspot.com[/color][/FILE]
User avatar
vermaden
Giant Locked
 
Posts: 2316
Joined: 16 Nov 2008, 19:37
Location: pl_PL.lodz

Postby Poincare » 18 Jul 2009, 21:57

vermaden wrote:Type about:config in Firefox address bar and search for DPI setting, I use 75/72, but if you need bigger sizes try increasing it to something like 96.

Also you can select default X11 DPI by starting it like that: xinit -- -dpi 75


What about xterm? Those fonts are reeeealy small.
Poincare
Junior Member
 
Posts: 24
Joined: 13 Jul 2009, 03:09

Postby aragon » 18 Jul 2009, 22:38

Poincare wrote:What about xterm? Those fonts are reeeealy small.

xterm is configured via Xresources. Add something like this to your ~/.Xdefaults:

Code: Select all
xterm*faceName: Monospace:size=10
aragon
Giant Locked
 
Posts: 2031
Joined: 16 Nov 2008, 17:04
Location: Cape Town, South Africa


Return to X.Org

Who is online

Users browsing this forum: No registered users and 1 guest