keyboard

The K Desktop Environment

keyboard

Postby Graaf_van_Vlaanderen » 04 Jul 2009, 15:42

KDE4 is not taking over the keyboard layout from cli.
Which file do I need to edit to change keyboard layout for KDE4?
Graaf_van_Vlaanderen
Member
 
Posts: 199
Joined: 03 Feb 2009, 10:43
Location: Halle, Belgium

Postby richardpl » 04 Jul 2009, 16:52

KDE4 have its own GUI tools.
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby Daisuke_Aramaki » 04 Jul 2009, 18:22

Graaf_van_Vlaanderen wrote:KDE4 is not taking over the keyboard layout from cli.
Which file do I need to edit to change keyboard layout for KDE4?


are you trying setxkbmap to set your layout? I have never tried it with KDE. But it worked on other wm's after changing the layout from the commandline using setxkbmap for me.
User avatar
Daisuke_Aramaki
Member
 
Posts: 220
Joined: 09 Feb 2009, 20:51
Location: Stuttgart, Germany

Postby Graaf_van_Vlaanderen » 04 Jul 2009, 19:23

Daisuke_Aramaki wrote:are you trying setxkbmap to set your layout? I have never tried it with KDE. But it worked on other wm's after changing the layout from the commandline using setxkbmap for me.



Code: Select all
%setxkbmap be


works for me.
The question is now, in which file do I need to place this?
Or what is changing the keymap setting from the rc.conf file or why is this value not taken over by the X system?
Graaf_van_Vlaanderen
Member
 
Posts: 199
Joined: 03 Feb 2009, 10:43
Location: Halle, Belgium

Postby richardpl » 04 Jul 2009, 19:30

If you ever read man pages ([man=1]kbdmap[/man]) you would know that console keyboard settings are not related to X11 in any way.

You can change keyboard setting via xorg.conf too.
Also there are gui tools available in KDE4.
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby Graaf_van_Vlaanderen » 04 Jul 2009, 20:13

richardpl wrote:If you ever read man pages ([man=1]kbdmap[/man]) you would know that console keyboard settings are not related to X11 in any way.


It's the first time I'm installing FreeBSD on a laptop, so there are quite some issues to solve.
I'm reading man pages and documents already for the whole day, so I can miss comments like this!
Graaf_van_Vlaanderen
Member
 
Posts: 199
Joined: 03 Feb 2009, 10:43
Location: Halle, Belgium

Postby Daisuke_Aramaki » 04 Jul 2009, 21:27

Graaf_van_Vlaanderen wrote:
Code: Select all
%setxkbmap be


works for me.
The question is now, in which file do I need to place this?
Or what is changing the keymap setting from the rc.conf file or why is this value not taken over by the X system?


i start my X with xinit so i have this command in my .xinitrc, like this

Code: Select all
setxkbmap de &


This way, everytime X is started the keyboard map "de" is used.
User avatar
Daisuke_Aramaki
Member
 
Posts: 220
Joined: 09 Feb 2009, 20:51
Location: Stuttgart, Germany

Postby ale » 05 Jul 2009, 00:21

I'm not 100% sure that this is going to work on kde too, but try looking at this [post=19423]post[/post].
Obviously you'll have to set the correct string inside the merge node.
User avatar
ale
Senior Member
 
Posts: 1064
Joined: 19 Nov 2008, 01:28
Location: Roma


Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests