Dontzap false doesn't

X.Org on FreeBSD installation & configuration.

Dontzap false doesn't

Postby RandomSF » 12 Jun 2009, 18:49

Running x.org 7.4, fluxbox 1.1.

I have
Code: Select all
Section "ServerFlags"
        Option       "DontZap" "false"
EndSection
in my xorg.conf, but <ctrl><alt><bksp> no longer does anything. Up until a couple weeks ago I had used this to close down my Xsession.

Unfortunately for me, I don't remember changing anything that would cause this new (lack of) behavior.

Any ideas?
RandomSF
Junior Member
 
Posts: 23
Joined: 16 Nov 2008, 22:07

Postby anomie » 12 Jun 2009, 18:55

The xorg.conf(5) manpages indicate:
Option "DontZap" "boolean"


Could it be that providing any value to this directive registers as true? Just remove the directive from your config altogether and see if you're getting the behavior you want.
"Do Not Engage in Useless Activity" --Miyamoto Musashi
User avatar
anomie
Member
 
Posts: 783
Joined: 17 Nov 2008, 04:37
Location: Texas

Postby RandomSF » 12 Jun 2009, 19:05

The rest of that section of man page has
Code: Select all
Option "DontZap"  "boolean"
This disallows the use of the Ctrl+Alt+Backspace sequence.
That sequence is normally used to terminate the  Xorg  server.
When this  option  is enabled (as per default),
that key sequence has no special meaning.
Default: on.
so I think it's enabled by default. I tried your suggestion anyway and it didn't help.
RandomSF
Junior Member
 
Posts: 23
Joined: 16 Nov 2008, 22:07

Postby anomie » 12 Jun 2009, 19:10

Hmm, I see. I should have checked my Xorg version (7.3) before responding. In my case, default is off.

The other thing I'd suggest is checking how "boolean" is represented in the 7.4 xorg.conf manpages. (FALSE == 0, false, off, no.. or what?)
"Do Not Engage in Useless Activity" --Miyamoto Musashi
User avatar
anomie
Member
 
Posts: 783
Joined: 17 Nov 2008, 04:37
Location: Texas

Postby richardpl » 12 Jun 2009, 20:30

If you dont use hald with Xorg:

Code: Select all
Section "InputDevice"
 Identifier "Keyboard0"
 Driver "kbd"
 Option "XkbOptions" "terminate:ctrl_alt_bksp,...."


if you use hald with Xorg, you need to modify hald settings .....
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby RandomSF » 12 Jun 2009, 21:14

I don't use hald with X.

Your snippet solved my problem.

Thank you.
RandomSF
Junior Member
 
Posts: 23
Joined: 16 Nov 2008, 22:07


Return to X.Org

Who is online

Users browsing this forum: No registered users and 0 guests