Sound card not detected... Help?

Internal storage, motherboards, PCI cards, stuff inside the case.

Sound card not detected... Help?

Postby spoon » 04 Jun 2009, 23:56

Hello all, i'm very new(noob) to FreeBSD, an Ubuntu user, and former winblow$ user... Anyway who cares, on to my dilemma. I'm unable to get my SB X-fi sound card working. I tried setting up my sound card with "kldload snd_emu10k1" in the terminal, but then I get this error: "kldload: can't load snd_emu10k1: File exists".:(

At first I though this was FreeBSD's way of saying installation was successful and reboot, but um... suffice to say that wasn't the case as KMix won't show anything.

I was able to get this same sound card(duh) working under Ubuntu 64 without any problems:e, but it refuses to work under freebsd.:( I'm running FreeBSD 7.1 64bit with KDE 3.5 and everything else works wonderfully(as can be expected) except this sound card, which doesn't work at all.

I'm not concerned about any special BS features/frills ect. I just want to be able to hear sound. Please if anyone can help, I really want this to work, for the most part I'm enjoying freebsd, as it's faster than ubuntu, and if I get my sound card working I may just replace ubuntu entirely. Is there a way I could port the X-fi linux driver to FreeBSD?

Thanks in advance for any assistance you can provide me.
User avatar
spoon
Junior Member
 
Posts: 20
Joined: 08 May 2009, 03:47

Postby ale » 05 Jun 2009, 00:14

Did you tried following the handbook?
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/sound-setup.html

Can you try as root kldload sound; cat /dev/sndstat ?
User avatar
ale
Senior Member
 
Posts: 1064
Joined: 19 Nov 2008, 01:28
Location: Roma

Postby joel@ » 05 Jun 2009, 05:08

FreeBSD does not support the Creative X-FI soundcard. Maybe if you try the OSS port.
User avatar
joel@
Member
 
Posts: 245
Joined: 27 Sep 2007, 06:42
Location: Arentorp, Sweden

Postby SirDice » 05 Jun 2009, 11:26

Indeed, you need to install [port]audio/oss[/port] to get the X-Fi working.

Mine works fine with it:

Code: Select all
dice@williscorto:~>ossinfo
Version info: OSS 4.1 (b 1052/200906022100) (0x00040100) BSD
Platform: FreeBSD/i386 7.2-STABLE FreeBSD 7.2-STABLE #0: Tue May  5 13:09:54 CEST 2009     root@molly.dicelan.home:/usr/obj/usr/src/sys/CORTO (williscorto.dicelan.home)

Number of audio devices:        2
Number of audio engines:        6
Number of mixer devices:        1


Device objects
 0: oss_sbxfi0 Sound Blaster X-Fi (SB073x) interrupts=22320665 (22320665)
    PCI device 1102:0005, subdevice 1102:0031


Mixer devices
 0: Sound Blaster X-Fi (SB073x) (Mixer 0 of device object 0)

Audio devices
Sound Blaster X-Fi (SB073x) output  /dev/oss/oss_sbxfi0/pcm0  (device index 0)
Sound Blaster X-Fi (SB073x) input  /dev/oss/oss_sbxfi0/pcmin0  (device index 1)
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16182
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby spoon » 06 Jun 2009, 01:59

Thanks for your help guys, but the OSS port doesn't work.
I got this error:

Code: Select all
oss-4.1.b1052 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of audio/oss
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1


I also tried kldload sound, but got this error:

Code: Select all
kldload: can't load sound: File exists


Oh well thanks for helping anyway, I guess I'll just use freebsd without sound...:\
User avatar
spoon
Junior Member
 
Posts: 20
Joined: 08 May 2009, 03:47

Postby Oko » 06 Jun 2009, 02:21

spoon wrote:Thanks for your help guys, but the OSS port doesn't work.
I got this error:

Code: Select all
oss-4.1.b1052 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of audio/oss
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1


I also tried kldload sound, but got this error:

Code: Select all
kldload: can't load sound: File exists


Oh well thanks for helping anyway, I guess I'll just use freebsd without sound...:\


Even better. Do not use FreeBSD pardon PC-BSD (which you obviously use) at all.

Did you even read what people suggested you to read? What does
kldload mean? kldload loads kernel modules drivers! You have been already instructed that your sound card is not supported by
any of kernel drivers. There is nothing to load into the kernel.

Sir Dice specifically told you that your card is supported by OSS. He even showed you his ossinfo. He has the same audio card as you.

The fact that OSS is already installed tells me that you do not use Vanilla FreeBSD but probably PC-BSD. On Vanilla FreeBSD you will enable OSS drivers
after installing the port by editing rc.conf with oss_enable="yes". Read the post compilation message! Then rebooting and you will have the sound. You probably want also to read documentation which comes with OSS since OSS port uses its own miser ossmixer and other things.
If you want to use VoIP you will have to adjust few permissions.
Wanting to learn is so rare a merit that it should be encouraged.
User avatar
Oko
Member
 
Posts: 374
Joined: 19 Nov 2008, 04:14
Location: Kosovo, Srbija

Postby DutchDaemon » 06 Jun 2009, 14:04

Please do not use bold and colour for system output, use [code] tags.
User avatar
DutchDaemon
Old Fart
 
Posts: 10463
Joined: 16 Nov 2008, 20:17
Location: The Netherlands

Postby spoon » 06 Jun 2009, 17:03

Oko, please calm down. Besides, there is no reason why you should be more upset than I am about my sound card not working.:\ I am in fact running FreeBSD and not PC-BSD. Below is a screen shot of FreeBSD detailing an error with the sound driver.

Image
User avatar
spoon
Junior Member
 
Posts: 20
Joined: 08 May 2009, 03:47

Postby SirDice » 07 Jun 2009, 13:24

Just add to /etc/rc.conf:
Code: Select all
oss_enable="YES"


No need to kldload anything the startup script will take care of it.

Not sure about KDE/ARTS working with oss though. I use Xfce and I try to stear clear of pulseaudio, esound or arts. Just set all your applications to use /dev/dsp0.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16182
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby spoon » 07 Jun 2009, 19:54

I added the code to the rc.conf file using ee (pic below) and rebooted but still no sound.:(
Image

Below this sentence is the code from ossinfo; am I doing something wrong?

Code: Select all
# ossinfo
Version info: OSS 4.1 (b 1052/200906060125) (0x00040100) BSD
Platform: FreeBSD/amd64 7.1-RELEASE FreeBSD 7.1-RELEASE #0: Thu Jan  1 08:58:24 UTC 2009     root@driscoll.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC (.gateway.2wire.net)

Number of audio devices:        2
Number of audio engines:        6
Number of mixer devices:        1


Device objects
 0: oss_sbxfi0 Sound Blaster X-Fi (SB055x) interrupts=105127 (105127)
    PCI device 1102:0005, subdevice 1102:0022


Mixer devices
 0: Sound Blaster X-Fi (SB055x) (Mixer 0 of device object 0)

Audio devices
Sound Blaster X-Fi (SB055x) output  /dev/oss/oss_sbxfi0/pcm0  (device index 0)
Sound Blaster X-Fi (SB055x) input  /dev/oss/oss_sbxfi0/pcmin0  (device index 1)
User avatar
spoon
Junior Member
 
Posts: 20
Joined: 08 May 2009, 03:47

Postby Bunyan » 08 Jun 2009, 05:27

Try soundon. This command enables the sound.
And test the sound from the black and white console with osstest
User avatar
Bunyan
Member
 
Posts: 143
Joined: 23 Jan 2009, 20:51

Postby spoon » 09 Jun 2009, 18:00

I got this error when I tried soundon:
Code: Select all
# soundon
kldload: can't load /usr/local/lib/oss/modules/osscore.ko: File exists
Loading the osscore module failed


However, when I tried osstest I was able to hear a short piano song out of both my speakers. Does this mean the sound is working? Why did I get the error above?
User avatar
spoon
Junior Member
 
Posts: 20
Joined: 08 May 2009, 03:47

Postby adamk » 09 Jun 2009, 18:20

You got that error because having oss_enable="YES" in /etc/rc.conf will start up oss and load the necessary module. There was no reason to run 'soundon'.

Based on the output from 'ossinfo' it looks like your card is detected and the driver loaded. osstest seems to confirm that.

Adam
adamk
Senior Member
 
Posts: 1624
Joined: 21 Nov 2008, 11:00

Postby Bunyan » 09 Jun 2009, 19:13

Startx and run ossxmix.
User avatar
Bunyan
Member
 
Posts: 143
Joined: 23 Jan 2009, 20:51

Postby malexe » 09 Jun 2009, 21:47

regarding your kde error message, I would start by following it, change the sample rate.

You can find the appropriate option in your control center.
User avatar
malexe
Junior Member
 
Posts: 33
Joined: 11 Dec 2008, 01:52

Postby spoon » 10 Jun 2009, 18:26

I ran ossmix and got this:
Code: Select all
# ossmix
Selected mixer 0/Sound Blaster X-Fi (SB055x)
Known controls are:
play [<leftvol>:<rightvol>] (currently 14.4:14.4 dB)
rec [<leftvol>:<rightvol>] (currently 14.4:14.4 dB)
recsrc <mic|line|video|aux|none> (currently line)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 96000) (Read-only)
vmix0-src <Fast|Low|Medium|High|High+|Production|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 24.7 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm2 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm3 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


I also changed the sample rate from 44100 to 96000 no more pop-up error but after I ran osstest I got this error:

Code: Select all
*** Scanning sound adapter #-1 ***
/dev/oss/oss_sbxfi0/pcm0 (audio engine 0): Sound Blaster X-Fi (SB055x) output
- Performing audio playback test...
  <left> Device returned error: Input/output error
/dev/oss/oss_sbxfi0/pcmin0 (audio engine 1): Sound Blaster X-Fi (SB055x) input
- Skipping input only device

*** Some errors were detected during the tests ***


So now osstest fails completely and I still have no sound. This is really odd because the audio works perfectly on XFCE (yes i'm also using XFCE) but when I tired the same procedure while running KDE I still can't seem to get any sound.
User avatar
spoon
Junior Member
 
Posts: 20
Joined: 08 May 2009, 03:47

Postby spoon » 12 Jun 2009, 22:10

Nevermind, I got it working.:stud Thank you for all your help as well as your patience, I wouldn't have been able to do it without you all.
User avatar
spoon
Junior Member
 
Posts: 20
Joined: 08 May 2009, 03:47

Postby DutchDaemon » 12 Jun 2009, 23:19

At least post the solution for other people encountering these problems.
User avatar
DutchDaemon
Old Fart
 
Posts: 10463
Joined: 16 Nov 2008, 20:17
Location: The Netherlands


Return to System Hardware

Who is online

Users browsing this forum: No registered users and 1 guest