YouTube not working in Firefox

Having problems running your new shiny and blinking gadget or watching DVDs, listening to CDs etc.?

YouTube not working in Firefox

Postby neelwebs » 22 Mar 2013, 18:34

I use Firefox on FreeBSD 9.1-RELEASE, and use Flash player through [FILE]nspluginwrapper[/FILE] and Linux emulation. Since yesterday, YouTube videos haven't worked on Firefox. I know that flash player works on Firefox, I don't have gnash, and YouTube works in Opera.
Is there a solution to this problem (Other than changing my browser)?
neelwebs
Junior Member
 
Posts: 12
Joined: 27 Apr 2012, 19:28

Postby wblock@ » 22 Mar 2013, 18:53

Happening here, too. Videos either think there is no Flash or cause Firefox to coredump. Run Firefox from the command line and see if it shows this:
Code: Select all
% firefox
(process:77232): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
Assertion failed: (wrote >= 0 && wrote == got), function cubeb_refill_stream, file /usr/ports/www/firefox/work/mozilla-release/media/libcubeb/src/cubeb_alsa.c, line 314.
Abort (core dumped)
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby zspider » 22 Mar 2013, 20:07

Try enabling the HTML5 trial on Youtube, if your browser supports it, it should work for some videos, the ones that don't appear to work will, if you use the embedded link.
User avatar
zspider
Member
 
Posts: 461
Joined: 16 Jun 2010, 16:50

The same

Postby YuryG » 26 Mar 2013, 17:57

The same here. YouTube became useless in latest Firefox last days. It either hangs in the video area, or tells me to upgrade Flash (it is in the latest Linux distro). In Epiphany YouTube still works. HTML5 is still too buggy, and not available for all videos. Also severe audio-video de-sync (or lagging in reaction) occurs when it is possible to start video in YouTube in Firefox.

FreeBSD-9.1.
YuryG
Junior Member
 
Posts: 3
Joined: 26 Mar 2013, 17:47

Postby wblock@ » 26 Mar 2013, 18:00

Please enter a PR.
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby cpm » 26 Mar 2013, 21:05

cpm
Senior Member
 
Posts: 1353
Joined: 30 Jul 2011, 20:10

Postby jrm » 26 Mar 2013, 21:24

I'm also having this problem (certain videos say I don't have the flash plugin installed). Setting [file]dom.ipc.plugins.enabled[/file] to [file]false[/file] in [file]about:config[/file] seems to be working, but I can not say for sure since the problem only happened with certain videos (which I can't specifically recall).

I only have the build options [file]GSTREAMER[/file], [file]LOGGING[/file], [file]OPTIMIZE_CFLAGS[/file] and [file]OSS[/file] selected.
User avatar
jrm
Member
 
Posts: 729
Joined: 16 Nov 2008, 17:32
Location: Halifax, Nova Scotia, Canada

Postby cpm » 26 Mar 2013, 21:41

When Firefox terminates a plugin that is no longer responding, you will see the "plugin has crashed" error dialog. To prevent Firefox from terminating plugins it considers non-responsive, must set [FILE]dom.ipc.plugins.timeoutSecs[/FILE] to [FILE]-1[/FILE] in [FILE]about:config[/FILE].
cpm
Senior Member
 
Posts: 1353
Joined: 30 Jul 2011, 20:10

Postby wblock@ » 26 Mar 2013, 23:12

Mine didn't say anything about a plugin crashing, it just coredumped.

To be more specific about these workarounds: enter [file]about:config[/file] as a URL, right-click, select New, Boolean, enter [file]media.use_cubeb[/file], and set it to [file]false[/file]. [file]dom.ipc.plugins.enabled[/file] already exists, just set it to [file]false[/file]. After that, close and restart Firefox.

Followup: some non-Youtube videos will not play if the second one is set to [file]false[/file]. But if it is set to [file]true[/file], some Youtube videos claim Flash is not installed.
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby YuryG » 27 Mar 2013, 01:48

[FILE]dom.ipc.plugins.enabled[/FILE] to false works for me, thanks! Some videos I couldn't watch on youtube (all) yesterday I can now.
YuryG
Junior Member
 
Posts: 3
Joined: 26 Mar 2013, 17:47

Postby neelwebs » 28 Mar 2013, 13:47

YuryG wrote:[FILE]dom.ipc.plugins.enabled[/FILE] to false works for me, thanks! Some videos I couldn't watch on youtube (all) yesterday I can now.


Thanks! Now I can watch YouTube videos in Firefox!
neelwebs
Junior Member
 
Posts: 12
Joined: 27 Apr 2012, 19:28

Postby KNOStic » 31 Mar 2013, 06:32

Definitely something going on there - I don't get the crashes, but more often than not I get the "You need to install flash player" on an animated GIF background of analog TV snow. Latest flash version, works just dandy everywhere else. Tricks listed above make no difference.

Does the same thing when enabling HTML5, and when you click on the animated GIF which replaces the flash data, it's definitely showing that it's trying to push HTTP HTML5 video down and has cancelled the flash load just as it would normally start. Seems to me as though they're screwing with Firefox, Epiphany and Chromium work just fine.
Kevin McAleavey
The KNOS Project
User avatar
KNOStic
Junior Member
 
Posts: 77
Joined: 20 Jun 2010, 07:08
Location: Voorheesville, NY

Postby Understudy » 05 Apr 2013, 12:25

KNOStic wrote:Definitely something going on there - I don't get the crashes, but more often than not I get the "You need to install flash player" on an animated GIF background of analog TV snow. Latest flash version, works just dandy everywhere else. Tricks listed above make no difference.

Does the same thing when enabling HTML5, and when you click on the animated GIF which replaces the flash data, it's definitely showing that it's trying to push HTTP HTML5 video down and has cancelled the flash load just as it would normally start. Seems to me as though they're screwing with Firefox, Epiphany and Chromium work just fine.



I have the same situation as you. I just get the message "You need to install flash player." I am running v 20 on Firefox and 9.1 on [del]freebsd[/del] FreeBSD.

Sincerely,
Brendhan
My dream is to have a post that doesn't need to be edited by DutchDaemon.
Understudy
Junior Member
 
Posts: 83
Joined: 17 Nov 2008, 01:37
Location: West Palm Beach, FL

Postby wblock@ » 05 Apr 2013, 14:02

With Firefox 20, [file]media.use_cubeb[/file] true, and [file]dom.ipc.plugins.enabled[/file] left at the default (true), no problems with any video tried so far.
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby YuryG » 06 Apr 2013, 05:35

No, for me YouTube videos still could only be played with [FILE]dom.ipc.plugins.enabled[/FILE] to false in latest Firefox 20; the same as earlier, in 19th version of Firefox. (By the way, I didn't use [FILE]media.use_cubeb[/FILE] either time.)
YuryG
Junior Member
 
Posts: 3
Joined: 26 Mar 2013, 17:47

Postby AngryWolf » 06 Apr 2013, 15:08

jrm wrote:I'm also having this problem (certain videos say I don't have the flash plugin installed). Setting [file]dom.ipc.plugins.enabled[/file] to [file]false[/file] in [file]about:config[/file] seems to be working, but I can not say for sure since the problem only happened with certain videos (which I can't specifically recall).


Hope this helps identifying those videos:

In my experience, without the mentioned workaround, videos that are only available in 240p resolution could be played without any problems, the rest (ie. ones also available in HD resolutions did not work for me.
AngryWolf
Junior Member
 
Posts: 18
Joined: 19 Mar 2011, 21:31

Postby vortex » 07 Apr 2013, 11:44

wblock@ wrote:Mine didn't say anything about a plugin crashing, it just coredumped.

To be more specific about these workarounds: enter [file]about:config[/file] as a URL, right-click, select New, Boolean, enter [file]media.use_cubeb[/file], and set it to [file]false[/file]. [file]dom.ipc.plugins.enabled[/file] already exists, just set it to [file]false[/file]. After that, close and restart Firefox.

Followup: some non-Youtube videos will not play if the second one is set to [file]false[/file]. But if it is set to [file]true[/file], some Youtube videos claim Flash is not installed.


This works for me.
Thanks!
vortex
Junior Member
 
Posts: 1
Joined: 16 Nov 2008, 19:38
Location: germany, hamburg

Just disable the adblock addon and it should probably work

Postby zubair » 07 Apr 2013, 15:41

Just disable the Adblock add-on and it should probably work. It worked for me that way.
zubair
Junior Member
 
Posts: 1
Joined: 07 Apr 2013, 15:38

Postby neelwebs » 08 Apr 2013, 18:47

zubair wrote:Just disable the Adblock add-on and it should probably work. It worked for me that way.


I did not have Adblock on my Firefox. And anyways I'm now using Opera (got a little too used to it).
neelwebs
Junior Member
 
Posts: 12
Joined: 27 Apr 2012, 19:28

Postby baos » 11 Apr 2013, 06:39

Fix worked for me, thanks for posting it!
baos
Junior Member
 
Posts: 18
Joined: 22 Jul 2010, 07:07

Postby poisonlux » 12 Apr 2013, 20:16

I got this:

[FILE]media.use_cubeb[/FILE] → true
[FILE]dom.ipc.plugins.enabled[/FILE] → false

And it's working o.o
poisonlux
Junior Member
 
Posts: 4
Joined: 23 Mar 2013, 03:56

Postby macondo » 29 Apr 2013, 18:35

Hi all, do these tips apply to FreeBSD 8.3? Thank you.
FreeBSD 8.3 - ratpoison/icewm - Desktop Atom/1 GB RAM
macondo
Junior Member
 
Posts: 13
Joined: 07 Oct 2010, 14:19

Postby ankscorek » 10 May 2013, 01:21

Hey friends,

To be more specific about these workarounds: enter about:config as a URL, right-click, select New, Boolean, enter media.use_cubeb, and set it to false. dom.ipc.plugins.enabled already exists, just set it to false. After that, close and restart Firefox.


This work around was working for quite some time, but now this one has stopped responding. I tried other combinations as given in this thread but again the video part is not working.

Any suggestions please.
ankscorek
Junior Member
 
Posts: 58
Joined: 13 Nov 2012, 09:49

Postby wblock@ » 10 May 2013, 01:52

[file]dom.ipc.plugins.enabled[/file] is the touchy one. As reported, some videos only work with it set to true, some only work with it set to false.
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby chessmaster » 21 Sep 2013, 15:36

wblock@ wrote:Mine didn't say anything about a plugin crashing, it just coredumped.

To be more specific about these workarounds: enter [file]about:config[/file] as a URL, right-click, select New, Boolean, enter [file]media.use_cubeb[/file], and set it to [file]false[/file]. [file]dom.ipc.plugins.enabled[/file] already exists, just set it to [file]false[/file]. After that, close and restart Firefox.

Followup: some non-Youtube videos will not play if the second one is set to [file]false[/file]. But if it is set to [file]true[/file], some Youtube videos claim Flash is not installed.


Thanks! That solved my problem.
User avatar
chessmaster
Junior Member
 
Posts: 57
Joined: 01 Jan 2012, 15:23
Location: Dover,DE

Next

Return to Multimedia

Who is online

Users browsing this forum: No registered users and 1 guest