ccache calls clang, not gcc46

Installing and upgrading FreeBSD.

ccache calls clang, not gcc46

Postby Beeblebrox » 23 Jan 2013, 17:00

I seem to be getting an onslaught of odd errors these days...

I recently switched to the slower updated [port]lang/gcc[/port] from [port]lang/gcc46[/port]. As you know, the only difference is that [port]lang/gcc[/port] updates are less frequent than [FILE]gcc46[/FILE].

I'm also running a pure [FILE]clang[/FILE] world using [FILE]WITH_CLANG_IS_CC[/FILE]. But now a strange problem: When I try to build a port, [FILE]clang[/FILE] is being used by [FILE]ccache[/FILE] (I can tell by the output). The only way to ensure that [FILE]gcc46[/FILE] is used as compiler is to disable in [FILE]/etc/make.conf[/FILE] this:
Code: Select all
#CC:=${CC:C,^gcc46,/usr/local/libexec/ccache/world/gcc46,1}
#CXX:=${CXX:C,^g\+\+\46,/usr/local/libexec/ccache/world/g++46,1}

And enable this:
Code: Select all
CC=gcc46
CXX=g++46

I have played around with some settings but I get no results.
11-CURRENT_amd64_root-on-zfs_RadeonKMS
User avatar
Beeblebrox
Member
 
Posts: 838
Joined: 03 Sep 2010, 04:45

Return to Installing & Upgrading

Who is online

Users browsing this forum: No registered users and 2 guests