Sound issue PC-BSD 9.0 on Lenovo Thinkpad R400

This forum discusses issues related to running FreeBSD on notebooks, laptops, and other mobile equipment.

Sound issue PC-BSD 9.0 on Lenovo Thinkpad R400

Postby AB-stromer » 29 Nov 2012, 08:59

Hi all,

I am happy with FreeBSD and PC-BSD on my 3 systems, however with PC-BSD 9.0 on my Lenovo Thinkpad R400 I don't get sound regardless what I try. Would be glad if one of you experts have a hint for me!

Situation:

Parameters and tunings I have found in various postings to similar topics, tried out but have erased again as they have not been working in my case are:

[FILE]/boot/loader.conf[/FILE]:
Code: Select all
sound_load="YES"
snd_hda_load="YES"
snd_driver_load="YES"

[FILE]/etc/sysctl.conf[/FILE]: (also tried with =0 ....)
Code: Select all
/hw.snd.default_unit=1


[FILE]/boot/device.hints[/FILE]:
Code: Select all
hint.hdac.0.cad0.nid18.config="as=0"
hint.hdac.0.cad0.nid17.config="as=1 seq=15 device=Headphones"
hint.hdac.0.cad0.nid22.config="as=1 seq=0"


Now, after erasing all these try-and-errors, the cleaned-up-again situation is as follows:

[FILE]dmesg[/FILE]:
Code: Select all
..
hdac0: <Intel 82801I High Definition Audio Controller> mem 0xfc020000-0xfc023fff
irq 17 at device 27.0 on pci0
..
hdac0: HDA Codec #0: Conexant CX20561 (Hermosa)
pcm0: <HDA Conexant CX20561 (Hermosa) PCM #0 Analog> at cad 0 nid 1 on hdac0
pcm1: <HDA Conexant CX20561 (Hermosa) PCM #1 Analog> at cad 0 nid 1 on hdac0
..

Code: Select all
$ cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 32bit 2009061500/i386)
Installed devices:
pcm0: <HDA Conexant CX20561 (Hermosa) PCM #0 Analog> (play/rec) default
pcm1: <HDA Conexant CX20561 (Hermosa) PCM #1 Analog> (play/rec)

[FILE]/etc/sysctl.conf[/FILE]:
Code: Select all
hw.snd.default_auto=1


The sound is working with other operating systems so I mean it is not a broken hardware (just wanted to check the basics ;) )
AB-stromer
Junior Member
 
Posts: 7
Joined: 16 Nov 2008, 17:15

Postby SirDice » 29 Nov 2012, 09:26

[thread=7290]Topics about PC-BSD | FreeNAS | NAS4Free | DesktopBSD | m0N0WALL | pfSense | kFreeBSD[/thread]
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16161
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby mav@ » 29 Nov 2012, 21:27

Have yo tested your headphones output? Have you tried it in combination with hw.snd.default_unit=1?
mav@
Member
 
Posts: 604
Joined: 20 Feb 2008, 22:44
Location: Dnepropetrovsk, Ukraine

Postby Trihexagonal » 30 Nov 2012, 03:46

Try adding these lines to your [file]/etc/rc.conf[/file] file:

Code: Select all
snddetect_enable="YES"
mixer_enable="YES"
User avatar
Trihexagonal
Member
 
Posts: 156
Joined: 20 Mar 2012, 04:39

Postby AB-stromer » 30 Nov 2012, 08:35

mav@ wrote:Have yo tested your headphones output?


Yes, also no sound

mav@ wrote:Have you tried it in combination with hw.snd.default_unit=1?


yes, with =1 and with =0; no change
AB-stromer
Junior Member
 
Posts: 7
Joined: 16 Nov 2008, 17:15

Postby AB-stromer » 30 Nov 2012, 08:53

Trihexagonal wrote:Try adding these lines to your [file]/etc/rc.conf[/file] file:

Code: Select all
snddetect_enable="YES"
mixer_enable="YES"


have tried that, and: hey, first time sound on headphones!!

but not yet speaker...
AB-stromer
Junior Member
 
Posts: 7
Joined: 16 Nov 2008, 17:15

Postby Trihexagonal » 30 Nov 2012, 09:09

AB-stromer wrote:have tried that, and: hey, first time sound on headphones!!

but not yet speaker...


I'm glad it helped. I'd go back and try some of those settings again in your first post you said you erased now that you do have some sound.
User avatar
Trihexagonal
Member
 
Posts: 156
Joined: 20 Mar 2012, 04:39


Return to Mobile Computing

Who is online

Users browsing this forum: No registered users and 0 guests