Unable to build libreoffice-3.5.2.2

Installing and maintaining the FreeBSD Ports Collection or FreeBSD Packages (i.e. third party software).

Unable to build libreoffice-3.5.2.2

Postby alie » 03 May 2012, 07:56

Code: Select all
oovbaapi deliver
Module 'oovbaapi' delivered successfully. 0 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/cppuhelper/qa/unourl

 it seems that the error is inside 'cppuhelper', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd cppuhelper
rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/cppuhelper/unxfbsd.pro # optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
*** Error code 1

Stop in /usr/ports/editors/libreoffice.



Anyone facing same issue with FreeBSD 9-STABLE?
[color="DarkRed"]www.alielee.com[/color]
FreeBSD FreeBSD 9.1-PRERELEASE #0 r243320 /usr/obj/usr/src/sys/EZYCLIE amd64
User avatar
alie
Member
 
Posts: 561
Joined: 11 Dec 2008, 08:13
Location: Somewhere in the world

Postby zeissoctopus » 03 May 2012, 15:19

Do you enable any non-default features such as DTrace userland in [FILE]/etc/make.conf[/FILE] or
Code: Select all
WITH_ICONV=yes
in [FILE]/etc/src.conf[/FILE] in base/kernel configuration files?
My FreeBSD 9-STABLE built libreoffice 3.5.2_2 + openjdk6 without any error.
zeissoctopus
Member
 
Posts: 140
Joined: 08 Aug 2009, 09:09
Location: Hong Kong

Postby alie » 04 May 2012, 01:11

zeissoctopus wrote:Do you enable any non-default features such as DTrace userland in [FILE]/etc/make.conf[/FILE] or
Code: Select all
WITH_ICONV=yes
in [FILE]/etc/src.conf[/FILE] in base/kernel configuration files?
My FreeBSD 9-STABLE built libreoffice 3.5.2_2 + openjdk6 without any error.


I didn't add any non-default feature, just plain [FILE]make.conf[/FILE] with [FILE]clang[/FILE] for the kernel.
[color="DarkRed"]www.alielee.com[/color]
FreeBSD FreeBSD 9.1-PRERELEASE #0 r243320 /usr/obj/usr/src/sys/EZYCLIE amd64
User avatar
alie
Member
 
Posts: 561
Joined: 11 Dec 2008, 08:13
Location: Somewhere in the world

Postby Drohne » 06 May 2012, 12:45

The same problem here on both FreeBSD 9-STABLE/amd64 (SVN tag r235056, buildworld today) and FreeBSD 10-CURRENT/amd64 (SVN tag r235072, buildworld today), there error is on all systems (three of them) the same:

Code: Select all
[ build CHK ] loaded modules: cppcanvas

cppcanvas deliver
Module 'cppcanvas' delivered successfully. 0 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            [url]http://wiki.documentfoundation.org/Development[/url]

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/ucb/source/ucp/cmis

 it seems that the error is inside 'ucb', please re-run build
 inside this module to isolate the error and/or test your fix:

-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd ucb
rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/ucb/unxfbsd.pro # optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [install] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [run-depends] Error code 1

Stop in /usr/ports/german/libreoffice.
*** [/usr/ports/german/libreoffice/work/.install_done.libreoffice._usr_local] Error code 1

Stop in /usr/ports/german/libreoffice.
*** [run-depends] Error code 1

Stop in /usr/ports/editors/libreoffice-i18n.
*** [install] Error code 1
E c c A Bque e d
Drohne
Junior Member
 
Posts: 2
Joined: 28 Mar 2012, 08:15

Postby bsdpit » 17 May 2012, 08:13

Hi,

Same problem here. Any ideas?
Thank you!
bsdpit
Junior Member
 
Posts: 1
Joined: 01 May 2012, 13:51

Postby Drohne » 18 May 2012, 07:08

Yes, there is a solution, but I forgot the details.

The reason was that I compiled some ports prerequiste for LibreOffice with GCC 4.6 (or the system's legacy gcc 4.2.1). This seems to confuse the build with CLANG.

You may see where or on what your compile process stops when you follow the instructions given at the stage of disruption of the compilation process. Do it, follow the advice! If the error is still persistent, you will get a hint on what library the compilation will terminate errorful - as it did in my attempt. I recompiled that faulty port with CLANG and the error went away.

I forgot what library I had to recompile, sorry about this.
E c c A Bque e d
Drohne
Junior Member
 
Posts: 2
Joined: 28 Mar 2012, 08:15

Postby overmind » 18 May 2012, 11:12

I had the same problem. I've just recompiled the kernel and world without [file]clang[/file] support and then I was able to compile LibreOffice.

Just remove from [FILE]/etc/make.conf[/FILE]:
Code: Select all
CC?=clang
CXX?=clang++


Then rebuild your kernel and world and you should be able to compile LibreOffice.
overmind
Member
 
Posts: 315
Joined: 18 Nov 2008, 12:29

Postby Grell » 20 May 2012, 17:35

I seem to be having the same problem. While compiling libreoffice it continuously fails building certain modules, I go into the work directory and successfully build them, then retry compiling libreoffice. Inevitably another module fails building and I must start the process over again, only to be followed by another module failing to build. I have tried adding
Code: Select all
CC?=clang
CXX?=clang++
to [FILE]make.conf[/FILE], as well as compiling without those options. I seem to be stuck :\ . Anyway, if anyone has a solution I'm all ears.
Grell
Junior Member
 
Posts: 78
Joined: 31 Mar 2011, 14:04
Location: New Jersey, US

Postby overmind » 20 May 2012, 17:38

Remove those two line from [file]/etc/make.conf[/file] then recompile and reinstall kernel and world and then try to compile libreoffice.
overmind
Member
 
Posts: 315
Joined: 18 Nov 2008, 12:29

Postby tim-m89 » 21 May 2012, 07:55

overmind wrote:I had the same problem. I've just recompiled the kernel and world without [file]clang[/file] support and then I was able to compile LibreOffice.

Just remove from [FILE]/etc/make.conf[/FILE]:
Code: Select all
CC?=clang
CXX?=clang++


Then rebuild your kernel and world and you should be able to compile LibreOffice.


This was never part of my [FILE]/etc/make.conf[/FILE]:
Code: Select all
WITH_QT_PHONON=yes

RUBY_DEFAULT_VER=1.9

WITH_GTK2=yes

# added by use.perl 2012-03-11 00:51:13
PERL_VERSION=5.14.2

And I have exact same error as alie.

Edit not exactly the same. Mine failed on vcl rather than cppuhelper.
tim-m89
Member
 
Posts: 121
Joined: 13 Mar 2009, 03:46

Postby tim-m89 » 22 May 2012, 05:53

My theory based on it failing on different modules randomly then working is that it perhaps is related to parallel builds. A quick look in the makefiles:
[FILE]/usr/ports/editors/libreoffice/Makefile[/FILE]:
Code: Select all
MAKE_JOBS_UNSAFE= yes

[FILE]/usr/ports/editors/openoffice-3/Makefile[/FILE]:
Code: Select all
MAKE_JOBS_SAFE= yes


Maybe changing the line in libreoffice's Makefile from
Code: Select all
MAKE_JOBS_UNSAFE= yes
to
Code: Select all
MAKE_JOBS_SAFE= yes
will work?
tim-m89
Member
 
Posts: 121
Joined: 13 Mar 2009, 03:46

Postby wblock@ » 22 May 2012, 15:19

[file]MAKE_JOBS_UNSAFE=yes[/file] is saying that parallel build jobs don't work with that port. Changing that will allow parallel jobs, which is not likely to help.
User avatar
wblock@
Old Fart
 
Posts: 10171
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby overmind » 22 May 2012, 20:21

Just build and install kernel and world without [file]clang[/file] and see if then [file]libreoffice[/file] will compile.
overmind
Member
 
Posts: 315
Joined: 18 Nov 2008, 12:29

Postby Junkie » 23 May 2012, 14:58

Here is a hint
Code: Select all
/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd ucb
rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/ucb/unxfbsd.pro # optional module 'clean'
build

Just follow it
Junkie
Junior Member
 
Posts: 18
Joined: 22 Oct 2010, 18:10
Location: Kyev, Ukraine

Postby Grell » 23 May 2012, 21:52

Yeah I have tried that, building the modules manually. What inevitably happens though is another module will fail later on. I go build it and down the road another will fail. It also has nothing to do with having [FILE]clang[/FILE] and all that in [FILE]make.conf[/FILE] as I have compiled my userland and kernel without specifying it to use [FILE]clang[/FILE].
Grell
Junior Member
 
Posts: 78
Joined: 31 Mar 2011, 14:04
Location: New Jersey, US

Postby srivo » 31 May 2012, 12:25

Same problem for me!
srivo
Junior Member
 
Posts: 65
Joined: 04 Dec 2009, 12:59
Location: Canada

Postby roddierod » 03 Jun 2012, 14:47

Did anyone figure this out as I am having the same problem now?
User avatar
roddierod
Member
 
Posts: 697
Joined: 17 Nov 2008, 12:36
Location: On my Slingerlands!

editors/libreoffice doesn't compile

Postby pkubaj » 04 Jun 2012, 05:53

I'm trying to update libreoffice-3.5.2_2 to 3.5.2_4. Unfortunately, it seems I can't. The error is:
Code: Select all
-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/vcl/prj

 it seems that the error is inside 'vcl', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd vcl
gmake clean # optional
gmake -r

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** Error code 1



As I use a recent 9.0-STABLE, I also have Clang 3.1. That's why, having thought that it may not work with 3.1 and after reading libreoffice's [FILE]Makefile[/FILE], I confirmed that compilation with GCC 4.6 is supported. I decided to try it out and that's what I saw later:
Code: Select all
-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            [url]http://wiki.documentfoundation.org/Development[/url]

  internal build errors:

ERROR: error 65280 occurred while making /usr/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/cppunit

 it seems that the error is inside 'cppunit', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd cppunit
rm -Rf /usr/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/cppunit/unxfbsd.pro # optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/obj/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** Error code 1


Of course, I had run [cmd=]make clean[/cmd] before attempting to compile with GCC. In both cases, I tried to run [FILE]make[/FILE] in those directories, with Clang the compilation continues on, only to exit with similar error later, although in different directory. I suspect that the same also happens when using GCC, but I haven't tried it.

In order to be sure that it's not my misconfiguration, I've recompiled the world with an empty [FILE]/etc/src.conf[/FILE], which didn't help. I've also confirmed that the very same error is also present on my another PC, but the installed ports and their configuration are mostly the same. It seems that some ports interfere with [port]editors/libreoffice[/port].

At last, options I use for compilation are:
Code: Select all
朮碓pkubaj@DESKTOP1朮碓 Mon Jun 04 07:51:41P
_cwd}/usr/ports/editors/libreoffice/ make showconfig
===> The following configuration options are available for libreoffice-3.5.2_4:
     DEBUG=off: Enable debug flags
     GNOME=off: Enable GNOME Desktop support
     GTK2=on: Enable GTK2 gui toolkit support
     GTK3=off: Enable GTK3 gui toolkit support
     JAVA=on: Add java support (XML Filters, macros)
     KDE4=off: Enable KDE4 Desktop support
     MMEDIA=on: Enable multimedia backend for impress
     PGSQL=off: Build with PostgreSQL-SDBC driver
     SDK=off: Build with SDK
     SVG=on: Enable SVG image support
     SYSTRAY=off: Enable systemtray quickstarter
     WEBDAV=off: Enable webdav protocol
===> Use 'make config' to modify these settings

They worked before, except that I compiled when PGSQL option wasn't present.

My [FILE]/etc/make.conf[/FILE] is as following:

Code: Select all
CPUTYPE?=core2
WITH_NEW_XORG="YES"
DISTDIR=/tmp
WRKDIRPREFIX=/usr/obj
.if (!empty(.CURDIR:M/usr/src*) || !empty(.CURDIR:M/usr/obj*))
.if !defined(NOCCACHE)
CC:=${CC:C,^cc,/usr/local/libexec/ccache/world/cc,1}
CXX:=${CXX:C,^c\+\+,/usr/local/libexec/ccache/world/c++,1}
.endif
.endif

.if ${CC:T} == "clang"
CFLAGS+=        -Qunused-arguments
.endif
# added by use.perl 2012-05-11 02:51:01
PERL_VERSION=5.14.2
pkubaj
Member
 
Posts: 377
Joined: 02 Jun 2010, 21:49

Postby roddierod » 04 Jun 2012, 15:51

This fixed my problem

http://marc.info/?l=freebsd-ports&m=133850915813844&w=2

I still need to go into each individual module and fix the errors when the popped up, but the last one was descripted in the post above and the patch included allowed me to successfully finish the build.
User avatar
roddierod
Member
 
Posts: 697
Joined: 17 Nov 2008, 12:36
Location: On my Slingerlands!

Postby pkubaj » 04 Jun 2012, 22:49

I've found another, easier workaround: install [port]editors/openoffice-3[/port]
It also works quite well, considering that there's 3.4 already.
pkubaj
Member
 
Posts: 377
Joined: 02 Jun 2010, 21:49

Postby tim-m89 » 05 Jun 2012, 02:39

pkubaj wrote:I've found another, easier workaround: install [port]editors/openoffice-3[/port]
It also works quite well, considering that there's 3.4 already.


That's not a workaround, that's just giving up. I would like to take libreoffice for a spin but I'm just going to make do with openoffice for now too though.
tim-m89
Member
 
Posts: 121
Joined: 13 Mar 2009, 03:46

Postby pkubaj » 05 Jun 2012, 10:03

tim-m89 wrote:That's not a workaround, that's just giving up. I would like to take libreoffice for a spin but I'm just gona make do with openoffice for now too though.


Frankly, I find OpenOffice better than LibreOffice (at least ATM). It works way faster than LO. I don't think I would switch back to LO, even if I could. Maybe LO is more standard-compliant, but it doesn't matter for me, OO is enough for me.
pkubaj
Member
 
Posts: 377
Joined: 02 Jun 2010, 21:49

Postby Mage » 05 Jun 2012, 11:18

pkubaj wrote:I'm trying to update libreoffice-3.5.2_2 to 3.5.2_4. Unfortunately, it seems I can't. The error is:
Code: Select all
-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
...


Same here. And since I upgraded [FILE]png-[/FILE] first the already installed version of LibreOffice doesn't work.
Mage
Junior Member
 
Posts: 47
Joined: 16 Dec 2011, 01:00

Postby wblock@ » 05 Jun 2012, 13:29

roddierod wrote:This fixed my problem

http://marc.info/?l=freebsd-ports&m=133850915813844&w=2

I still need to go into each individual module and fix the errors when the popped up, but the last one was descripted in the post above and the patch included allowed me to successfully finish the build.


Mine eventually built but did not run.
User avatar
wblock@
Old Fart
 
Posts: 10171
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby roddierod » 05 Jun 2012, 13:37

Yes...I didn't get to follow up on this, thinking maybe I did miss something. I got a splash screen but nothing else. Running from the terminal gave no errors either.

Still a bit of chatter about this on the mailing list, as you know. I'm attempting to build apache-openoffice now, as I need something to open my important spreadsheets and such.
User avatar
roddierod
Member
 
Posts: 697
Joined: 17 Nov 2008, 12:36
Location: On my Slingerlands!

Next

Return to Installation and Maintenance of FreeBSD Ports or Packages

Who is online

Users browsing this forum: Carpetsmoker, Google [Bot] and 4 guests