KDE Konsole and zsh

The K Desktop Environment

KDE Konsole and zsh

Postby vdaras » 09 Mar 2012, 15:38

Hello,

In FreeBSD 9.0 system with KDE version 4.7.3, I changed my user's default shell using [FILE]chsh[/FILE] to [FILE]zsh[/FILE] and now every time I use Konsole it seems it can't spawn a [FILE]zsh[/FILE] process at startup. If I change back to [FILE]csh[/FILE] and run [FILE]/bin/zsh[/FILE] (I've created a link to [FILE]/usr/local/bin/zsh[/FILE]) Konsole works perfectly with [FILE]zsh[/FILE]. When using [FILE]chsh[/FILE] I tried both [FILE]/bin/zsh[/FILE] and [FILE]/usr/local/bin/zsh[/FILE] to no avail. Anyone experienced the same problem?
vdaras
Junior Member
 
Posts: 4
Joined: 15 Apr 2011, 19:36

Postby xibo » 09 Mar 2012, 19:02

I had that problem. You can open another tab in konsole which will spawn immediately (well, lagging of cause due to the 200% cpu usage of the first tab). After about 5 minutes, the first tab will become usable too. I.e. always the first zsh session of a new konsole window will hang, for about 5 minutes on full cpu usage, with both sides spinning in select(2) iirc.

I don't know what it's caused by, but upgrading to the new versions of kde and zsh solved it for me ;)
xibo
Member
 
Posts: 373
Joined: 03 Dec 2010, 07:49
Location: Germany

Postby phoenix » 09 Mar 2012, 19:38

Did you also update your Konsole settings to start ZSH by default instead of BASH? Works fine here, no pause at startup, no lag, no issues. Been using ZSH with Konsole since the early KDE 4.2-ish days.
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
User avatar
phoenix
MFC'd
 
Posts: 3349
Joined: 17 Nov 2008, 05:43
Location: Kamloops, BC, Canada

Postby Persephone » 09 Mar 2012, 21:16

I was having a similar problem with KDE and zsh a couple months ago. Not sure which port upgrade(s) fixed the problem but I no longer have it with an up to date ports.
Persephone
Junior Member
 
Posts: 33
Joined: 25 Nov 2011, 08:28


Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests