Problem with mounting CD-ROM

General questions about the FreeBSD operating system. Ask here if your question does not fit elsewhere.

Problem with mounting CD-ROM

Postby olo » 02 Mar 2012, 20:11

Hello,
I just installed FreeBSD 9 on VMware Workstation and I have a problem with mounting an IDE CD-ROM.

This is happening when I'm trying to mount it:
Code: Select all
freebsd# mkdir /cdrom
freebsd# mount /dev/cd0 /cdrom
[B]mount: /dev/cd0 : Invalid argument[/B]


My [FILE]/dev[/FILE]:
Code: Select all
freebsd# cd /dev
freebsd# ls
acpi            cuau0.lock      led             stderr          ttyva
ad3             cuau1           log             stdin           ttyvb
ad3p1           cuau1.init      lpt0            stdout          ttyvc
ad3p2           cuau1.lock      lpt0.ctl        sysmouse        ttyvd
ad3p3           dcons           mdctl           ttyu0           ttyve
ada0            devctl          mem             ttyu0.init      ttyvf
ada0p1          devstat         midistat        ttyu0.lock      ugen0.1
ada0p2          dgdb            mixer0          ttyu1           ugen0.2
ada0p3          fd              mpt0            ttyu1.init      ugen0.3
atkbd0          fd0             nfslock         ttyu1.lock      ugen1.1
audit           fido            null            ttyv0           uhid0
bpf             geom.ctl        pass0           ttyv1           ums0
bpf0            gptid           pass1           ttyv2           urandom
bpsm0           io              pci             ttyv3           usb
[b]cd0[/b]             iso9660         ppi0            ttyv4           usbctl
console         kbd0            psm0            ttyv5           xpt0
consolectl      kbd1            ptmx            ttyv6           zero
ctty            kbdmux0         pts             ttyv7
cuau0           klog            random          ttyv8
cuau0.init      kmem            sndstat         ttyv9


My [FILE]/etc/fstab[/FILE]:
Code: Select all
freebsd# cat /etc/fstab
# Device        Mountpoint      FStype  Options Dump    Pass#
/dev/ada0p2     /               ufs     rw      1       1
/dev/ada0p3     none            swap    sw      0       0
olo
Junior Member
 
Posts: 13
Joined: 02 Mar 2012, 19:31
Location: KÅ‚odzko, PL

Postby Beastie » 02 Mar 2012, 20:15

Try passing it a filesystem argument:
[cmd=#]mount -t cd9660 /dev/cd0 /cdrom[/cmd]
May the source be with you!
Beastie
Senior Member
 
Posts: 1859
Joined: 28 Mar 2009, 11:27
Location: /dev/earth0

Postby olo » 02 Mar 2012, 20:20

Thank you very much it works :)
olo
Junior Member
 
Posts: 13
Joined: 02 Mar 2012, 19:31
Location: KÅ‚odzko, PL


Return to General

Who is online

Users browsing this forum: No registered users and 0 guests