USB KEyboard not working

Stuff that plugs in via USB, FireWire, eSATA, PS/2, etc.

USB KEyboard not working

Postby oliver@ » 13 Feb 2012, 11:10

Hi,

I'm unable to get my Logitech Gaming Keyboard G510 to work with FreeBSD 8. It is working in the beastie boot loader but after FreeBSD is booted up, everything seems to be f....ed up :(

Right now, I have the [FILE]atkbd[/FILE] stuff in [FILE]/boot/device.hints[/FILE] disabled as I thought, this might interfere with my USB Keyboard but it didn't change anything except that [FILE]/dev/atkbd0[/FILE] is now gone.

Code: Select all
root@kartoffel olivleh1> sysctl -a |grep kbd
hw.syscons.kbd_debug: 1
hw.syscons.kbd_reboot: 1
hw.usb.ukbd.no_leds: 0
hw.usb.ukbd.debug: 0
hw.kbd.keymap_restrict_change: 0
dev.ukbd.0.%desc: Logitech G510 Gaming Keyboard, class 0/0, rev 2.00/1.65, addr 2
dev.ukbd.0.%driver: ukbd
dev.ukbd.0.%location: bus=1 hubaddr=1 port=0 devaddr=2 interface=0
dev.ukbd.0.%pnpinfo: vendor=0x046d product=0xc22d devclass=0x00 devsubclass=0x00 sernum=""
 release=0x0165 intclass=0x03 intsubclass=0x01
dev.ukbd.0.%parent: uhub0
root@kartoffel olivleh1>


When I try to change the keyboard while being remotly logged in:

Code: Select all
root@kartoffel olivleh1> kbdcontrol -K < /dev/console
kbd1
    kbdmux0, type:AT 101/102 (2)
root@kartoffel olivleh1> kbdcontrol -i < /dev/console
kbd1:
    kbdmux0, type:AT 101/102 (2)
root@kartoffel olivleh1> kbdcontrol -A kbd1 < /dev/console
kbd1
    kbdmux0, type:AT 101/102 (2)
kbdcontrol: unable to (un)mux the keyboard: Device not configured
root@kartoffel olivleh1> kbdcontrol -k /dev/ukbd0 < /dev/console > /dev/null
kbdcontrol: cannot open /dev/ukbd0: Device busy
root@kartoffel olivleh1>


No idea what is going on here - shouldn't -[FILE]K[/FILE] detatch the keyboard? Why is it still attached with [FILE]-i[/FILE]? Does it reattach automatically, what the heck is [FILE]kbd1[/FILE] anyway?

[FILE]ukbd0[/FILE] is "linked" to [FILE]kbd2[/FILE]. But what is [FILE]kbd1[/FILE]?
oliver@
Junior Member
 
Posts: 65
Joined: 20 Feb 2008, 22:44
Location: Germany

Postby SirDice » 14 Feb 2012, 10:10

Make sure the BIOS is set to support "Legacy USB". That means the keyboard will appear as a 'regular' PS/2 keyboard.

My G110 works fine everywhere, except in the beasty menu. This seems to be BIOS related though, as the same keyboard works fine on another machine.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby oliver@ » 14 Feb 2012, 11:55

Hi,

Legacy USB is already enabled - otherwise I could not even select something in the Bootmanager (already tried "BIOS only"). The Keyboard is also detected by FreeBSD - it is not a matter of not being able to have it as a Keyboard... it is just, that everything done with kbdcontrol seems to be just not working... and so I can not use it and have to always attach a PS/2 Keyboard when working with FreeBSD.... argh.
oliver@
Junior Member
 
Posts: 65
Joined: 20 Feb 2008, 22:44
Location: Germany

Postby oliver@ » 24 Feb 2012, 06:49

Mh... so none got an idea?
Any idea how to proceed to get it working? Maybe ask on the ML? I could open a PR but I'd like to see a solution ;)
oliver@
Junior Member
 
Posts: 65
Joined: 20 Feb 2008, 22:44
Location: Germany


Return to Peripheral Hardware

Who is online

Users browsing this forum: No registered users and 0 guests