No sound in headphones

Having problems running your new shiny and blinking gadget or watching DVDs, listening to CDs etc.?

No sound in headphones

Postby cuq » 31 Jan 2012, 01:15

Hi, I was trying to figure out what is happening with my sound card but I couldn't discover how to solve this. I read the snd_hda man pages but I couldn't figure out what to do. Please if someone know what to do or have any ideas...

My system:
Code: Select all
FreeBSD ojosdelsalado 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:46:30 UTC
 2012     root@farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64

I have
Code: Select all
sound_enable="YES"
snd_hda_load="YES"

in [FILE]/boot/loader.conf[/FILE].
[FILE]/dev/sndstat[/FILE] has
Code: Select all
FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
Installed devices:
pcm0: <HDA ATI R6xx HDMI PCM #0 HDMI> (play)
pcm1: <HDA IDT 92HD81B1X PCM #0 Analog> (play/rec) default
pcm2: <HDA IDT 92HD81B1X PCM #1 Analog> (rec)

and here is my dmesg.boot with verbose output.

Now when I plug the headphones the speakers mute but no sound in the headphones... It would be nice to control the two volumens independently with the mixer, in my old netbook I could do this, I don't know however how or why that was possible.

Thank you very much.

cheers
cuq
ps. please excuse my poor English
cuq
Junior Member
 
Posts: 30
Joined: 22 Feb 2010, 04:11

Postby cuq » 02 Feb 2012, 13:05

Any idea? I have been trying many things but none of them seems to work. I can't hear any sound when the I plug the headphones, the computer spekers works fine and they mute when I plug the headphones but, as I said before, I get no sound from them...

thank you very much,

cheers
cuq
cuq
Junior Member
 
Posts: 30
Joined: 22 Feb 2010, 04:11

Postby LateNiteTV » 02 Feb 2012, 23:00

You may need to play with [FILE]device.hints[/FILE] or change [FILE]hw.snd.default_unit[/FILE]
[CMD=$]man snd_hda[/CMD]
LateNiteTV
Member
 
Posts: 391
Joined: 19 Nov 2008, 20:18
Location: palm springs

Postby bbzz » 03 Feb 2012, 15:08

It looks like the pins are correct but you never know.
I don't know... try using different configuration like this:

Code: Select all
hint.hdac.0.cad0.nid11.config="as=3 seq=15"
hint.hdac.0.cad0.nid13.config="as=3 seq=0"


in [FILE]/boot/device.hints[/FILE]

Also if you don't use external speakers but only headphones try turning speakers off with:

Code: Select all
hint.hdac.0.cad0.nid13.config="as=0 seq=0"


You could also turn everything off and then turn on one by one.

Read [man=4]snd_hda[/man]

Also make sure it's not something else (as trivial as turning on volume in headphones).
bbzz
Member
 
Posts: 858
Joined: 04 Nov 2010, 01:07
Location: random

Postby aragon » 03 Feb 2012, 21:16

You have 3 pcm units, and it looks like the second one is your analog output device. FreeBSD usually uses the first one by default, so try set pcm1 as your default unit:

[cmd=#]sysctl hw.snd.default_unit=1[/cmd]
aragon
Giant Locked
 
Posts: 2031
Joined: 16 Nov 2008, 17:04
Location: Cape Town, South Africa

Postby bbzz » 04 Feb 2012, 00:15

It already is, check post #1.
bbzz
Member
 
Posts: 858
Joined: 04 Nov 2010, 01:07
Location: random

Postby cuq » 05 Feb 2012, 01:50

Thanks to you all, I will try what bbzz says.


cheers
cuq
cuq
Junior Member
 
Posts: 30
Joined: 22 Feb 2010, 04:11


Return to Multimedia

Who is online

Users browsing this forum: No registered users and 1 guest