FreeBSD 9, disable ipv6

Network related discussions (including general TCP/IP stuff, routing, etc).

FreeBSD 9, disable ipv6

Postby DD » 19 Jan 2012, 10:18

How can I disable ipv6 on [del]FBSD[/del] FreeBSD 9?

I don't want the link-local on any interface, besides [FILE]ntpd[/FILE] seems not able to bind the ipv6 addresses giving me error during startup.
DD
Junior Member
 
Posts: 6
Joined: 19 Jan 2012, 10:11
Location: Milan, Italy

Postby SirDice » 19 Jan 2012, 10:27

Not sure if this is correct, the settings changed a lot compared to 8.x and I'm still adjusting myself.

/etc/rc.conf:
Code: Select all
ipv6_network_interfaces="none"    # Default is auto
ipv6_activate_all_interfaces="NO" # this is the default
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16153
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby DD » 19 Jan 2012, 10:31

SirDice wrote:Not sure if this is correct, the settings changed a lot compared to 8.x and I'm still adjusting myself.

[file]/etc/rc.conf[/file]:
Code: Select all
ipv6_network_interfaces="none"    # Default is auto
ipv6_activate_all_interfaces="NO" # this is the default


I've already tried that, it doesn't do the trick.
DD
Junior Member
 
Posts: 6
Joined: 19 Jan 2012, 10:11
Location: Milan, Italy

Postby DD » 19 Jan 2012, 10:57

The NTPd problem doesn't occur on the other server, so my fault I guess. Even though I did the same thing on both. Only difference is the fist is a virtual machine and the second one "physical". Anyway, still don't care for the ipv6 stuff. If someone knows how to disable it it'd be great.
DD
Junior Member
 
Posts: 6
Joined: 19 Jan 2012, 10:11
Location: Milan, Italy

Postby SirDice » 19 Jan 2012, 11:07

DD wrote:Anyway, still don't care for the ipv6 stuff.

You should. It won't be long until all IPv4 addresses are completely depleted.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16153
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby DD » 19 Jan 2012, 11:13

SirDice wrote:You should. It won't be long until all IPv4 addresses are completely depleted.


Those servers won't see any public IP, ever. :)

And to be totally honest I'm not skilled enough on ipv6 - yet - to risk using it in production environment when it's more the superfluous.
DD
Junior Member
 
Posts: 6
Joined: 19 Jan 2012, 10:11
Location: Milan, Italy

Postby SirDice » 19 Jan 2012, 11:21

DD wrote:And to be totally honest I'm not skilled enough on ipv6 - yet -

Neither was I but it never hurts to be prepared for the future. It'll also give you an edge over your colleagues as they will scramble to get educated when they're forced to migrate and you already know how it works ;)

to risk using it in production environment when it's more the superfluous.

Ah, yes, understandable.

Slightly offtopic, the 6th of June will be another IPv6 day. http://www.worldipv6day.org/
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16153
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby DD » 19 Jan 2012, 11:32

SirDice wrote:Neither was I but it never hurts to be prepared for the future. It'll also give you an edge over your colleagues as they will scramble to get educated when they're forced to migrate and you already know how it works ;)


Sure but I barely have the time to check on the new FreeBSD release, you know. It's merely a question of having the time to do a bit of studying.

SirDice wrote:Ah, yes, understandable.


And you know what? I'll stick with the 8.2 for now.
DD
Junior Member
 
Posts: 6
Joined: 19 Jan 2012, 10:11
Location: Milan, Italy

Postby phoenix » 19 Jan 2012, 15:36

[cmd=#]grep ipv6 /etc/defaults/rc.conf[/cmd]
Read the comments attached to those, and the [man=5]rc.conf[/man] man page for details.
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
User avatar
phoenix
MFC'd
 
Posts: 3349
Joined: 17 Nov 2008, 05:43
Location: Kamloops, BC, Canada

Postby DD » 19 Jan 2012, 15:45

phoenix wrote:[cmd=#]grep ipv6 /etc/defaults/rc.conf[/cmd]
Read the comments attached to those, and the [man=5]rc.conf[/man] man page for details.


That's the first thing I did, but I'm sure I missed something.
DD
Junior Member
 
Posts: 6
Joined: 19 Jan 2012, 10:11
Location: Milan, Italy

Postby bbzz » 19 Jan 2012, 16:02

Why not just rebuild kernel without IPv6?
bbzz
Member
 
Posts: 858
Joined: 04 Nov 2010, 01:07
Location: random

Postby phoenix » 19 Jan 2012, 16:29

This is how we do it on our 9.0 boxes:
Code: Select all
ip6addrctl_enable="NO"                  # New way to disable IPv6 support
ip6addrctl_policy="ipv4_prefer"         # Use IPv4 instead of IPv6
ipv6_activate_all_interfaces="NO"       # Do not automatically add IPv6 addresses


Guess you have to search for "ip6" as well as "ipv6".
Freddie

Help for FreeBSD: Handbook, FAQ, man pages, mailing lists.
User avatar
phoenix
MFC'd
 
Posts: 3349
Joined: 17 Nov 2008, 05:43
Location: Kamloops, BC, Canada

Postby Wout » 16 Apr 2012, 13:10

DD wrote:I don't want the link-local on any interface, besides ntpd seems not able to bind the ipv6 addresses giving me error during startup.


Setting
Code: Select all
ifconfig_bge0_ipv6="inet6 auto_linklocal"
in rc.conf (change bge0 to your interface) has fixed the ntpd warnings for me (9.0-RELEASE).

I would suggest NOT disabling the link-local IPv6 address when using a kernel with IPv6 support (GENERIC does), because this may result in unexpected behaviors of the kernel (see ifconfig(8) BUGS section). Even if you do not use IPv6 yet, you will eventually ;)
User avatar
Wout
Junior Member
 
Posts: 3
Joined: 14 Mar 2009, 11:17
Location: Belgium


Return to Networking

Who is online

Users browsing this forum: No registered users and 0 guests