Xorg freezes system. Configuration problem?

X.Org on FreeBSD installation & configuration.

Xorg freezes system. Configuration problem?

Postby RandicusDracoAlbus » 14 Dec 2011, 09:45

I have tried to install FreeBSD almost ten times, but have the same result every time. I install the complete system, including Xorg, with the installation DVD. I follow the instructions in the FreeBSD Handbook.

Code: Select all
hald enable=”YES”
dbus enable=”YES”


The first problem; [FILE]dbus enable=”YES”[/FILE] yields an error message saying it is an invalid command. The second problem; if I launch X with [FILE]startx[/FILE], I get a TWM GUI with three open tabs and an analogue clock. However, the system is completely frozen. Neither mouse nor keyboard work. The only thing I can do is shut off the computer with the off button. Perhaps related is that during installation, when testing the mouse it will not work with any protocol-hardware combination. But of course, the mouse works fine in CLI. Other threads concern X freezing after it has been running. My problem is that it freezes immediately. So my guess is, it has something to do with configuration.

I am not familiar with FreeBSD, but I am a Linux user, so I am familiar with the concept of configuration and like experimenting. Hence my stubborn multiple attempts to get FreeBSD working.

It is unlikely a hardware issue, since every Linux system I have tried works perfectly on my computer (in regards to hardware that is). I am using a four and a half-year old Lenovo lap-top and the video card has never been a problem with any operating system. Perhaps I missed it, but I do not see anything in the manual that requires complex configuration of Xorg before it can be used at least on a minimal level.

Although I am a Linux user, I am not a computer geek. Is there something simple I am over-looking? I doubt FreeBSD is terribly more difficult to install than Linux.

Any suggestions would be appreciated, because I really want to give FreeBSD try.
RandicusDracoAlbus
Junior Member
 
Posts: 8
Joined: 14 Dec 2011, 08:45
Location: China

Postby SirDice » 14 Dec 2011, 09:51

RandicusDracoAlbus wrote:
Code: Select all
hald enable=”YES”
dbus enable=”YES”

The first problem; dbus enable=”YES” yields an error message saying it is an invalid command.


There's supposed to be an underscore there, not a space.

Code: Select all
hald_enable="YES"
dbus_enable="YES"


The second problem; if I launch X with startx, I get a TWM GUI with three open tabs and an analogue clock. However, the system is completely frozen. Neither mouse nor keyboard work.

That's because [FILE]hald[/FILE] and [FILE]dbus[/FILE] aren't loaded. The system isn't "frozen", it just doesn't respond to keyboard or mouse input.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby RandicusDracoAlbus » 14 Dec 2011, 11:05

I am impressed with the quick response!

If [FILE]hald[/FILE] is enabled, why does it not load? What is the difference between between "enable" and "load"? Forgive me. I am used to Linux terminology.:r

Plus, when I attempt to configure, [FILE]hald[/FILE] enables, but [FILE]dbus[/FILE] does not. The handbook states that both dependencies are installed with Xorg.
RandicusDracoAlbus
Junior Member
 
Posts: 8
Joined: 14 Dec 2011, 08:45
Location: China

Postby kpa » 14 Dec 2011, 11:18

[FILE]/etc/rc.conf[/FILE] uses the
Code: Select all
*_enable="YES"
syntax for enabling services that have their startup scripts in [FILE]/etc/rc.d [/FILE] or [FILE]/usr/local/etc/rc.d[/FILE].

[FILE]/boot/loader.conf[/FILE] uses the
Code: Select all
*_load="YES"
syntax for instructing [man=8]loader[/man] to load kernel modules before the kernel gets launched on boot up.
kpa
MFC'd
 
Posts: 3395
Joined: 05 Jul 2010, 13:19
Location: People's Technocratic Republic of Finland

Postby SirDice » 14 Dec 2011, 11:20

RandicusDracoAlbus wrote:If hald is enabled, why does it not load?

It's not enabled. You have an error in your [file]rc.conf[/file].

What is the difference between between "enable" and "load"?

[file]*_enable[/file] is used in [file]/etc/rc.conf[/file], [file]*_load[/file] is used in [file]/boot/loader.conf[/file].

See [man=5]rc.conf[/man] and [man=5]loader.conf[/man].

Plus; when I attempt to configure, hald enables, but dbus does not. The handbook states that both dependencies are installed with Xorg.

On FreeBSD, anything you install will NOT be enabled. You need to enable things yourself.

[FILE]hald[/FILE] is depending on [FILE]dbus[/FILE], so [FILE]dbus[/FILE] must be started before [FILE]hald[/FILE].
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby RandicusDracoAlbus » 14 Dec 2011, 12:40

Thanks for the terminology clarification. That information will be very useful.
SirDice wrote:Hald is depending on dbus, so dbus must be started before hald.

I followed the order in the guide: [FILE]hald[/FILE], then [FILE]dbus[/FILE]. I have a feeling that is the simple thing I was missing. Thank you very much. I shall up-date this thread with notification of success or failure after I try to install FreeBSD again. Probably tomorrow.
RandicusDracoAlbus
Junior Member
 
Posts: 8
Joined: 14 Dec 2011, 08:45
Location: China

Postby wblock@ » 14 Dec 2011, 15:51

RandicusDracoAlbus wrote:Thanks for the terminology clarification. That information will be very useful.

I followed the order in the guide: hald, then dbus. I have a feeling that is the simple thing I was missing.


The order of the enable statements does not matter. All they do is set variable values.
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby RandicusDracoAlbus » 15 Dec 2011, 04:53

I installed FreeBSD again this afternoon. As usual, there was no difficulty enabling [FILE]hald[/FILE], but trying to enable [FILE]dbus[/FILE] generates "command not found." Running
[cmd=]Xorg -configure[/cmd]
yields
Code: Select all
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
My hardware is detected, but the end of the configuration report says,
Code: Select all
Failed to load DMI info, X60 TV quirk not applied
Still an unresponsive display, but at least now I can return to the CLI with ctrl+alt+F1.:\

As much as I would like to try out FreeBSD and compare it to my GNU-Linux system, I think I am not enough of a computer geek to use it.:(
RandicusDracoAlbus
Junior Member
 
Posts: 8
Joined: 14 Dec 2011, 08:45
Location: China

Postby wblock@ » 15 Dec 2011, 05:07

RandicusDracoAlbus wrote:I installed FreeBSD again this afternoon. As usual, there was no difficulty enabling hald, but trying to enable dbus generates "command not found."


The exact error message in context would be helpful. Normally that kind of error would not come from [file]/etc/rc.conf[/file].

As much as I would like to try out FreeBSD and compare it to my GNU-Linux system, I think I am not enough of a computer geek to use it.:(


Consider PC-BSD.
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby RandicusDracoAlbus » 15 Dec 2011, 05:43

I have tried PCBSD. The problem is the internet connection. I configure it, what should be properly, but it does not work. IP, DNS and Gateway are all correct. The system says the connection is active, but it actually is not. It is either a difficulty with the domain entry or PCBSD does not like my hardware. I have no trouble manually configuring my internet connection with Linux systems.

It is difficult to judge the quality of BSD with the standard PCBSD, because the only GUI is Kde, which is slow on every system. And one of Kde's bugs displays the wrong time and will not allow it to be corrected. (I learned about the bug on PCBSD's forum.)
RandicusDracoAlbus
Junior Member
 
Posts: 8
Joined: 14 Dec 2011, 08:45
Location: China

Postby akregator » 15 Dec 2011, 08:17

You must launch [FILE]dbus[/FILE] before [FILE]hald[/FILE], [FILE]hal[/FILE] needs [FILE]dbus[/FILE]. I never saw [FILE]hal[/FILE] work without [FILE]dbus[/FILE].
akregator
Junior Member
 
Posts: 36
Joined: 15 Jun 2011, 16:27
Location: France

Postby RandicusDracoAlbus » 15 Dec 2011, 10:21

akregator wrote:You must launch dbus before hald, hal needs dbus. I never saw hal work without dbus.

And what about this answer?
wblock@ wrote:The order of the enable statements does not matter. All they do is set variable values.

:\
Hopefully I can try configuring in the opposite order without having to re-install. But then even that would only be a minor annoyance. Whether a standard installation only uses a small number of the files on the DVD or because FreeBSD is very efficient, it installs in a short time.:e
RandicusDracoAlbus
Junior Member
 
Posts: 8
Joined: 14 Dec 2011, 08:45
Location: China

Postby SirDice » 15 Dec 2011, 10:30

The order in [file]rc.conf[/file] doesn't matter, the daemons will always be started in the correct order.

If you start the services by hand [FILE]dbus[/FILE] must be started before [FILE]hald[/FILE].
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby SNK » 15 Dec 2011, 10:47

Some other points.

First, as a desktop user, do not install packages from the install medium. Those are old.

Second, you do not install a desktop environment or window manager?

Third, [PORT]x11/xorg[/PORT] is a pain to configure, especially the first time. It involves a lot of trial and error and some headaches. But once it works you will think it all worth it.
SNK
Member
 
Posts: 130
Joined: 15 May 2011, 18:34
Location: The Netherlands

Postby RandicusDracoAlbus » 16 Dec 2011, 04:10

SNK wrote:Second, you do not install a desktop environment or window manager?
Third, [PORT]x11/xorg[/PORT] is a pain to configure, especially the first time. It involves a lot of trial and error and some headaches. But once it works you will think it all worth it.


Whether I install Gnome and Metacity or only Metacity, has made no difference. This time I installed Gnome just to be on the safe side. I have also passed the [FILE]dbus[/FILE] hurdle. Trying to enable it has always resulted in "Command not found," but this time it was successful, but TWM is still unresponsive. The only thing I did differently was enter the enable commands as user instead of root, but I doubt that was the solution. At any rate, you appear to be correct. I am discovering the trials and errors.

I then ran
[cmd=]Xorg -configure[/cmd]
As the handbook warns may happen, I got a black screen that makes discerning anything difficult. When I returned to the CLI the report said:

Code: Select all
Failed to load DMI info, X60 TV quirk not applied.
drm0: <Intel i945GM> on vgapci0
vgapci0: child drm0 requested pci_enable_busmaster
info: [drm] AGP at 0x0000000 256MB
info: [drm] Initialized i915 1.6.0 20080730
Setting master
drm0: [I THREAD]
record: RECORD extension enabled at configuration time.
record: This extension is known to be broken, disabling extension now..
record: http//bugs.freedesktop.org/show_bug.cgi?id=20500
Dropping master


I could easily be wrong, but I interpret this to mean that either: there is a bug in the Xorg programme on the DVD; or FreeBSD does not like my hardware, which is unlikely, since PCBSD has no problem with the hardware and PCBSD is FreeBSD with pre-loaded packages. So I am probably interpreting the report incorrectly.
RandicusDracoAlbus
Junior Member
 
Posts: 8
Joined: 14 Dec 2011, 08:45
Location: China

Postby wblock@ » 16 Dec 2011, 19:05

If PCBSD runs correctly, boot the live DVD and copy the [file]xorg.conf[/file] it generates. Then use that in FreeBSD.
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy


Return to X.Org

Who is online

Users browsing this forum: No registered users and 1 guest