nvidia driver

Having problems running your new shiny and blinking gadget or watching DVDs, listening to CDs etc.?

nvidia driver

Postby trucker » 27 Nov 2011, 23:18

Hello and thanks for looking. I've just installed FreeBSD 8.2. But I am lost as how to setup nvidia-driver. It's started by [FILE]kldload[/FILE] and shows with [FILE]kldstat[/FILE] as [FILE]nvidia.ko[/FILE]. Linux emulator is also showing as [FILE]linux.ko[/FILE].

Now my next step was to try to get them to auto start so far its not doing this. And I don't know if I am even heading in the right direction.
I am not good with command line, I can do what I see others say to do, but as far as knowing why or the next step I am lost. I have been reading posts and have both KDE4 and Gnome up and on line. But that's about it. No sound, no nvidia, no flashplayer.

Again thanks if anyone can help me get this OS working.
trucker
Junior Member
 
Posts: 2
Joined: 21 Nov 2011, 08:16
Location: USA

Postby bigtoque » 28 Nov 2011, 05:13

Did you install the driver through ports or did you just download the driver from the nVidia website?

You likely need to add:

Code: Select all
Driver "nvidia"


to the "Device" section of your [FILE]/etc/X11/xorg.conf[/FILE].


Mine looks like this after using the driver from ports:
Code: Select all
Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "GF104 [GeForce GTX 460]"
        BusID       "PCI:1:0:0"
EndSection


This page tells you how to get flash working:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/desktop-browsers.html

This page tells you how to get your sound working:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/sound-setup.html
bigtoque
Junior Member
 
Posts: 75
Joined: 16 Jul 2010, 05:55

Postby SirDice » 28 Nov 2011, 06:59

trucker wrote:I've just installed FreeBSD 8.2. But I am lost as how to setup nvidia-driver. It's started by [FILE]kldload[/FILE] and shows with [FILE]kldstat[/FILE] as [FILE]nvidia.ko[/FILE]. Linux emulator is also showing as [FILE]linux.ko[/FILE].

Now my next step was to try to get them to auto start so far its not doing this. And I don't know if I am even heading in the right direction.

Add to [file]/boot/loader.conf[/file]:
Code: Select all
nvidia_load="YES"


See [man=5]loader.conf[/man].
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16156
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby trucker » 03 Dec 2011, 16:23

bigtoque wrote:Did you install the driver through ports or did you just download the driver from the nVidia website?

You likely need to add:

Code: Select all
Driver "nvidia"


to the "Device" section of your [FILE]/etc/X11/xorg.conf[/FILE].


Mine looks like this after using the driver from ports:
Code: Select all
Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "GF104 [GeForce GTX 460]"
        BusID       "PCI:1:0:0"
EndSection


This page tells you how to get flash working:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/desktop-browsers.html

This page tells you how to get your sound working:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/sound-setup.html


I used ports
trucker
Junior Member
 
Posts: 2
Joined: 21 Nov 2011, 08:16
Location: USA

Postby Dru » 04 Dec 2011, 00:37

Installing [port]x11/nvidia-xconfig[/port] and [port]x11/nvidia-settings[/port] should be of some help to you, I would imagine. That is if you haven't already. Pretty much makes it cake.

nvidia-setup
User avatar
Dru
Member
 
Posts: 186
Joined: 27 Sep 2009, 23:57


Return to Multimedia

Who is online

Users browsing this forum: No registered users and 0 guests