install 32bit NVIDIA driver on 64bit PC-BSD

Internal storage, motherboards, PCI cards, stuff inside the case.

install 32bit NVIDIA driver on 64bit PC-BSD

Postby grigorovl » 24 Sep 2011, 19:46

I am writing here as these forums are more active. I am using PC-BSD 9.0-BETA2 64bit. It came with the 280v of the 64bit NVIDIA driver. Can someone tell me how I can install the 32bit NVIDIA driver alongside with the 64bit one?


Steam currently works, downloads games, but on launch is stuck on "Launching so and so game..." for about 4 min then nothing happens. In order to get Steam games working, since Wine is 32bit, I need a 32bit NVIDIA driver alongside. This has been documented in many places, including the FreeBSD wiki for wine

3D acceleration is working with the 64bit nvidia driver provided that you install the 32bit version (same version number) into the chroot (tested with World of Warcraft, 8.0-RELEASE).

Can someone clarify how to do that? The current driver I have is v280 64bit.

Cheers.
grigorovl
Junior Member
 
Posts: 58
Joined: 02 Mar 2010, 01:27
Location: California, USA

Postby demo » 25 Sep 2011, 01:58

Did you setup a chroot for 32-bit binaries?
http://wiki.freebsd.org/Wine#Wine_on_FreeBSD.2BAC8-amd64

If you did, chroot back into the 32-bit system as in the instructions on that page, then instead of
Code: Select all
cd /usr/ports/emulators/wine && make install clean


You would use this to install the 32bit nvidia driver
Code: Select all
cd /usr/ports/x11/nvidia-driver && make install clean
User avatar
demo
Junior Member
 
Posts: 16
Joined: 02 Aug 2010, 20:33

Postby rusty » 25 Sep 2011, 06:45

Or, you could use the pre-built packages from http://people.freebsd.org/~ivoras/wine/
there's a script there for installing the nvidia 32-bit driver.
rusty
Member
 
Posts: 251
Joined: 03 Jan 2010, 09:09
Location: South West UK

Postby grigorovl » 26 Sep 2011, 06:20

I did that, I am running his 64bit wine pkg, I have a native 64bit NVIDIA v280 and his script installed the 32bit NVIDIA v280. I installed Steam through winetricks and configured everything as per the page, but I still cannot get Team Fortress 2 to launch. Strangely enough, Portal launches and works. I cannot isolate if it's a 64bit problem or it's elsewhere.
grigorovl
Junior Member
 
Posts: 58
Joined: 02 Mar 2010, 01:27
Location: California, USA


Return to System Hardware

Who is online

Users browsing this forum: No registered users and 1 guest