FSCK: cannot determine filesystem type (6.2->8.2)

General questions about the FreeBSD operating system. Ask here if your question does not fit elsewhere.

FSCK: cannot determine filesystem type (6.2->8.2)

Postby monkeyboy » 30 Jun 2011, 06:44

I converted a FreeBSD 6.2 system to 8.2, with a couple of data drives that supposedly would "move over". However I found that [FILE]bsdlabel[/FILE] complained about the partitioning of these drives and then [FILE]fsck[/FILE] reported
Code: Select all
cannot determine filesystem type
Got me a little worried that 8.2 couldn't read these drives/filesystems from 6.2.

As it turns out, running [FILE]fsck_ffs[/FILE] instead worked fine and the drives mounted okay. I gather that between 6.2 and 8.2, [FILE]fsck[/FILE] tried to get "smarter" but not smart enough to figure out to use [FILE]fsck_ffs[/FILE] with these drives. Also the use of the 'c' partition is now (weakly) prohibited.

It would be nice to be able to "restore" 8.2 [FILE]fsck[/FILE]'s ability to realize that these are FFS filesystems. Any clues as to how? (I guess I could read the code to see what it is trying to test.)
monkeyboy
Junior Member
 
Posts: 90
Joined: 21 Apr 2009, 17:36

Postby graudeejs » 30 Jun 2011, 09:30

Use the [FILE]-t[/FILE] flag.

[CMD="$"]fsck -t ufs /dev/da0[/CMD]
(Don't remember if ufs was in lowercase or uppercase, probably lowercase)
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby acheron » 30 Jun 2011, 11:52

acheron
Junior Member
 
Posts: 92
Joined: 18 Aug 2010, 11:37
Location: France

Postby monkeyboy » 30 Jun 2011, 17:36

Thanks, I get it now, although not sure why [FILE]dumpfs[/FILE] can figure these things out, but [FILE]fsck[/FILE] needs to look in [FILE]fstab[/FILE] when a filesystem may very well not be in there. I guess you could argue the read vs read/write/destroy issue, but presuming that [FILE]fstab[/FILE] is actually correct doesn't seem much better.
monkeyboy
Junior Member
 
Posts: 90
Joined: 21 Apr 2009, 17:36

Postby tingo » 02 Jul 2011, 23:05

Yes, it is a bit annoying that [FILE]fsck[/FILE] in 8.2 (or perhaps this started in 8.1, I don't remember) can't figure this out on its own, while it did in all previous releases. It could be argued that this change is a POLA violation, too.
Torfinn
tingo
Member
 
Posts: 946
Joined: 16 Nov 2008, 22:02
Location: Oslo, Norway


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest