Trouble with Realtek NIC

Internal storage, motherboards, PCI cards, stuff inside the case.

Trouble with Realtek NIC

Postby ablmf » 30 Mar 2011, 16:10

I just installed FreeBSD on my new Dell laptop. And I found the system could not recognize my NIC.

The out put of [FILE]ifconfig[/FILE] is like this :

Code: Select all
lo0: flags=......


There's only [FILE]lo0[/FILE].

But [FILE]pciconf -lv[/FILE] shows that there is a driver for my NIC:

Code: Select all
re0@pci0:3:0:0: class=0x02000 ...
vendor = 'Realtk Semiconductor'
device = 'Realtke 10/10/100 ......
class = network
subclass = ethernet


How can I fix this? A laptop without internet is really useless.
ablmf
Junior Member
 
Posts: 2
Joined: 30 Mar 2011, 16:04

Postby ablmf » 30 Mar 2011, 16:23

OK, I found perhaps it's the problem of re(4) driver : http://forums.freebsd.org/showthread.php?t=21748

Maybe I should try FreeBSD after next version is released.
ablmf
Junior Member
 
Posts: 2
Joined: 30 Mar 2011, 16:04

Postby gkontos » 30 Mar 2011, 20:46

ablmf wrote:OK, I found perhaps it's the problem of re(4) driver : http://forums.freebsd.org/showthread.php?t=21748

Maybe I should try FreeBSD after next version is released.

You can apply the patch with a usb drive or wait for the next snapshot of stable.
Powered by BareBSD
User avatar
gkontos
Senior Member
 
Posts: 1370
Joined: 09 Dec 2009, 08:36
Location: Polidendri, GR


Return to System Hardware

Who is online

Users browsing this forum: No registered users and 2 guests