No sound on 8.2

Having problems running your new shiny and blinking gadget or watching DVDs, listening to CDs etc.?

No sound on 8.2

Postby z662 » 02 Mar 2011, 02:29

I recently installed 8.2 and can not get sound to work. I am running a Toshiba Satellite L675D. The output of [cmd=]cat /dev/sndstat[/cmd] are:

Code: Select all
FreeBSD Audio Driver (newpcm: 32bit 2009061500/i386)
Installed devices:
pcm0: <HDA ATI RS690/780 HDMI PCM #0 HDMI> (play) default
pcm1: <HDA Realtek ALC269 PCM #0 Analog> (play/rec)
pcm2: <HDA Realtek ALC269 PCM #1 Analog> (rec)

It may be worth mentioning that when I boot up KDE I get an error message asking if I want to permanently forget about these devices. Obviously the hardware is being picked up but I believe I am loading the wrong kernel modules. I am not sure how to fix this. Any help would be greatly appreciated. Thanks in advance.
User avatar
z662
Member
 
Posts: 188
Joined: 18 Mar 2009, 00:54
Location: Pittsburgh, PA

Postby wblock@ » 02 Mar 2011, 03:16

It's not the wrong kernel modules, it's using the sound output on your HDMI video card by default. Just change that and it should be fine:
[file]/boot/loader.conf[/file]
Code: Select all
hw.snd.default_unit="1"
User avatar
wblock@
Old Fart
 
Posts: 10204
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby z662 » 02 Mar 2011, 03:59

Thanks for the reply. I added that line to my [FILE]loader.conf[/FILE] and now see that the analog device is my default after rebooting. Unfortunately I still have no sound though.

After going into the OSS Audio Mixer in KDE I see that there are three devices called "OSS Audio Mixer" I have turned all of them all of the way up and also see options for selecting the master channel. "Volume" was selected by default and I changed it to 'PCM' but to no avail.
User avatar
z662
Member
 
Posts: 188
Joined: 18 Mar 2009, 00:54
Location: Pittsburgh, PA

Postby wblock@ » 02 Mar 2011, 06:26

Look at a lower level:
[cmd="#"]mixer vol 75[/cmd]
User avatar
wblock@
Old Fart
 
Posts: 10204
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby z662 » 02 Mar 2011, 21:21

Still no go. Something is telling me that KDE shouldn't be thinking that my sound devices were removed. Also note that I tried to play an mp3 file via mplayer on the command line prior to starting KDE. Does the output from [FILE]/dev/sndstat[/FILE] mean that I am definitely loading all the required kernel modules and therefore just do not have something configured properly?
User avatar
z662
Member
 
Posts: 188
Joined: 18 Mar 2009, 00:54
Location: Pittsburgh, PA

Postby wblock@ » 03 Mar 2011, 00:35

Yes, you have the right module loaded. It found the hardware and created [file]/dev/dsp[/file].

No idea what KDE does with sound. The Handbook recommends testing by dumping a binary file to [file]/dev/dsp[/file]:
[cmd="#"]cat [file]filename[/file] > /dev/dsp[/cmd]
User avatar
wblock@
Old Fart
 
Posts: 10204
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby z662 » 03 Mar 2011, 02:53

I just tried doing the above with an mp3 and still no luck. Do you think I am using an incorrect mixer? I have tried all of them though...no idea on what to do at this point. Would posting my rc.conf and/or loader.conf help at all?
User avatar
z662
Member
 
Posts: 188
Joined: 18 Mar 2009, 00:54
Location: Pittsburgh, PA

Postby z662 » 03 Mar 2011, 03:24

I was able to get my sound working! My [FILE]/boot/loader.conf[/FILE] now appears as follows:

Code: Select all
sound_load="YES"
snd_uaudio_load="YES"
hw.snd.default_unit="1"
snd_hda_load="YES"



Thanks again for your help wblock
User avatar
z662
Member
 
Posts: 188
Joined: 18 Mar 2009, 00:54
Location: Pittsburgh, PA


Return to Multimedia

Who is online

Users browsing this forum: No registered users and 0 guests