FreeBSD gnome under vmware-player - not working again

X.Org on FreeBSD installation & configuration.

FreeBSD gnome under vmware-player - not working again

Postby choudharypranay » 23 Dec 2010, 08:26

i'm using vmware-player 3.1.3
FreeBSD 8.1

this is what i did:
1. installed FreeBSD minimal.
while selecting packages, i choosed everything under gnome and installed.
2. [FILE]pkg_add -v -r compat6x-i386[/FILE] (required for vmware tools)
3. [FILE]./vmware-install.pl[/FILE] (installed vmware tools)
4. in [FILE]/etc/rc.conf[/FILE]: [FILE]gnome_enable="YES"[/FILE]
5. in [FILE]/etc/fstab[/FILE]: [FILE]proc /proc procfs rw 0 0[/FILE]
6. [FILE]pkg_add xf86-input-vmmouse[/FILE]
7. in [FILE]/etc/X11/xorg.conf[/FILE]: [FILE]Option "AutoAddDevices" "off"[/FILE]



my mouse and keyboard is detected in text mode. but not in X mode.
tried all forums, but no solution worked for me.

this is my [FILE]/etc/rc.conf[/FILE]
Code: Select all
# -- sysinstall generated deltas -- # Wed Dec 22 21:37:12 2010
# Created: Wed Dec 22 21:37:12 2010
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
hostname="gnome-bsd.blr.global.com"
#ifconfig_em0="DHCP"
keymap="us.iso"
moused_enable="YES"
sshd_enable="YES"
ifconfig_em0="inet 192.168.16.24 netmask 255.255.255.0"
defaultrouter="192.168.16.1"
gnome_enable="YES"
dbus_enable="YES"


this is my /etc/X11/xorg.conf
Code: Select all
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
  Option "DontZap"         "off"
  Option "AllowEmptyInput" "off"
  Option "AutoAddDevices"  "off"
EndSection

Section "Files"
   ModulePath   "/usr/local/lib/xorg/modules"
   FontPath     "/usr/local/lib/X11/fonts/misc/"
   FontPath     "/usr/local/lib/X11/fonts/TTF/"
   FontPath     "/usr/local/lib/X11/fonts/OTF"
   FontPath     "/usr/local/lib/X11/fonts/Type1/"
   FontPath     "/usr/local/lib/X11/fonts/100dpi/"
   FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
   Load  "dbe"
   Load  "dri"
   Load  "dri2"
   Load  "extmod"
   Load  "glx"
   Load  "record"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/sysmouse"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "HWcursor"              # [<bool>]
        #Option     "Xinerama"              # [<bool>]
        #Option     "StaticXinerama"        # <str>
   Identifier  "Card0"
   Driver      "vmware"
   VendorName  "VMware"
   BoardName   "SVGA II Adapter"
   BusID       "PCI:0:15:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection



this is my x-server log:
Code: Select all
........
.........
(II) AIGLX: Loaded and initialized /usr/local/lib/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0
(II) LoadModule: "mouse"
(WW) Warning, couldn't open module mouse
(II) UnloadModule: "mouse"
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) No input driver matching `mouse'
(II) LoadModule: "kbd"
(WW) Warning, couldn't open module kbd
(II) UnloadModule: "kbd"
(EE) Failed to load module "kbd" (module does not exist, 0)
(EE) No input driver matching `kbd'
(II) config/hal: Adding input device AT Keyboard
(II) AutoAddDevices is off - not adding device.
(EE) config/hal: NewInputDeviceRequest failed (8)
(II) config/hal: Adding input device PS/2 Mouse
(II) AutoAddDevices is off - not adding device.
(EE) config/hal: NewInputDeviceRequest failed (8)


my input devices are not detected. what can i do?
thanks in advance
choudharypranay
Junior Member
 
Posts: 15
Joined: 18 Dec 2010, 01:26

Postby SirDice » 23 Dec 2010, 10:50

You need to add [port]x11/xorg[/port] or [port]x11/xorg-minimal[/port] too. Gnome only depends on bits and pieces of Xorg and thus won't install a working Xorg.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16182
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby wblock@ » 23 Dec 2010, 14:15

choudharypranay wrote:7. in /etc/X11/xorg.conf: Option "AutoAddDevices" "off"


Please stop doing that. Please tell whoever advised it that it's wrong and should be corrected: AllowEmptyInput, FreeBSD, and Xorg Input
User avatar
wblock@
Old Fart
 
Posts: 10199
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby choudharypranay » 24 Dec 2010, 00:22

SirDice wrote:You need to add x11/xorg or x11/xorg-minimal too.

While installing i checked the X11 packages. Almost all packages were added under dependencies. Anyways I've add the package X11 again and try.
choudharypranay
Junior Member
 
Posts: 15
Joined: 18 Dec 2010, 01:26

Postby choudharypranay » 24 Dec 2010, 00:56

SirDice wrote:You need to add [port]x11/xorg[/port] or [port]x11/xorg-minimal[/port] too. Gnome only depends on bits and pieces of Xorg and thus won't install a working Xorg.


[CMD=" "]#pkg_add -v -r xorg[/CMD]

worked perfectly fine. Solution was so simple, i feel so stupid now.
Thanks a lot.
choudharypranay
Junior Member
 
Posts: 15
Joined: 18 Dec 2010, 01:26

Postby choudharypranay » 24 Dec 2010, 13:53

For newbies like me.... this is what I did to have Gnome running on freebsd installed in vmware-player 3.1.3

Code: Select all
0.   While installing FreeBSD-8.1, make sure that:
   a. You have enabled your mouse configuration
   b. You have selected the gnome packages that you require
   c. you have created one user (other than root).

1.   Installing VMWARE Drivers.
   a.   Install VmWare tools dependency:
      pkg_add -v -r compat6x-i386 (required for vmware tools)
   
   b.   Install VmWare Tools (also requires perl, if not installed use: pkg_add -v -r perl)
      VMWARE MENU -> VM -> INSTALL VMWARE TOOLS
      mount /cdrom/
      cd /cdrom/
      cp * /tmp/
      cd /tmp/
      tar zxpf vmware-freebsd-tools.tar.gz
      cd vmware-tools-distrib
      ./vmware-install.pl

   c.   Install VmWare Driver for Mouse
      pkg_add xf86-input-vmmouse

2.   add these lines in /etc/rc.conf:
   dbus_enable="YES"
   gnome_enable="YES"

3.   add this line in /etc/fstab:
   proc /proc procfs rw 0 0

4.   install x-window server:
   #pkg_add -v -r xorg

5.   #reboot: you are good to go.
choudharypranay
Junior Member
 
Posts: 15
Joined: 18 Dec 2010, 01:26


Return to X.Org

Who is online

Users browsing this forum: No registered users and 0 guests