[PC-BSD] Broadcom wireless on Dell doesn't turn on.

This forum discusses issues related to running FreeBSD on notebooks, laptops, and other mobile equipment.

[PC-BSD] Broadcom wireless on Dell doesn't turn on.

Postby nemirst » 07 Dec 2010, 18:22

Hi folks,

Just started using Unix-type OS few days ago and now I have one problem. I can't get wireless device turning on (led is switched off) even though it's working on Windows. OS installed is PCBSD 8.1 so there should be no difference compared to FreeBSD. I have some kind of Dell mini wireless card (it must be Broadcom). Please tell me how to get more accurate information in terminal and I'll provide you with it if you need. For reference I used some parts of FreeBSD handbook.

Here's what I tried:
* Added [FILE]if_bwn_load="YES"[/FILE] to [FILE]/boot/loader.conf[/FILE].
* Did "[FILE]make install clean[/FILE]" inside [FILE]/usr/ports/net/bwn-firmware-kmod[/FILE] directory
* reboot
* [FILE]ifconfig wlan0 create wlandev bwn0[/FILE]
* [FILE]ifconfig wlan0 up scan[/FILE]

Tried also bwi instead of bwn with no success.

What should I do to make my wireless work?
nemirst
Junior Member
 
Posts: 7
Joined: 07 Dec 2010, 17:10

Postby richardpl » 07 Dec 2010, 19:03

Add bwn firmware to loader.conf
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby DutchDaemon » 07 Dec 2010, 19:07

nemirst wrote:OS installed is PCBSD 8.1 so there should be no difference compared to FreeBSD.


That's a risky misconception, so beware of advice.
User avatar
DutchDaemon
Old Fart
 
Posts: 10466
Joined: 16 Nov 2008, 20:17
Location: The Netherlands

Postby nemirst » 07 Dec 2010, 19:29

richardpl wrote:Add bwn firmware to loader.conf


I did it now I guess. Added
Code: Select all
bwn_v4_ucode_load="YES"
to [FILE]/boot/loader.conf[/FILE].
Tried also manual load of module after reboot [CMD=" "]kldload bwn_v4_ucode[/CMD] and got message:
Code: Select all
kldload: can't load bwn_v4_ucode: File exists

Which should mean that module is really loaded. Wifi is still not working, led turned off.
nemirst
Junior Member
 
Posts: 7
Joined: 07 Dec 2010, 17:10

Postby richardpl » 07 Dec 2010, 21:01

Is there hardware switch somewhere?

Anythin displayed in dmesg(8)
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby joag » 07 Dec 2010, 21:16

This is how I did it under FreeBSD 7 http://nixheiser.info/Projects.html, FreeBSD-8 changed things slightly, but here http://www.freebsd.org/doc/handbook/network-wireless.html is all the info you need, reading this section in the handbook and with the example in my site I think you should be able to have this wireless card working.

BTW check if you chipset is supported otherwise it won't work unless you use ndiswrapper.
joag
joag
Junior Member
 
Posts: 39
Joined: 28 May 2010, 14:16
Location: Panama

Postby richardpl » 07 Dec 2010, 21:54

BTW check if you chipset is supported otherwise it won't work unless you use NDISulator.


There, fixed it for ya.
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby joag » 07 Dec 2010, 22:02

richardpl wrote:There, fixed it for ya.


:D exactly, that was the idea :p
joag
joag
Junior Member
 
Posts: 39
Joined: 28 May 2010, 14:16
Location: Panama

Postby nemirst » 09 Dec 2010, 17:55

richardpl wrote:Is there hardware switch somewhere?

Anythin displayed in dmesg(8)

Thanks for mentioning this useful command. I see some interesting lines now:
Code: Select all
need multicast update callback
need multicast update callback
bwn_v4_lp_ucode15: could not load firmware image, error 2
bwn-open_v4_lp_ucode15: could not load firmware image, error 2

But there is also line in [FILE]/boot/loader.conf[/FILE] which should load these firmware images:
Code: Select all
if_bwn_load="YES"
bwn_v4_ucode_load="YES"


I will try http://forums.freebsd.org/showpost.php?p=113500&postcount=227 solution but it seems like a silly workaround.

joag wrote:FreeBSD-8 changed things slightly, but here http://www.freebsd.org/doc/handbook/network-wireless.html is all the info you need, reading this section in the handbook and with the example in my site I think you should be able to have this wireless card working.

Yes, thanks I already read first sections which are more firmware/driver related.


By the way, I switched to FreeBSD 8.1 x86.
nemirst
Junior Member
 
Posts: 7
Joined: 07 Dec 2010, 17:10

Postby nemirst » 11 Dec 2010, 12:21

I now switched to Ndisulator and configured system using this guide: http://www.freebsd.org/doc/handbook/config-network-setup.html.
When I load wireless module manually all works fine but when it's started automatically at boot adding line
Code: Select all
bcmwl5_sys_load="YES"
to [FILE]/boot/loader.conf[/FILE] system crashes showing page fault and offers only to restart. I had to use FreeBSD installation disk to fix system modifying [FILE]loader.conf[/FILE]. Is there any way to start module automatically?
Also wireless hardware led is disabled but [CMD="dhclient"]wlan0[/CMD] works just fine when loading module manually.
nemirst
Junior Member
 
Posts: 7
Joined: 07 Dec 2010, 17:10

Postby richardpl » 11 Dec 2010, 19:32

Why are you trying to load module via loader.conf?

Just stop doing that.

You do not need to use install cd to unload module from loader prompt.

For more info about NDISulator follow this thread:
http://forums.freebsd.org/showthread.php?t=9204
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby nemirst » 11 Dec 2010, 20:48

I'm loading module via loader.conf because I want it to load automatically at startup and that's what is said if you follow that link I posted before:
You can configure the system to load the NDIS modules at boot time in the same way as with any other module. First, copy the generated module, W32DRIVER_SYS.ko, to the /boot/modules directory. Then, add the following line to /boot/loader.conf:

Why shouldn't I follow handbook? Could be I understood incorrectly what was written in it...

How do I unload module otherwise? I couldn't access commandline before that restart. Was there any secret key combination?
nemirst
Junior Member
 
Posts: 7
Joined: 07 Dec 2010, 17:10

Postby richardpl » 11 Dec 2010, 21:45

Information in handbook was never correct. You was very lucky if you ever got ndis modules to not crash during boot.

Nothing is really secret. From loader prompt/bootloader menu you type unload, this will unload all modules
now you just type boot command and/or load modules you really want via load command.
This and the others is explained in various manual pages.

You can load modules after boot via rc.local and many other options...
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby nemirst » 12 Dec 2010, 16:59

Tried older Broadcom driver and it loaded successfully at startup. One more thing is left. Interface is not getting ip by DHCP automatically at startup. I have to type manually:[CMD="dhclient"]wlan0[/CMD]
That's only command necessary and wireless is working.
Wireless entries in [FILE]/etc/rc.conf[/FILE]:
Code: Select all
wlans_ndis0="wlan0"
ifconfig_wlan0="WPA DHCP"
nemirst
Junior Member
 
Posts: 7
Joined: 07 Dec 2010, 17:10

Postby richardpl » 12 Dec 2010, 17:08

Use SYNCDHCP.
richardpl
Member
 
Posts: 841
Joined: 17 Nov 2008, 17:02
Location: Croatia

Postby nemirst » 12 Dec 2010, 17:10

I just wanted to make post here about solution found here: http://forums.freebsd.org/showpost.php?p=109410&postcount=8

Thanks again!
nemirst
Junior Member
 
Posts: 7
Joined: 07 Dec 2010, 17:10


Return to Mobile Computing

Who is online

Users browsing this forum: No registered users and 0 guests