Using samba4-devel

Discussion related to network/web services such as Apache, BIND Sendmail, etc.

Using samba4-devel

Postby Johnny2Bad » 10 Nov 2010, 23:04

I finally got gnome going and it installed samba4-devel. But how do you start it?

I tried
[CMD=""]smbclient[/CMD]
and
[CMD=""]samba[/CMD]
to start the thing. But in both cases I get a
[CMD=""]Command not found[/CMD] message.
I also have
[CMD=""]samba_enabled="YES"[/CMD]
in my /etc/rc.conf file but nothing.

Any help would be much appreciated,
Jonathan.
Johnny2Bad
Junior Member
 
Posts: 83
Joined: 02 Nov 2010, 01:32

Postby DutchDaemon » 11 Nov 2010, 00:12

Look at the start scripts in [file]/usr/local/etc/rc.d/[/file], and run them with 'start' behind them, e.g.

[cmd=]/usr/local/etc/rc.d/whatever start[/cmd]

or even

[cmd=]service whatever start[/cmd]/

BTW, I'm pretty sure
Code: Select all
samba_enabled="YES"
is wrong. Look in the start script for the proper syntax.
User avatar
DutchDaemon
Old Fart
 
Posts: 10463
Joined: 16 Nov 2008, 20:17
Location: The Netherlands

Postby frankpeng » 07 Nov 2012, 16:59

samba4 is not cooked in FreeBSD. You cannot start Samba4 automatically in [FILE]rc.conf[/FILE] by using [FILE]samba_enable="YES"[/FILE]

You can manually start samba4 by [FILE]/usr/local/samba/bin/samba[/FILE].

I do not know how to setup ldap and kerberos with samba4.

samba4 use samba-tool to add new users.

Anyway, samba4 is brand new. You cannot use samba3 ideas.
frankpeng
Junior Member
 
Posts: 55
Joined: 04 Dec 2009, 06:34

Postby SirDice » 07 Nov 2012, 17:05

Frankpeng, you are responding to a two year old post. I'm sure the OP has solved it by now.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16161
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands


Return to Web & Network Services

Who is online

Users browsing this forum: No registered users and 0 guests