HP P1566 in FreeBSD 8.1

Stuff that plugs in via USB, FireWire, eSATA, PS/2, etc.

HP P1566 in FreeBSD 8.1

Postby tooker » 01 Nov 2010, 14:38

Does anyone have this printer working under FreeBSD 8.1? I've installed cups, hplip & foo2zjs but no luck. Hp-check & [FILE]/usr/local/libexec/cups/backend/hp[/FILE] found nothing.

Does this printer require firmware to work like HP 1005 for example?

[CMD=" "]usbconfig dump_device_desc[/CMD] returns:
Code: Select all
ugen1.2: <HP LaserJet Professional P1566 Hewlett-Packard> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0200
  bDeviceClass = 0x0000
  bDeviceSubClass = 0x0000
  bDeviceProtocol = 0x0000
  bMaxPacketSize0 = 0x0040
  idVendor = 0x03f0
  idProduct = 0x092a
  bcdDevice = 0x0100
  iManufacturer = 0x0001  <Hewlett-Packard>
  iProduct = 0x0002  <HP LaserJet Professional P1566>
  iSerialNumber = 0x0003  <000000000QB00ZLJSI1c>
  bNumConfigurations = 0x0001
tooker
Junior Member
 
Posts: 11
Joined: 03 Jan 2010, 21:44
Location: Russia, St. Petersburg

Postby tingo » 01 Nov 2010, 20:46

Always check openprinting.org when having problems with a new printer. Yours is listed:
http://www.openprinting.org/printer/HP/HP-LaserJet_Pro_P1566
The foo2zjs driver should be all you need.

Are you using the latest version of hplip? Check /var/log/messages for error messages.
try to run hp-setup and hp-check as root (it could be a permissions problem).
You need to set the DISPLAY environment variable if you want to run hp-setup etc. as root.
Torfinn
tingo
Member
 
Posts: 947
Joined: 16 Nov 2008, 22:02
Location: Oslo, Norway

Postby tooker » 02 Nov 2010, 12:08

The foo2zjs driver should be all you need.


Does this mean that I don't require [port]print/hplip[/port] to install?

foo2zjs driver is already intalled on my system. Followed instruction for FreeBSD 8.0 from http://foo2zjs.rkkda.com/INSTALL but after setup of printer in CUPS and sending "Test Page" to it nothing happens.

In the instruction

Use:
Code: Select all
       usb:/dev/ulpt0
       usb:/dev/ulpt1

for the URI.


is noticed, but I don't have such devices. I used [FILE]usb:/dev/ugen1.2[/FILE] for the URI.

Does my printer require firmware loaded to print or not?
tooker
Junior Member
 
Posts: 11
Joined: 03 Jan 2010, 21:44
Location: Russia, St. Petersburg

Postby tingo » 11 Nov 2010, 21:34

Try to install foo2zjs from the port ([port]print/foo2zjs[/port]) instead (pay attention to the instructions given when you install the port). Does it work then?
You will probably want to have hplip ([port]print/hplip[/port]) installed - everything works nicer then (for me at least).
I have a HP Photosmart 8250, so I can't say if your printer requires firmware or not.
Torfinn
tingo
Member
 
Posts: 947
Joined: 16 Nov 2008, 22:02
Location: Oslo, Norway


Return to Peripheral Hardware

Who is online

Users browsing this forum: No registered users and 1 guest