Automount in Gnome

The GNOME desktop environment

Automount in Gnome

Postby Icher » 12 Sep 2010, 13:31

Hello,

I did a fresh install of FreeBSD 8.1 with Gnome and KDE. In Gnome when I connect an USB drive I get the following 2 Errors:
Code: Select all
[B]Cannot mount volume[/B]
Unable to mount the volume 'RALLY2'.
Details: mount_msdosfs: dev/msdosfs/RALLY2: Device busy

Code: Select all
[B]Cannot mount volume[/B]
Error org.freedesktop.Hal.Device.UnknownError.
Details: An unknown error occured


Well after the 2 errors the device is mounted. But for every new mount the is a new directory under /media

Code: Select all
$ ls /media | grep RALLY
RALLY2
RALLY2_
RALLY2__
$


Then I try to unmount the device and get the following error:

Code: Select all
[B]Cannot unmount volume[/B]
The volume 'RALLY2' was probably
mounted manually on the command line
Details Device to unmount is not in /media/.hal-mtab
so it is not mounted by HAL


So who did mount the device?

Mounting other HDD devices from my computer works great automatically.

My PolicyKit.conf taken from PC-BSD:

Code: Select all
<config version="0.1">
        <define_admin_auth group="operator"/>
        <match action="org.freedesktop.hal.storage.mount-removable">
                <return result="yes"/>
        </match>
        <match action="org.freedesktop.hal.storage.mount-fixed">
                <return result="yes"/>
        </match>
        <match action="org.freedesktop.hal.storage.eject">
                <return result="yes"/>
        </match>
</config>


Has anyone a idea what is going wrong here?
Icher
Junior Member
 
Posts: 14
Joined: 18 Dec 2009, 08:08

Postby SirDice » 14 Sep 2010, 06:53

Make sure everything is unmounted and remove any stray directories from [file]/media/[/file].
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby Yampress » 14 Sep 2010, 08:43

hald and dbus are in /etc/rc.conf ?
Code: Select all
dbus_enable="YES"
hald_enable="YES"


http://www.freebsd.org/gnome/docs/halfaq.html

and the directory /media is empty ?
User avatar
Yampress
Junior Member
 
Posts: 36
Joined: 08 Aug 2010, 11:37
Location: PL

Postby Icher » 15 Sep 2010, 16:49

my /etc/rc.conf:

Code: Select all
dbus_enable="YES"
hald_enable="YES"
polkitd_enable="YES"
gnome_enable="YES"


the /media directory is empty, without the hdd that are mounted automatically

Code: Select all
# ls /media
.hal-mtab   disk      disk-2      disk-4
.hal-mtab-lock   disk-1      disk-3
#


But I figured out, that usb-sticks with ntfs file system can be mounted perfectly by hal. Only when hal call the mount_msdosfs the error occurs.
Icher
Junior Member
 
Posts: 14
Joined: 18 Dec 2009, 08:08

Postby EdGe » 15 Sep 2010, 21:44

Greetings.

It could be a badly formatted usb stick. Put a new file system on it and try again.
EdGe
Junior Member
 
Posts: 31
Joined: 16 Aug 2010, 13:58

Postby Yampress » 18 Sep 2010, 16:46

Code: Select all
dbus_enable="YES"
hald_enable="YES"
polkitd_enable="YES"
gnome_enable="YES"

No,no no no

try only

Code: Select all
gnome_enable="YES"



This will enable services such as GDM, HAL, D-BUS, and Avahi on system startup. If you do not want to run all of these services, you should forget the gnome_enable property, and manually enable the services you want.



or correct is

Code: Select all
dbus_enable="YES"
hald_enable="YES"
polkitd_enable="YES"
gdm_enable="YES"


Never those deamons with gnome_enable="YES"
User avatar
Yampress
Junior Member
 
Posts: 36
Joined: 08 Aug 2010, 11:37
Location: PL

Postby Icher » 18 Sep 2010, 23:36

Yampress wrote:try only

Code: Select all
gnome_enable="YES"




I have change this

EdGe wrote:Greetings.

It could be a badly formatted usb stick. Put a new file system on it and try again.


Then I try this

[cmd=]newfs_msdosfs /dev/da0s1[/cmd]

Ok now the USB Stick is mounted automatically, but I can't unmout it. When I try it in nautilus or use this:

[cmd=]umount /dev/da0s1[/cmd]

the stick is direly mounted again by hal.
Icher
Junior Member
 
Posts: 14
Joined: 18 Dec 2009, 08:08

Postby Yampress » 19 Sep 2010, 08:24

I can umount pendrive on gnome (right button of mouse and umount).
When system writes something on pendrive you can't umount his. You have to wait, when done it.
User avatar
Yampress
Junior Member
 
Posts: 36
Joined: 08 Aug 2010, 11:37
Location: PL

Postby Icher » 19 Sep 2010, 11:46

Yampress wrote:I can umount pendrive on gnome (right button of mouse and umount).
When system writes something on pendrive you can't umount his. You have to wait, when done it.


I know how to unmount a pendrive. The problem is after it is removed. The icon has disappeared from the desktop. It is directly mounted again by hal. So I can't remove the pendrive because it is mounted again.
Icher
Junior Member
 
Posts: 14
Joined: 18 Dec 2009, 08:08

Postby wblock@ » 19 Sep 2010, 16:18

You may have to disable automounting somewhere in the desktop environment. No idea where GNOME has that; in xfce4, it's Settings/File Manager/Advanced.
User avatar
wblock@
Old Fart
 
Posts: 10207
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy


Return to GNOME

Who is online

Users browsing this forum: No registered users and 0 guests