phpmyadmin fail

Installing and maintaining the FreeBSD Ports Collection or FreeBSD Packages (i.e. third party software).

phpmyadmin fail

Postby bluethundr » 17 Aug 2010, 04:04

I am attempting to install phpMyAdmn 2.1.1 onto FreeBSD 8.1. However it is failing with this error:

Code: Select all
/usr/ports/databases/php5-mysql/work/php-5.3.3/ext/mysql/php_mysql.c:2158: error: 'zend_fcall_info_cache' has no member named 'object_ptr'


This is the complete output that I am experiencing:


phpMyAdmin Full Error

I'm not sure if this is because I running a newer version of mysql and I need to fall back to an earlier version:

Code: Select all
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 3
Server version: 5.5.5-m3 FreeBSD port: mysql-server-5.5.5_1

Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL v2 license

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql>



On the good news front I got X windows running today. TWM FTW!! :P
bluethundr
Junior Member
 
Posts: 62
Joined: 21 Jul 2010, 02:46

Postby SirDice » 17 Aug 2010, 09:45

Don't use MySQL 5.5.x. Install either 5.1.x or 5.0.x.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

older MySQL

Postby bluethundr » 17 Aug 2010, 12:04

K, sir dice! I'll give that a try when I get home from work tonight and let you know how that goes!
bluethundr
Junior Member
 
Posts: 62
Joined: 21 Jul 2010, 02:46

Postby anomie » 18 Aug 2010, 21:32

That, or get to the 3.x branch of phpMyAdmin.

http://www.phpmyadmin.net/home_page/downloads.php

(FWIW, I am running mostly 2.x branch with older MySQL.)
"Do Not Engage in Useless Activity" --Miyamoto Musashi
User avatar
anomie
Member
 
Posts: 783
Joined: 17 Nov 2008, 04:37
Location: Texas

Postby tokes » 20 Sep 2010, 02:43

I'm having the exact same error as the one you put in Pastie, but with different versions of ports:

FreeBSD - FreeBSD 7.0-RELEASE #0
MySQL - mysql-server-5.1.22
PHP - /usr/ports/lang/php5 is php-5.3.3, although when I run phpinfo() from Apache it says I'm running 5.2.5?
phpMyAdmin - phpMyAdmin-3.3.6-all-languages

I'm a supernoobie to FreeBSD so I'd appreciate any help!

Also, I tried to "just install" phpMyAdmin into Apache's root but when I try to load http://host/phpMyAdmin/setup/index.php I just get a blank page. But, if I put a php file with phpinfo() in it in that same folder, it executes okay?

Thanks in advance,
tokes
Junior Member
 
Posts: 1
Joined: 20 Sep 2010, 02:33


Return to Installation and Maintenance of FreeBSD Ports or Packages

Who is online

Users browsing this forum: possamai and 8 guests