Which filesystem for external drive?

Stuff that plugs in via USB, FireWire, eSATA, PS/2, etc.

Which filesystem for external drive?

Postby demo » 13 Aug 2010, 03:22

Hi, i have a 500GB LaCiE external hard-drive, i bought it for the purpose of storing my music, photos, movies etc. I tend to distro hop/re-install fairly often. Its connected by usb and is detected etc.

My drive is currently formatted as ext4, and refuses to mount under FreeBSD, which isn't a problem, i can backup the stuff and reformat it... but the problem is choosing a suitable filesystem.

Which filesystem, would be appropriate to use for both a Linux and FreeBSD host?
I don't want to use ntfs, for personal reasons. And Fat-32's file size limit isn't ideal.

The drive needs read and write support under both Linux/FreeBSD. Any ideas? :stud
User avatar
demo
Junior Member
 
Posts: 16
Joined: 02 Aug 2010, 20:33

Postby vermaden » 13 Aug 2010, 05:27

I mostly use FAT32 for that purpose, its the most 'portable' sollution for an external USB drive, Windows/Linux/Mac OSX/BSDs have built in support for it, with ext2 You will have to add that support to Windows and OS X, with NTFS You would have to add it to Linux/BSDs/OSX with fuse, it also depends how portable You want this drive to be, it its gonna stand right beside You box always attached to it, then You do not need portability, but if You would want to have this drive 'working' with every OS, FAT32 is the best way.
Religions, worst damnation of mankind.
"FreeBSD has always been the operating system that GNU/Linux should have been." Frank Pohlmann, IBM
[FILE][color="DarkSlateBlue"]http://vermaden.blogspot.com[/color][/FILE]
User avatar
vermaden
Giant Locked
 
Posts: 2317
Joined: 16 Nov 2008, 19:37
Location: pl_PL.lodz

Postby demo » 16 Sep 2010, 19:08

Ok seems like its been a while, but i finally got round to doing this, formatted my drive to FAT32. I have a problem with read/write though.

Just to clarify in case "large" is part of the problem:
Code: Select all
$ sudo mount -t msdosfs /dev/da0s1 /mnt/fat32/
mount_msdosfs: /dev/da0s1: Disk too big, try '-o large' mount option: Invalid argument


I can successfully mount my drive using:
Code: Select all
$ sudo mount -t msdosfs -o large /dev/da0s1 /mnt/fat32/


However i am stuck with read-only support. How can i go about mounting it so i can write to the disk?


Code: Select all
$ uname -a
FreeBSD freya 8.1-RELEASE FreeBSD 8.1-RELEASE #0: Mon Jul 19 02:36:49 UTC 2010
     root@mason.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64
$ df -h /dev/da0s1   
Filesystem    Size    Used   Avail Capacity  Mounted on
/dev/da0s1    466G     86G    380G    18%    /mnt/fat32


If need anymore info to help solve this, just ask.
Thanks
User avatar
demo
Junior Member
 
Posts: 16
Joined: 02 Aug 2010, 20:33

Postby Beastie » 16 Sep 2010, 20:35

[file]/etc/sysctl.conf[/file]:
Code: Select all
vfs.usermount=1

[cmd=#]sysctl vfs.usermount=1[/cmd]

Add yourself to the operator group:
[cmd=#]pw group mod operator -m demo[/cmd]

[file]/etc/rc.conf[/file]:
Code: Select all
devfs_system_ruleset="localrules"

[file]/etc/devfs.rules[/file]:
Code: Select all
[localrules=5]
add path 'da*' mode 0660 group operator

Restart devfs:
[cmd=#]/etc/rc.d/devfs restart[/cmd]

Create a mountpoint in your home directory:
[cmd=%]mkdir ~/mnt[/cmd]

Now you can mount R/W and without sudo:
[cmd=%]mount -t msdosfs -o large,longnames /dev/da0s1 ~/mnt[/cmd]
May the source be with you!
Beastie
Senior Member
 
Posts: 1861
Joined: 28 Mar 2009, 11:27
Location: /dev/earth0


Return to Peripheral Hardware

Who is online

Users browsing this forum: No registered users and 0 guests