FreeBSD 8.1 Boot Loader Problems

Installing and upgrading FreeBSD.

FreeBSD 8.1 Boot Loader Problems

Postby bluethundr » 01 Aug 2010, 23:20

Hello,

Well unfortunately in my attempt to upgrade some components on my FreeBSD 8.1 box login was totally busted. If you tried to log into the box either via ssh or locally it would compplain that lilnintl.8.so was not present.

So I decided to reinstall and have as of yet been unsuccessful in getting it to boot as I had the first time.

I have tried multiple times but it seems my current problems revolve around the FreeBSD boot loader.

I have two SAS drives and I am formatting both with FDISK as one large partition. On the first drive I am setting the boot flag by pressing S. The two drives are listed as ad4 and ad5, respectively.

When I leave that screen I get the choice of using either the Standard non-interactive boot manager, or the BootMgr FreeBSD boot manager. I have tried both multiple times and when I reboot after the install the system is not bootable. Generally I am installing the boot loader(s) on the first drive (ad4). I generally don't bother installing a boot loader on the second drive (ad5) but I have even in fits of desperation installed both there.

Using the FreeBSD Disklabel Editor I setup my partitions this way


Code: Select all
ad4s1d  /boot 512M UFS2+S Y
ad4s1b  /boot 512M SWAP
ad4s1a  /boot 512M UFS2+S Y
ad5s1d  /boot 512M UFS2+S Y
ad5s1e  /boot 512M UFS2+S Y
ad5s1f  /boot 512M UFS2+S Y
ad5s1g  /boot 512M UFS2+S Y



I have been going through lengthy installs every time I think I have it right always end up in the same place:

Code: Select all
Invalid partition
Invalid partition
No /boot/loader

FreeBSD/i386 boot
Default: 0:ad(0,a)/boot/kernel/kernel

FreeBSD/i386 boot
Default: 0:ad(0,a)/boot/kernel/kernel
bluethundr
Junior Member
 
Posts: 62
Joined: 21 Jul 2010, 02:46

Postby DutchDaemon » 02 Aug 2010, 00:42

I'm assuming the disklabel output in your post is a matter of a botched cut & paste job? BTW, the original libintl error was probably caused by not paying attention to [FILE]/usr/ports/UPDATING[/FILE] when upgrading ports. Is bash your login shell? Then this is the likely cause:

[CMD=" "]less +/20100530 /usr/ports/UPDATING[/CMD]
User avatar
DutchDaemon
Old Fart
 
Posts: 10463
Joined: 16 Nov 2008, 20:17
Location: The Netherlands

botched paste

Postby bluethundr » 02 Aug 2010, 02:44

Hi DD

Thanks for the input! Yes the output of disklabel is badly botched. I had no way to copy-paste as this is an attempt at fresh install and I cannot ssh into this box yet. Apparently I brain farted my way through the whole thing. sorry about that! :r

Here's another attempt at a better representation of the output:

Code: Select all
Part   Mount            Size      Newfs  Part
-----  -----            -----     ------ ----
ad4s1d /boot            512MB     UFS2+S Y
ad4s1b swap             4096MB    SWAP
ad4s1a /                33538MB   UFS2+S Y
ad5s1d /var             4096MB    UFS2+S Y
ad5s1e /usr/local/www   40690MB   UFS2+S Y
ad5s1f /usr             40690MB   UFS2+S Y
ad5s1g /usr/local/vmail 811GB     UFS2+S Y


I'm hoping to build this box out into a postfix server.

And as to the original libintl error I'll keep that command in mind if I am ever faced with that situation again! And yes bash was my login shell. But when the error occurred I had no way of logging into the box either via ssh or locally so I doubt that I could have run that command.

Thanks again for the input..
bluethundr
Junior Member
 
Posts: 62
Joined: 21 Jul 2010, 02:46

Postby fronclynne » 02 Aug 2010, 02:59

Do not use a separate partition for [file]/boot/[/file]. This isn't linux. FreeBSD expects [file]/boot/[/file] to be part of the root partition.
[color="DimGray"]Quid habemus reliquum?
Nutrimentum anatum![/color]
[color="Teal"]Внимание: лифт вниз не поднимает[/color]
User avatar
fronclynne
Senior Member
 
Posts: 1297
Joined: 09 Feb 2009, 04:47
Location: Lunch Time

bsd != linux :\

Postby bluethundr » 03 Aug 2010, 03:38

ah! that was the breakthrough I was looking for! /boot has to be part of /. I usually separate the two under linux, but believe me this is a lesson that will stick like glue!

thanks!
bluethundr
Junior Member
 
Posts: 62
Joined: 21 Jul 2010, 02:46


Return to Installing & Upgrading

Who is online

Users browsing this forum: mrjayviper, pieside and 4 guests