Dual Monitor setup, xrandr doesn't even show the outputs

X.Org on FreeBSD installation & configuration.

Dual Monitor setup, xrandr doesn't even show the outputs

Postby caesius » 25 Jun 2010, 23:46

I'm experimenting with a dual monitor setup.

I have a 7600GT card, one flash new BenQ monitor, and one old Viewsonic.

If I plug them both in to my graphics card and boot up both screens display the same thing while on the command line.

As soon as I start XOrg only one turns on however. What is bothering me though, is the output of xrandr:

Code: Select all
> xrandr -q
Screen 0: minimum 320 x 240, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
  1920x1080       50.0*
  1680x1050       51.0
... <truncated>


I'm not seeing the outputs I'm expecting: DVI-0, DVI-1 etc. So the problem seems to be with the outputs from the graphics card. Anyone have any ideas what I should try next?
caesius
Member
 
Posts: 277
Joined: 16 Nov 2008, 03:23
Location: New Zealand

Postby adamk » 26 Jun 2010, 01:24

Neither the closed source 'nvidia' driver or the opensource, but obfuscated, 'nv' driver fully support xrandr 1.2. nouveau might do what you want. 'nvidia', of course, supports twinview, which provides functionality similar to xrandr.

Adam
adamk
Senior Member
 
Posts: 1624
Joined: 21 Nov 2008, 11:00

Postby nekoexmachina » 26 Jun 2010, 02:47

use x11/nvidia-xconfig to configure it with xinerama or twinview.
User avatar
nekoexmachina
Member
 
Posts: 312
Joined: 24 Jan 2010, 16:30
Location: Russia


Return to X.Org

Who is online

Users browsing this forum: No registered users and 0 guests