Hard disks not recognized

Installing and upgrading FreeBSD.

Hard disks not recognized

Postby floomby » 08 Jun 2010, 18:55

Hi,

I have tried to install PCBSD 8.0 i386 DVD and then the FreeBSD 8.0 amd64 bootonly disc.
Both times, my two SATA hard disks (one on primary master and the other on secondary master) were not recognized.

Obviously it would be nice if I could get it up and running :)

Here is the dmesg output running from a live PCBSD environment:
http://pastebin.com/kCVT8eCv

It seems like the sata controller is being recognized but not the hard disks connected, given the lines : atapci1 ICH7 SATA300 controller, ata2, etc.
Typing lsdev at the loader prompt indeed lists the hard disks correctly.
I have tried loading geom_mbr, geom_bsd and geom_label from the loader prompt but to no avail.

There appear to be no settings in the bios about sata compatability mode, legacy, etc.

For completeness, here is the lspci output from Linux:
http://pastebin.com/zsghNatX

This is my first attempt at BSD, is there anything I can try to get the hdds recognized by inserting device hints or loading modules or something?

Any help would be appreciated.

Thanks
floomby
Junior Member
 
Posts: 2
Joined: 08 Jun 2010, 15:45

Postby JimW » 09 Jun 2010, 01:40

Do you have a drive plugged into a USB port?

Code: Select all
umass0: <SMI Corporation USB DISK, class 0/0, rev 2.00/11.00, addr 2> on usbus4


If you do, try booting without it being plugged into the machine.

It could be creating an IRQ conflict that the system doesn't agree with....

Code: Select all
<Intel 82801G (ICH7) USB controller USB-B> port 0xc880-0xc89f irq 19 at device 29.1 on pci0

<Intel ICH7 SATA300 controller> port 0xc400-0xc407,0xc080-0xc083,0xc000-0xc007,0xbc00-0xbc03,0xb880-0xb88f irq 19 at device 31.2 on pci0
JimW
Junior Member
 
Posts: 95
Joined: 13 Nov 2009, 05:56
Location: New York

Postby floomby » 09 Jun 2010, 05:17

No, there were no usb drives connected.
I had a USB mouse connected.

Here is the dmesg output with the mouse unplugged:
http://pastebin.com/gmQCHhAb

I then further tried disabling USB in the bios with no result.

After a fair amount of googling, I found this post http://groups.google.com/group/mailing.freebsd.stable/browse_thread/thread/8258252238ba1390
I'm not sure if it is the same thing but there appears to be no solution :\

Thanks
floomby
Junior Member
 
Posts: 2
Joined: 08 Jun 2010, 15:45

Postby JimW » 09 Jun 2010, 21:32

I also did a Google search on your problem because I got curious. It's clear there have been others with the same problem you are experiencing, but what is not clear is how, or if some of them have been solved.

I saw one posting claiming the guy solved his issue by installing a PATA drive on his IDE bus and putting the OS on that drive. Then the system recognized the drives attached to the SATA controller. I can't find the link and will do another search and see if I can post it for you.

There are no BIOS mode settings for the SATA controller such as Enhanced or Compatible? Nothing related to AHCI?

I was wondering if loading the ahci kernel module might work. In your [file]/boot/loader.conf[/file] file try adding the following...

Code: Select all
ahci_load="YES"


The man page includes some device hints that may also be worth a look. Not sure that will help, but it is worth a shot.
JimW
Junior Member
 
Posts: 95
Joined: 13 Nov 2009, 05:56
Location: New York


Return to Installing & Upgrading

Who is online

Users browsing this forum: No registered users and 1 guest