Very slow response to mouse and keyboard

The GNOME desktop environment

Very slow response to mouse and keyboard

Postby dheerajsuthar » 12 May 2010, 22:33

Hi to everyone in this forum!
I am suffering a problem in nearly every desktop environment:
Gnome
Kde4
Xfce4
Problem is that they respond very slowly to all mouse and key press. Also menu and task switching is painfully slow. Some time they just hang without any error. Also same with switching console.
I have installed everything (including nvidia driver from ports) according to Handbook.
I am attaching following:
x log
rc.conf
kldstat
dmesg.boot

My system specifications:
Specification:
FreeBSD RELEASE 8 i386 (no modification in kernel, Generic one)
Dell Studio XPS 1340

Intel® Core™ 2 Duo P8700 (3MB cache/2.53GHz/1066Mhz FSB)

Operating System
Genuine Windows® 7 Home Premium, 64bit, English
Specifications - Operating System

Operating System
Genuine Windows® Vista Home Premium, 64bit, English
Specifications - Operating System


LCD Panel
Edge-to-Edge 13.3" HD WXGA LCD with 2.0 Megapixel Camera
Specifications - LCD Panel


Internal Optical Drive
8X Slot Load CD/DVD Burner (Dual Layer DVD+/-R Drive)
Specifications - Internal Optical Drive


MEMORY
4GB4 Dual Channel DDR3 SDRAM3 at 1067MHz (2 Dimms)
Specifications - MEMORY

Hard Drive
320GB5 7200 RPM6 SATA Hard Drive
Specifications - Hard Drive


Video Card
NVIDIA® GeForce® 9500M - 256MB
Specifications - Video Card

SOUND CARD
High Definition Audio 2.0
Specifications - SOUND CARD


Wireless Networking Cards
Dell Wireless 1520 802.11n Half Mini-Card
Specifications - Wireless Networking Cards

Background:
This is my second stint with FreeBSD. Tried it once before but had some trouble with CD/DVD drive and other problem. Although couldn't solve it but found the reason : Perhaps my CD drive is on slave whereas FreeBSD needs it on Master (got the idea by runnig FreeBSD on virtual machine. Worked on Linux(SlackWare 13 + Xfce4) meanwhile and everything worked pretty well and fast. However I had some strange inclination toward FreeBSD from begining:) (mainly due to its design and nice documentation) so I am here again. Please help me in continuing my stay with this great OS.
Attachments

[The extension txt has been deactivated and can no longer be displayed.]

[The extension txt has been deactivated and can no longer be displayed.]

[The extension txt has been deactivated and can no longer be displayed.]

[The extension txt has been deactivated and can no longer be displayed.]

[The extension txt has been deactivated and can no longer be displayed.]

dheerajsuthar
Junior Member
 
Posts: 45
Joined: 04 Dec 2009, 16:30

Postby wblock@ » 12 May 2010, 22:48

From your xorg.conf:

[file]#my changes to have mouse and keyboard
Section "ServerFlags"
Option "AllowEmptyInput" "False"
EndSection
#my changes end[/file]

AllowEmptyInput will do that. Remove it, stop using it, tell everyone you know that what was used a year ago as a temporary bug fix is now a bug cause.

Your [file]rc.conf[/file] shows that you're running hal and dbus, so just remove the AEI option and try your window manager. If that works, you can also remove the InputDevice sections from xorg.conf, and you're done.

If you really need to disable hal input device detection, use [file]Option "AutoAddDevices" "Off"[/file]. And you can put it in the ServerLayout section, there's no need for the extra ServerFlags section.
User avatar
wblock@
Old Fart
 
Posts: 10222
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby dheerajsuthar » 13 May 2010, 06:50

wblock wrote:From your xorg.conf:

[file]#my changes to have mouse and keyboard
Section "ServerFlags"
Option "AllowEmptyInput" "False"
EndSection
#my changes end[/file]

AllowEmptyInput will do that. Remove it, stop using it, tell everyone you know that what was used a year ago as a temporary bug fix is now a bug cause.

Your [file]rc.conf[/file] shows that you're running hal and dbus, so just remove the AEI option and try your window manager. If that works, you can also remove the InputDevice sections from xorg.conf, and you're done.

If you really need to disable hal input device detection, use [file]Option "AutoAddDevices" "Off"[/file]. And you can put it in the ServerLayout section, there's no need for the extra ServerFlags section.

Thanks for reply wblock. Probably that's why I like FreeBSD "everything configured by hand and helpful community.". Your solution worked very well.However I am still searching answer for making my synaptic touchpad work(hopefully I will find it on this forum).

Can you please guide me where to get more details on finer options in X configuration (I have read Xorg section in Handbook). Actually that's one of the biggest reason of my working on FreeBSD as I want to learn internals of the system. I want total control over my system. Handbook is very nice but I want something in more detail with some background. Can you kindly give links to these resources (including books etc.). I have already started searching this forum and FreeBSD site.
Thanks again,
dheerajsuthar
Junior Member
 
Posts: 45
Joined: 04 Dec 2009, 16:30

Postby wblock@ » 13 May 2010, 13:18

dheerajsuthar wrote:Can you please guide me where to get more details on finer options in X configuration (I have read Xorg section in Handbook).


xorg.conf(5) is a good start, and [file]/var/log/Xorg.0.log[/file]. And the man page for your video driver. After that, probably the freebsd-x11 mailing list, and then maybe the xorg mailing lists at http://lists.freedesktop.org/mailman/listinfo/. Mailing lists are generally a better source for technical information than web forums.
User avatar
wblock@
Old Fart
 
Posts: 10222
Joined: 07 Sep 2009, 23:23
Location: Milky Way galaxy

Postby dheerajsuthar » 13 May 2010, 13:51

Thanks again wblock. My queries are solved :). Moderators can kindly close the thread.
dheerajsuthar
Junior Member
 
Posts: 45
Joined: 04 Dec 2009, 16:30


Return to GNOME

Who is online

Users browsing this forum: No registered users and 0 guests