KDE4 under VMWARE: keyboard and mouse don't work

The K Desktop Environment

KDE4 under VMWARE: keyboard and mouse don't work

Postby nhanquy » 09 Mar 2010, 15:04

On a XP machine, I have vmware player installed and have freebsb8.0/kde4 installed:

On the /ect/rc.conf I have added:
Code: Select all
hald_enable="YES"
dbus_enable="YES"
local_startup="${local_startup} /usr/local/kde4/etc/rc.d"
kdm4_enable="YES"


and on ~/.xinitrc:
Code: Select all
PATH=/usr/local/kde4/bin:$PATH
export PATH
startkde4


If I boot freebsd; it will go to kdm and it won't accept keyboard or mouse input.

1. So what is wrong here? What should I have done?
Note that my /etc/ttys does not have this line:
Code: Select all
ttyv8 "/usr/local/kde4/bin/kdm -nodaemon" xterm on secure


2. How do I get out to another window? (no keyboard input :( - And no where from vmware
I could send ALT+F1 as input, for example!)
nhanquy
Junior Member
 
Posts: 23
Joined: 24 Jul 2009, 00:13

Postby SirDice » 09 Mar 2010, 15:09

The ~/.xinitrc file isn't used if you use KDM. Boot to single user mode and remove the kdm4_enable option in rc.conf. Fix your keyboard and mouse first, then enable KDM.

IIRC VMWare emulates a PS/2 mouse and keyboard, regardless of what's connected to the host. For the mouse add to /etc/rc.conf:

Code: Select all
moused_enable="YES"


Make sure mouse and keyboard work before starting X.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16153
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby nhanquy » 09 Mar 2010, 15:21

#SirDice : Thanks! But how do I modify /etc/rc.conf in single user mode? It seem no editor and the file is read-only (I tried to use mv ...)
nhanquy
Junior Member
 
Posts: 23
Joined: 24 Jul 2009, 00:13

Postby nhanquy » 09 Mar 2010, 15:37

http://forums.freebsd.org/showthread.php?t=5860

found it ! thanks again ! ( so I don't have to re-install freebsd )

But still I could not make keyboard and mouse work under vmware.
Go gnome !
nhanquy
Junior Member
 
Posts: 23
Joined: 24 Jul 2009, 00:13

Postby nexy_sm » 22 Apr 2010, 11:57

moused_enable="YES" works fine for me. i am using vmware workstation under Dell Inspiron 1501, now I have working KDE. But now is the problem because I don't have internet under KDE :(
nexy_sm
Junior Member
 
Posts: 8
Joined: 21 Apr 2010, 14:25


Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests