FreeBSD 8.0 : USB flash

Stuff that plugs in via USB, FireWire, eSATA, PS/2, etc.

FreeBSD 8.0 : USB flash

Postby oxf00f » 10 Feb 2010, 08:25

Start:

1. boot
2. login: root
3. insert usb-flash and see:

Code: Select all
# ugen4.3: <JetFlash> at usbus4
umass1: <JetFlash Mass Storage Device, class 0/0, rev.2.00/1.00, addr 3> on usbus4
umass1: SCSI over Bulk-Only; quirks = 0x0100
umass1:1:1:-1: Attached to scbus1
(probe0:umass-sim1:1:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
(probe0:umass-sim1:1:0:0): CAM Status: SCSI Status Error
(probe0:umass-sim1:1:0:0): SCSI Status: Check Condition
(probe0:umass-sim1:1:0:0): UNIT ATTENTION asc:28,0
(probe0:umass-sim1:1:0:0): Not ready to change, medium may have changed
(probe0:umass-sim1:1:0:0): Retrying Command (per Sence Data)
da1 at umass-sim1 bus 1 target 0 lun 0
da1: <JetFlash Transcend 2GB 8.07> Removable Direct Access SCSI-2 device
da1: 40.000MB/s transfers
d1: 1926MB (3944448 512 byte sectors: 255H 63S/T 245C)
GEOM: da1: media size does not match label.


4. checking device
Code: Select all
# ls /dev | grep da1
da1
da1a


5. checking partitions
Code: Select all
# fdisk /dev/da1
******* Working on device /dev/da1 *******
parameters extracted from in-core disklabel are:
cylinders=245 heads=255 sectors/track=63 (16065 blks/cyl)

parameters to be used for BIOS calculations are:
cylinders=245 heads=255 sectors/track=63 (16065 blks/cyl)

Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Informations from DOS bootblock is:
The data for partition 1 is:
sysid 14 (0x0e), (Primary 'big' DOS (>32MB, LBA))
     start 63, size 3944385 (1925Meg), flag 0
          beg: cyl 0/ head 1/ sector 1;
          end: cyl 244/ head 254/ sector 63
The data for partition 2 is:
<UNUSED>
The data for partition 3 is:
<UNUSED>
The data for partition 4 is:
<UNUSED>


6. (!) try to mount:
Code: Select all
#mount -t msdosfs /dev/da1 /mnt
GEOM: da1: media size does not match label.
mount_msdosfs: /dev/da1: Invalid argument

7. (!) try to mount:
Code: Select all
#mount -t msdosfs /dev/da1a /mnt
GEOM: da1: media size does not match label.
mount_msdosfs: /dev/da1a: Invalid argument


Question: how to mount?
PS: sorry for my bad english)
oxf00f
Junior Member
 
Posts: 3
Joined: 10 Feb 2010, 08:19
Location: USSR, Saint-Petersburg

Postby mfaridi » 10 Feb 2010, 08:42

try this
[CMD=" "]mount -t msdosfs /dev/da0s1 /mnt[/CMD]
User avatar
mfaridi
Member
 
Posts: 622
Joined: 17 Nov 2008, 05:32
Location: Afghanistan

Postby oxf00f » 10 Feb 2010, 09:55

mfaridi wrote:try this
mount -t msdosfs /dev/da0s1 /mnt


not working :(

my dev is da1

Code: Select all
#mount -t msdosfs /dev/da0s1 /mnt
mount_msdosfs: /dev/da0s1: No such file or directory


Code: Select all
#mount -t msdosfs /dev/da1s1 /mnt
mount_msdosfs: /dev/da1s1: No such file or directory
oxf00f
Junior Member
 
Posts: 3
Joined: 10 Feb 2010, 08:19
Location: USSR, Saint-Petersburg

Solved!

Postby oxf00f » 10 Feb 2010, 11:37

Ura!!!

Solve:

FreeBSD don't see slice's because they are not present on the flash.

1. Windows XP: fill flash with "zeros" (WinHex)
2. FreeBSD: create slice type 6 FAT (sysinstall)
3. Windows XP: format flash with FAT

----

after plug in FreeBSD in /dev created /dev/da1s1 ))
oxf00f
Junior Member
 
Posts: 3
Joined: 10 Feb 2010, 08:19
Location: USSR, Saint-Petersburg


Return to Peripheral Hardware

Who is online

Users browsing this forum: No registered users and 0 guests