how to mount ntfs usb HDD with rw access

Stuff that plugs in via USB, FireWire, eSATA, PS/2, etc.

how to mount ntfs usb HDD with rw access

Postby beginner » 26 Jan 2010, 23:30

Hello,
I have two external usb hdds, one is FreeAgent Seagate and another one is Trancend. Each has 320 GB capacity. When I bought them, they were formated as fat32 file system. But I re-formated them ntfs so that I could copy large file like more than 4 GB.
I've been trying to mount them with read and write acees on my freebsd 8. But I got thoes ntfs usb hdds with read access only.
I have also 8 GB usb stick formated with fat32 file system. I tried to mount the 8 GB usb stick with [CMD=""]# mount -a -t msdosfs /dev/da2s1 /media/usb[/CMD]. That was successfully mounted with read and write access as normal user. So I thought that I could use my FreeAgent usb hdd with rw access if I re-formatted to fat32 file system. Then I re-formatted my FreeAgent usb hdd as fat32. And then I mounted it with [CMD=""]# mount -o large -t msdosfs /dev/da0s1 /media/FreeAgent[/CMD]. It was done very well and I can use now FreeAgent with rw access as normal user.
But the problem is that I would like to keep my another usb hdd Trancend with ntfs file system and I would like to mount it with rw access.
Pleae help me to get work with ntfs read write access as normal user.
Thank you.

I've already done the following steps:
Code: Select all
# cd /usr/ports/sysutils/fusefs-ntfs
# make install clean

# vim /etc/rc.conf
  fusefs_enable="YES"
  
# vim /boot/loader.conf
  fuse_load="YES"

# reboot
# mkdir -p /media/Trancend
# chmod 777 /media/Trancend
# mount -t ntfs /dev/da0s1 /media/Trancend
it only had read access.


regards,
I become FreeBSD fun boy.
beginner
Junior Member
 
Posts: 13
Joined: 17 Jan 2010, 20:42

Postby sixtydoses » 27 Jan 2010, 02:15

Try:
Code: Select all
ntfs-3g /dev/da0s1 /media
User avatar
sixtydoses
Member
 
Posts: 400
Joined: 18 Nov 2008, 15:21
Location: Near my dentist.

Postby Beastie » 27 Jan 2010, 02:17

beginner wrote:
Code: Select all
# mount -t ntfs /dev/da0s1 /media/Trancend
it only had read access.

It's not working because even though you installed the [port]sysutils/fusefs-ntfs[/port] port, you're still using FreeBSD's native NTFS mount. Use [cmd=#]ntfs-3g /dev/da0s1 /media/Trancend[/cmd] instead. To make it permanent, you'll have to add it to [file]/etc/fstab[/file]. It should be something like:
Code: Select all
/dev/da0s1 /media/Trancend ntfs-3g rw 0 0

Once you add it, you should be able to mount it with [cmd=#]mount /media/Trancend[/cmd] only.
May the source be with you!
Beastie
Senior Member
 
Posts: 1859
Joined: 28 Mar 2009, 11:27
Location: /dev/earth0

Postby beginner » 27 Jan 2010, 17:11

Thank your very much, sixtydoses and Beastie. It was successfully mounted with read write acess.

******************************************************
Btw, I found some bug from the experience.

Defect : Text which is written in Gedit cannot be saved on ntfs file system.

After mounting my Transcend hdd ntfs, I tested it if it have read and write access. I tested to write a text with VIM, Emacs and Gedit, and then save that text file on the hdd. Texts which were written in VIM and Emacs could save on it successfully. But Text which is written in Gedit could not save on the ntfs hdd. After clicking on Save button in Gedit, my pc was freezed and hanged. Nothing moved and nothing could do.

Effect: Every Time

My PC: Dell GX270 series
CPU: Pentium 4 @ 2 processors @ 2.8 GHz
RAM: 1 GB
VGA: Nvidia 6200 series - 128 MB
Desktop: GNOME
External USB HDD : Transcend - ntfs - 320GB

regards
I become FreeBSD fun boy.
beginner
Junior Member
 
Posts: 13
Joined: 17 Jan 2010, 20:42

Postby Beastie » 27 Jan 2010, 17:32

It's probably a bug in [port]sysutils/fusefs-ntfs[/port] and you should report it to its developers, not here. The FreeBSD Project has nothing to do with it. It only maintains the port.
May the source be with you!
Beastie
Senior Member
 
Posts: 1859
Joined: 28 Mar 2009, 11:27
Location: /dev/earth0

Postby beginner » 27 Jan 2010, 17:50

Beastie wrote:It's probably a bug in [port]sysutils/fusefs-ntfs[/port] and you should report it to its developers, not here. The FreeBSD Project has nothing to do with it. It only maintains the port.


Yes, It was just accidentially found bug. Me neither, not intended to report to it's developers. Beside, I don't think I have permission to report that bug. Let it be. I just wanted to say it right at time. It's my bad.

Thank you, Beastie.
I become FreeBSD fun boy.
beginner
Junior Member
 
Posts: 13
Joined: 17 Jan 2010, 20:42

Postby SirDice » 27 Jan 2010, 18:42

Everybody has permission to report bugs, that's one of the beauties of using open source ;)

As for your problem with Gedit, it may also be caused by gvfs. Most 'pure' gnome applications use it to access files. If it was a bug with fuse/ntfs-3g I would have expected to see some problems with the 'normal' access using vim/emacs too. GnomeVFS was replaced by gvfs not too long ago. Did you enable fuse support when building gvfs?
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16149
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby beginner » 27 Jan 2010, 19:09

SirDice wrote:Everybody has permission to report bugs, that's one of the beauties of using open source ;)

As for your problem with Gedit, it may also be caused by gvfs. Most 'pure' gnome applications use it to access files. If it was a bug with fuse/ntfs-3g I would have expected to see some problems with the 'normal' access using vim/emacs too. GnomeVFS was replaced by gvfs not too long ago. Did you enable fuse support when building gvfs?


Aha, oh yeah! :-) That's nice if everyone can report bugs.

For gvfs, um, I don't remember if I enable fuse support. When I installed [FILE]sysutils/fusefs-ntfs[/FILE] port, I just let it go as default configuration or setting. I had no idea to enable about it. I installed Gnome from DVD. So which ports I should re-install and enable for gvfs support?
I become FreeBSD fun boy.
beginner
Junior Member
 
Posts: 13
Joined: 17 Jan 2010, 20:42

Postby sixtydoses » 27 Jan 2010, 21:11

Hmm.. I don't remember having problems saving stuff in gedit on mounted ntfs but it has been a while so I could be wrong. Think SirDice was referring to [FILE]devel/gvfs[/FILE]. Try running [CMD="#"]make config[/CMD] and see if 'Enable fuse' is selected.
User avatar
sixtydoses
Member
 
Posts: 400
Joined: 18 Nov 2008, 15:21
Location: Near my dentist.

Postby SirDice » 27 Jan 2010, 21:25

beginner wrote:Aha, oh yeah! :-) That's nice if everyone can report bugs.

The tricky part is finding someone that can fix it ;)

sixtydoses wrote:Hmm.. I don't remember having problems saving stuff in gedit on mounted ntfs but it has been a while so I could be wrong. Think SirDice was referring to [FILE]devel/gvfs[/FILE]. Try running [CMD="#"]make config[/CMD] and see if 'Enable fuse' is selected.


Yep, that's the one I meant :)

Fuse isn't enabled by default so the package on the dvd doesn't have it enabled either.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16149
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby beginner » 27 Jan 2010, 22:45

SirDice wrote:The tricky part is finding someone that can fix it ;)

So do I, that's why I am finding you guys. :e

Here another problem that when I installed that [FILE]devel/gvfs[/FILE] port, it was failed. I did what suggestion message said, but I couldn't make it. Here my terminal output from building it.

Code: Select all
checking for gtkdoc-rebase... no
checking for gtkdoc-mkpdf... no
checking whether to build gtk-doc documentation... no
checking for GLIB... configure: error: Package requirements (glib-2.0 >= 2.21.2 gthread-2.0 gobject-2.0 gmodule-no-export-2.0 gio-unix-2.0 gio-2.0 ) were not met:

Requested 'glib-2.0 >= 2.21.2' but version of GLib is 2.20.5

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

===>  Script "configure" failed unexpectedly.
Please run the gnomelogalyzer, available from
"http://www.freebsd.org/gnome/gnomelogalyzer.sh", which will diagnose the
problem and suggest a solution. If - and only if - the gnomelogalyzer cannot
solve the problem, report the build failure to the FreeBSD GNOME team at
gnome@FreeBSD.org, and attach (a)
"/usr/ports/devel/gvfs/work/gvfs-1.4.3/config.log", (b) the output of the
failed make command, and (c) the gnomelogalyzer output. Also, it might be a
good idea to provide an overview of all packages installed on your system
(i.e. an `ls /var/db/pkg`). Put your attachment up on any website,
copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with
the attachment. Try to avoid sending any attachments to the mailing list
(gnome@FreeBSD.org), because attachments sent to FreeBSD mailing lists are
usually discarded by the mailing list software.
*** Error code 1

Stop in /usr/ports/devel/gvfs.
*** Error code 1

Stop in /usr/ports/devel/gvfs.
freebsd# sh gnomelogalyzer.sh

Generating build log. Please wait... done.

The cause of your build failure is not known to gnomelogalyzer.sh.  Before
e-mailing the build log to the FreeBSD GNOME team at freebsd-gnome@FreeBSD.org,
TRY EACH OF THE FOLLOWING:

  * If you are generating your own logfile, make sure to generate it with
    something similar to:
     "make 2>&1 | tee /path/to/logfile" (sh/bash/ksh/zsh) or
     "make |& tee /path/to/logfile" (csh/tcsh)
   * Make sure your cvsup(1) configuration file specifies the 'ports-all'
     collection
   * Run cvsup(1) and attempt the build again
   * Check /usr/ports/UPDATING for information pertinent to your build
     failure
   * 99% of the commonly reported build failures can be solved by
     running "portupgrade -a"
   * Read the FAQs at http://www.FreeBSD.org/gnome/
   * Search the archives of freebsd-gnome@FreeBSD.org.  Archives can be
     searched at http://www.freebsd.org/gnome/index.html#search

If you have not performed each of the above suggestions, don't bother asking
for help.  The chances are good that you'll simply be told to perform one of
the aforementioned steps.


regards,
I become FreeBSD fun boy.
beginner
Junior Member
 
Posts: 13
Joined: 17 Jan 2010, 20:42

Postby sixtydoses » 27 Jan 2010, 23:21

Code: Select all
Requested 'glib-2.0 >= 2.21.2' but version of GLib is 2.20.5


Looks like your [FILE]devel/glib20[/FILE] version is outdated. Current version is 2.22.4. Try to upgrade it.
User avatar
sixtydoses
Member
 
Posts: 400
Joined: 18 Nov 2008, 15:21
Location: Near my dentist.

Postby beginner » 28 Jan 2010, 16:48

Hello SirDice and sixtydoses,

Tonight I installed [FILE]devel/glib20[/FILE] (2.22.4) updated port and [FILE]devel/gvfs[/FILE] port enabling fuse support successfully. Then I restarted my pc and I tested it again. The same failure happened. Anyway it is ok for me because I knew that I could not save gedit text file on my Transcend ntfs hdd and I avoid to save on it. I will use VIM or Emacs instead of Gedit in case.
Thank you very much for helping me out till this step. I very appreciate you all. :)

BR,
I become FreeBSD fun boy.
beginner
Junior Member
 
Posts: 13
Joined: 17 Jan 2010, 20:42


Return to Peripheral Hardware

Who is online

Users browsing this forum: No registered users and 0 guests