KDE4 doesn't load..

The K Desktop Environment

KDE4 doesn't load..

Postby BSD_User » 26 Jan 2010, 18:44

First, I hope this post is in the right section.

Secondly, I need help.

I have just installed FreeBSD 7.2 from a clean install, and installed all the ports from disc that I felt was needed.

The problem is that I am trying to start up KDE4 and it would load up to the login screen, but my keyboard and mouse wouldn't work. So, I looked around and found that if you load hald_enable and dbus_enable into the rc.conf file then problem solved.

Now that I have changed rc.conf file and rebooted to load kde4, kde4 won't even show a login. It freezes or hangs on load up and I have to revert back to single user mode from Ctrl + Alt + Del.

Does anyone have a solution to this? My system hasn't had problems so far when just at the command line. Any help would be appreciative.

Thanks in advance.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby Daisuke_Aramaki » 26 Jan 2010, 18:54

Any reason why you went with 7.2? 8.0 is the latest release.

Coming to kde4, if i understand correctly you installed kde4, but how are you trying to start X. Are you using simple startx or you are expecting KDM to login? If you have installed KDM, there are a couple of things you need to do before it is setup, and it is clearly explained in the handbook. So please have a look.

http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11-wm.html

And I think you should also enable kdm in your rc.conf. But please verify, coz I don't use KDE, so I might be wrong

If you don't want KDM, and want the simple xinit script (.xinitrc) to start KDE, then do this.

Code: Select all
echo "exec /usr/local/kde4/bin/startkde" > ~/.xinitrc
User avatar
Daisuke_Aramaki
Member
 
Posts: 220
Joined: 09 Feb 2009, 20:51
Location: Stuttgart, Germany

Postby BSD_User » 26 Jan 2010, 19:16

I decided to go with 7.2 because I have read that it is sometimes better to go with the STABLE version rather than the CURRENT because the STABLE is more updated than the CURRENT version. I was using 6.4 up until recent, but decided to upgrade.

My current settings for KDE are a ttys file for kdm set at:

Code: Select all
ttyv8 "/usr/local/kde4/bin/kdm -nodaemon" xterm on secure


an ~/.xinitrc file under root with:

Code: Select all
exec /usr/local/kde4/bin/startkde


and I have removed hald_enable and dbus_enable from the rc.conf file.
With all these settings I have not been able to login to KDE4. It loads until login, but I get no response from the keyboard or mouse.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby BSD_User » 26 Jan 2010, 19:22

I just also tried to use startx after disabling ttys file on terminal 9, and it loads into kde, bypassing the login, but still no response from the keyboard or mouse. Thanks for the quick reply by the way.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby Daisuke_Aramaki » 26 Jan 2010, 19:24

May i know what version of Xorg you are running? If you are using the latest, hal and dbus are essential for auto detection of devices like keyboard and mouse.

Anyway, coming to your startx script, why are you trying to start kde as root? Not advisable at all. You do have a user account setup right? So add the 'startkde' part as i had mentioned earlier in that user's .xinitrc.

Also, have your tried if X works at all? I mean not KDE. If not, then you have an Xorg issue, rather than kde.
User avatar
Daisuke_Aramaki
Member
 
Posts: 220
Joined: 09 Feb 2009, 20:51
Location: Stuttgart, Germany

Postby instain » 26 Jan 2010, 19:29

I used to use the ttys method but it broke for me last week. I can't tell from your description if it was the same type of problem or not. I saw that the new recommended way to start kde4 is to add the following to rc.conf and leave ttys alone:

Code: Select all
local_startup="${local_startup} /usr/local/kde4/etc/rc.d"
kdm4_enable="YES"


Changing to this method fixed it for me. Might be worth a try.

http://wiki.freebsd.org/KDE4/Install
instain
Junior Member
 
Posts: 14
Joined: 17 Nov 2008, 14:24

Postby BSD_User » 26 Jan 2010, 19:31

I changed my ~/.xinitrc file under my user account. I am not sure how to check the xorg version. I tried using pkg_version xorg, but it gave me a long list and didn't say which version when coming to xorg, and also with X. I am not sure how to check X once KDE has been installed.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby BSD_User » 26 Jan 2010, 19:51

I tried instain's suggestion, but it won't allow keyboard or mouse still.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby BSD_User » 26 Jan 2010, 20:42

I also did as the handbook suggested, but with no such luck.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby BSD_User » 27 Jan 2010, 01:48

It seems as though KDE isn't the only victim. It seems that 7.2 is causing problems because I cannot use xdm either. Any help would be greatly appreciated. I tried to login via xdm by startx, but the keyboard and mouse do not work in that environment either. Would it be wise to revert back to version 6.4 or is 8.0 better? I am new to this stuff, but enjoy plugging away at a solution. I am not sure if there is an answer to my question, but I hope that this post helps.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby BSD_User » 27 Jan 2010, 02:17

After careful consideration, I am going to go back to just command line usage. GUIs are nice, but not if they soak up a lot of time spending trying to configure issues such as start up, and program application stability. I'll leave that to someone with a little more understanding. Thanks again for the help on this question.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby Daisuke_Aramaki » 27 Jan 2010, 09:45

BSD_User wrote:After careful consideration, I am going to go back to just command line usage. GUIs are nice, but not if they soak up a lot of time spending trying to configure issues such as start up, and program application stability. I'll leave that to someone with a little more understanding. Thanks again for the help on this question.


A few questions.

1. Upon trying the aforementioned methods are you able to get into a working KDE desktop? Forget the mouse and keyboard not working for the time being.

2. If yes, then your graphic card is detected fine and we can go to the next level.

3. I am sure your xorg-server version should be greater than 1.4. Hal and dbus are actually needed to autodetect devices like keyboard and mice. so add the hal_enable and dbus_enable entries back in your rc.conf.

4. If that didn't work please post your [FILE]xorg.conf[/FILE] here and also your [FILE]/var/log/Xorg.0.log[/FILE]

A related question. Do you have an [FILE]xorg.conf[/FILE] to start with? If not, generate it first. As root, execute this command

Code: Select all
Xorg -configure


This will generate a file called [FILE]xorg.conf.new[/FILE]. Rename this file as [FILE]xorg.conf[/FILE] and move to [FILE]/etc/X11/xorg.conf[/FILE]
User avatar
Daisuke_Aramaki
Member
 
Posts: 220
Joined: 09 Feb 2009, 20:51
Location: Stuttgart, Germany

Postby BSD_User » 28 Jan 2010, 17:16

Sorry, to be the bearer of bad news, but since my last post I have reinstalled FreeBSD 6.4. I had tried to use not only, KDE, but XDM as well in a standalone with X, but none of the two would work. Either I had problems loading from startx, xinit, or from boot-up, while having numerous configurations as I thought possible. Examples such as running without hald or dbus, running with hald and dbus, using startx at command line and disabling KDM or XDM, depending, and having no such luck. The farthest I was able to get into KDE at any given point was to the desktop, but with no keyboard or mouse. It seemed as though the Desktop was working, but I could not navigate through the files. Oh, I tried to use X configure and copied the new conf to the old file and rebooted, but again no such progress. If anyone can find a definite workaround this situation, then will be most grateful, but until then I am back on FreeBSD 6.4.
The laptop I was running was an old Dell P3 with 512 MB of RAM. Not sure if this info is relative, but I hope any of this helps someone.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby OH » 28 Jan 2010, 21:19

BSD_User wrote:I decided to go with 7.2 because I have read that it is sometimes better to go with the STABLE version rather than the CURRENT because the STABLE is more updated than the CURRENT version. I was using 6.4 up until recent, but decided to upgrade.


You should really upgrade to 8.0. I doubt very strongly that a recent kde4 will function (properly) under 6.4.
CURRENT is version 9.0 There are STABLE-versions for 7.2 and 8.0, but I'd recommend sticking to 8.0 security errata branch (or as it's called in csup: RELENG_8_0)

See this page
OH
Member
 
Posts: 209
Joined: 25 Aug 2009, 09:32
Location: The Netherlands

Postby BSD_User » 28 Jan 2010, 21:26

I just wanted to thank everyone for all the posts. I found my solution and IT WORKS!!! I did some extensive searching and found that I can load KDE4 on FreeBSD 7.2,(Yes, I went back to 7.2), without hald_enable or dbus_enable in my rc.conf file. There is a snippet that I found that told me how to fix my problem. The site is at:

http://www.dev-urandom.com/user/xorg.php

and if you have trouble accessing the site, then here is what you might need to do:

Add this to your xorg.conf file, and remove hald_enable and dbus_enable from you rc.conf:

Code: Select all
Section "ServerFlags"
   option   "AutoAddDevices"   "off"
   option   "AllowEmptyInput"   "off"
EndSection

This is an entire new section in FreeBSD 7.2 and every line was added. I rebooted and Thank God for the person who found this solution it worked!!

Hope this helps. Made my day.
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby BSD_User » 28 Jan 2010, 21:43

Sorry!!! Don't disable dbus in rc.conf, just hald_enable. If dbus is disabled then you can't login, but mouse and keyboard work. Added dbus_enable to rc.conf and so far so good. Later!
BSD_User
Junior Member
 
Posts: 12
Joined: 26 Jan 2010, 18:34
Location: Maryland, USA

Postby zeissoctopus » 03 Feb 2010, 16:17

I use dbus, hald in rc.conf.
I use Xorg -configure

Since dbus + hald are able to detect keyboard and mice themself, I remove any lines about keyboard and mice in /etc/X11/xorg.conf.

xorg.conf.new, default output of Xorg -configure include lines about keyboard and mice, for example.
Code: Select all
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection


By dbus and hald, you do not need any keyboard and mice setting in your /etc/X11/xorg.conf
Code: Select all
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
EndSection
zeissoctopus
Member
 
Posts: 140
Joined: 08 Aug 2009, 09:09
Location: Hong Kong


Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests