Installing Firefox

Installing and maintaining the FreeBSD Ports Collection or FreeBSD Packages (i.e. third party software).

Installing Firefox

Postby inux » 06 Jan 2010, 03:45

Hello, I tried to install firefox from ports but when I try to install gives me this:
Code: Select all
# cd /usr/ports/www/firefox
# make install clean
===>  firefox-2.0.0.20_9,1 is forbidden: too many security issues  http://www.vuxml.org/freebsd/922d2398-9e2d-11de-a998-0030843d3802.html
http://www.vuxml.org/freebsd/49e8f2ee-8147-11de-a994-0030843d3802.html.
*** Error code 1

What does this mean?
inux
Junior Member
 
Posts: 24
Joined: 30 Dec 2009, 12:37

Postby sixtydoses » 06 Jan 2010, 04:53

Use [FILE]www/firefox35[/FILE], firefox2 is deprecated.

http://portsmon.freebsd.org/portoverview.py?category=www&portname=firefox
User avatar
sixtydoses
Member
 
Posts: 400
Joined: 18 Nov 2008, 15:21
Location: Near my dentist.

Postby abence » 26 Apr 2010, 20:36

sixtydoses wrote:Use [FILE]www/firefox35[/FILE], firefox2 is deprecated.

http://portsmon.freebsd.org/portoverview.py?category=www&portname=firefox


Hi, i now install gnome and i have got an error code:
Code: Select all
===>  Installing for gnome2-2.26.3
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/gweather-applet-2 - found
===>   gnome2-2.26.3 depends on executable: gnome-audio-profiles-properties - found
===>   gnome2-2.26.3 depends on executable: gnome-dictionary - found
===>   gnome2-2.26.3 depends on executable: eog - found
===>   gnome2-2.26.3 depends on executable: gconf-editor - found
===>   gnome2-2.26.3 depends on executable: gnect - found
===>   gnome2-2.26.3 depends on executable: gedit - found
===>   gnome2-2.26.3 depends on executable: gnome-terminal - found
===>   gnome2-2.26.3 depends on executable: gnome-session - found
===>   gnome2-2.26.3 depends on executable: bug-buddy - found
===>   gnome2-2.26.3 depends on executable: gnome-system-monitor - found
===>   gnome2-2.26.3 depends on executable: nautilus - found
===>   gnome2-2.26.3 depends on file: /usr/local/sbin/gdm - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/gnome/help/user-guide/C/user-guide.xml - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/sounds/question.wav - found
===>   gnome2-2.26.3 depends on file: /usr/local/libdata/pkgconfig/libgail-gnome.pc - found
===>   gnome2-2.26.3 depends on executable: file-roller - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/themes/HighContrast/gtk-2.0/gtkrc - found
===>   gnome2-2.26.3 depends on executable: gok - found
===>   gnome2-2.26.3 depends on executable: gcalctool - found
===>   gnome2-2.26.3 depends on file: /usr/local/lib/X11/fonts/bitstream-vera/Vera.ttf - found
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/gnome-netstatus-applet - found
===>   gnome2-2.26.3 depends on executable: dasher - found
===>   gnome2-2.26.3 depends on executable: evolution - found
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/evolution-webcal - found
===>   gnome2-2.26.3 depends on executable: network-admin - found
===>   gnome2-2.26.3 depends on executable: vino-passwd - found
===>   gnome2-2.26.3 depends on executable: exchange-connector-setup-2.26 - not found
===>    Verifying install for exchange-connector-setup-2.26 in /usr/ports/mail/evolution-exchange
     => No directory for exchange-connector-setup-2.26.  Skipping..
===>   gnome2-2.26.3 depends on file: /usr/local/lib/gstreamer-0.10/.gstreamer-plugins-core.keep - found
===>   gnome2-2.26.3 depends on file: /usr/local/lib/gstreamer-0.10/libgstgconfelements.so - found
===>   gnome2-2.26.3 depends on executable: totem - found
===>   gnome2-2.26.3 depends on executable: gnome-control-center - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/gnome-background-properties/gnome-nature.xml - found
===>   gnome2-2.26.3 depends on executable: evince - found
===>   gnome2-2.26.3 depends on executable: alacarte - found
===>   gnome2-2.26.3 depends on executable: gnome-power-manager - found
===>   gnome2-2.26.3 depends on executable: orca - found
===>   gnome2-2.26.3 depends on executable: gnome-mount - found
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/notification-daemon - found
===>   gnome2-2.26.3 depends on executable: seahorse-agent - not found
===>    Verifying install for seahorse-agent in /usr/ports/security/seahorse-plugins
===>   seahorse-plugins-2.26.2_2 depends on file: /usr/local/lib/firefox/libgtkembedmoz.so - not found
===>    Verifying install for /usr/local/lib/firefox/libgtkembedmoz.so in /usr/ports/www/firefox
===>  firefox-2.0.0.20_9,1 is forbidden: too many security issues  http://www.vuxml.org/freebsd/922d2398-9e2d-11de-a998-0030843d3802.html 
http://www.vuxml.org/freebsd/49e8f2ee-8147-11de-a994-0030843d3802.html.
*** Error code 1

Stop in /usr/ports/www/firefox.
*** Error code 1

Stop in /usr/ports/security/seahorse-plugins.
*** Error code 1

Stop in /usr/ports/security/seahorse-plugins.
*** Error code 1

Stop in /usr/ports/x11/gnome2.
*** Error code 1

Stop in /usr/ports/x11/gnome2.
Server-pc#
Server-pc#
Server-pc#
Server-pc#
Server-pc#
Server-pc# make install
===>  Installing for gnome2-2.26.3
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/gweather-applet-2 - found
===>   gnome2-2.26.3 depends on executable: gnome-audio-profiles-properties - found
===>   gnome2-2.26.3 depends on executable: gnome-dictionary - found
===>   gnome2-2.26.3 depends on executable: eog - found
===>   gnome2-2.26.3 depends on executable: gconf-editor - found
===>   gnome2-2.26.3 depends on executable: gnect - found
===>   gnome2-2.26.3 depends on executable: gedit - found
===>   gnome2-2.26.3 depends on executable: gnome-terminal - found
===>   gnome2-2.26.3 depends on executable: gnome-session - found
===>   gnome2-2.26.3 depends on executable: bug-buddy - found
===>   gnome2-2.26.3 depends on executable: gnome-system-monitor - found
===>   gnome2-2.26.3 depends on executable: nautilus - found
===>   gnome2-2.26.3 depends on file: /usr/local/sbin/gdm - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/gnome/help/user-guide/C/user-guide.xml - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/sounds/question.wav - found
===>   gnome2-2.26.3 depends on file: /usr/local/libdata/pkgconfig/libgail-gnome.pc - found
===>   gnome2-2.26.3 depends on executable: file-roller - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/themes/HighContrast/gtk-2.0/gtkrc - found
===>   gnome2-2.26.3 depends on executable: gok - found
===>   gnome2-2.26.3 depends on executable: gcalctool - found
===>   gnome2-2.26.3 depends on file: /usr/local/lib/X11/fonts/bitstream-vera/Vera.ttf - found
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/gnome-netstatus-applet - found
===>   gnome2-2.26.3 depends on executable: dasher - found
===>   gnome2-2.26.3 depends on executable: evolution - found
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/evolution-webcal - found
===>   gnome2-2.26.3 depends on executable: network-admin - found
===>   gnome2-2.26.3 depends on executable: vino-passwd - found
===>   gnome2-2.26.3 depends on executable: exchange-connector-setup-2.26 - not found
===>    Verifying install for exchange-connector-setup-2.26 in /usr/ports/mail/evolution-exchange
     => No directory for exchange-connector-setup-2.26.  Skipping..
===>   gnome2-2.26.3 depends on file: /usr/local/lib/gstreamer-0.10/.gstreamer-plugins-core.keep - found
===>   gnome2-2.26.3 depends on file: /usr/local/lib/gstreamer-0.10/libgstgconfelements.so - found
===>   gnome2-2.26.3 depends on executable: totem - found
===>   gnome2-2.26.3 depends on executable: gnome-control-center - found
===>   gnome2-2.26.3 depends on file: /usr/local/share/gnome-background-properties/gnome-nature.xml - found
===>   gnome2-2.26.3 depends on executable: evince - found
===>   gnome2-2.26.3 depends on executable: alacarte - found
===>   gnome2-2.26.3 depends on executable: gnome-power-manager - found
===>   gnome2-2.26.3 depends on executable: orca - found
===>   gnome2-2.26.3 depends on executable: gnome-mount - found
===>   gnome2-2.26.3 depends on file: /usr/local/libexec/notification-daemon - found
===>   gnome2-2.26.3 depends on executable: seahorse-agent - not found
===>    Verifying install for seahorse-agent in /usr/ports/security/seahorse-plugins
===>   seahorse-plugins-2.26.2_2 depends on file: /usr/local/lib/firefox/libgtkembedmoz.so - not found
===>    Verifying install for /usr/local/lib/firefox/libgtkembedmoz.so in /usr/ports/www/firefox
===>  firefox-2.0.0.20_9,1 is forbidden: too many security issues  http://www.vuxml.org/freebsd/922d2398-9e2d-11de-a998-0030843d3802.html 
http://www.vuxml.org/freebsd/49e8f2ee-8147-11de-a994-0030843d3802.html.
*** Error code 1

Stop in /usr/ports/www/firefox.
*** Error code 1

Stop in /usr/ports/security/seahorse-plugins.
*** Error code 1

Stop in /usr/ports/security/seahorse-plugins.
*** Error code 1

Stop in /usr/ports/x11/gnome2.
*** Error code 1

Stop in /usr/ports/x11/gnome2.


What's i do now?

//Sorry, i am hungary, and i cann't find a hungary forum.
abence
Junior Member
 
Posts: 3
Joined: 26 Apr 2010, 20:31

Postby crsd » 26 Apr 2010, 20:46

Please update your ports tree.
crsd
Member
 
Posts: 420
Joined: 24 Nov 2008, 02:15
Location: Russia, Krasnodar

Postby abence » 26 Apr 2010, 20:56

crsd wrote:Please update your ports tree.


How that?
abence
Junior Member
 
Posts: 3
Joined: 26 Apr 2010, 20:31

Postby crsd » 26 Apr 2010, 20:58

[url=Handbook]http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/ports-using.html[/url]
crsd
Member
 
Posts: 420
Joined: 24 Nov 2008, 02:15
Location: Russia, Krasnodar

Postby SirDice » 27 Apr 2010, 06:55

Your ports tree is horribly outdated. [port]www/firefox[/port] should install 3.6.x, not 2.0.x. Gnome2 should be 2.28.x, not 2.26.x.


Handbook: Chapter 24.3 Portsnap: A Ports Collection Update Tool
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16196
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby abence » 27 Apr 2010, 16:24

SirDice wrote:Your ports tree is horribly outdated. [port]www/firefox[/port] should install 3.6.x, not 2.0.x. Gnome2 should be 2.28.x, not 2.26.x.


Handbook: Chapter 24.3 Portsnap: A Ports Collection Update Tool


Ok, thx, i now writed portsnap fetch.
abence
Junior Member
 
Posts: 3
Joined: 26 Apr 2010, 20:31


Return to Installation and Maintenance of FreeBSD Ports or Packages

Who is online

Users browsing this forum: masayoshi, Yahoo [Bot] and 1 guest