How to configure Cisco for Cisco® Fast EtherChannel® mode

I have a question. The Freebsd FreeBSD supports the LACP mode and Cisco® Fast EtherChannel® mode. I know how to set teaming mode in freebsd FreeBSD, but I don't know how to set the Cisco for FEC mode. The freebsd FreeBSD handbook teaches how to set the Cisco for LACP, but doesn't teach for this, so who can teach me how to set it and verify it. Thanks.
 
Here is a basic example to configure ports 1 and 2 into a LACP Etherchannel from a Cisco 3560G series switch

Code:
conf t

interface Port-channel 1
description My FreeBSD EtherChannel
switchport mode access
exit

interface GigabitEthernet0/1
description First port on FreeBSD server
switchport mode access
channel-group 1 mode active
exit

interface GigabitEthernet0/2
description Second port on FreeBSD server
switchport mode access
channel-group 1 mode active
end

write mem
 
Thanks for all.

My switch is a Cisco 2950 and can set for @KernelPanic's sample, but how to verify Cisco® Fast EtherChannel mode is activated?

I input the command ifconfig in FreeBSD and can see:

Code:
lagg0:.....
      ......
      status:active
      laggproto:fec
      laggport: re1 flags=4<ACTIVE>
      laggportL re0 flags=4<ACTIVE>

but if I did not set @KernelPanic's sample in the Cisco switch, it still displays the same as above. so how to check network is performing in FEX mode. Thanks.
 
Last edited by a moderator:
Example from a 4507 (to show whether the etherchannel is up on the Cisco end):
Code:
per-4507-1>[B]sho etherchannel summary[/B]
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 8
Number of aggregators:           8

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Te1/1(P)    Te4/1(P)
2      Po2(SU)         LACP      Te1/2(P)    Te4/2(P)
3      Po3(SU)         LACP      Gi2/7(P)    Gi2/8(P)
4      Po4(SU)         LACP      Gi2/9(P)    Gi2/10(P)
5      Po5(SU)         LACP      Gi2/15(P)   Gi2/16(P)   Gi2/17(P)
6      Po6(SU)         LACP      Te1/3(P)    Te3/1(P)

etc.
 
Thanks to @throAU,

I follow @KernelPanic's sample to set the Cisco:
Code:
conf t
interface range FastEthernet 0/18 - 19
switchport mode access
channel-group 1 mode active

but I get EtherChannel summary, it's show as follows:

Code:
cisco#show etherchannel su
cisco#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 4
Number of aggregators:           4

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         LACP      Fa0/18(I)   Fa0/19(I)   
4      Po4(SD)          -        
5      Po5(SD)         LACP      Fa0/13(D)   Fa0/15(D)   
6      Po6(SD)          -

I should not be performed on FEC mode?

Code:
Fa0/18(I)   Fa0/19(I)

If FEC mode was performed, it should be shown as
Code:
Fa0/18(P)   Fa0/19(P)
?
 
Last edited by a moderator:
Can you post your rc.conf LAGG entries?

My previous Cisco example should work with the following setup:
Code:
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto lacp laggport re0 laggport re1"
ipv4_addrs_lagg0="<your IP goes here>"

The important part is that if you set the Cisco switch to use IEEE® 802.3ad Link Aggregation Control Protocol (LACP) you should set your FreeBSD server to do the same via the laggproto option.

You can confirm your port channel is working on the Cisco using show etherchannel 1 summary. When both ports registered as "P - bundled in port-channel" your link aggregation is working properly.

Off-Topic: Personally, I'd only use things like FEC or PAgP in a "Cisco-only" environment.
 
Thanks to @KernelPanic.

My settings as follows:

LACP Mode
FreeBSD Configurations:
Code:
ifconfig_lagg0="inet 10.1.2.51/16 laggproto lacp laggport re0 laggport re1"
ifconfig_re0="up media autoselect mtu 1500 -wol"
ifconfig_re1="up media autoselect mtu 1500 -wol"
cloned_interfaces="lagg0"

Cisco Configurations:
Code:
cisco#configure terminal     
cisco(config)#interface range f
cisco(config)#interface range fastEthernet 0/17 - 18
cisco(config-if-range)#channel-protocol lacp 
cisco(config-if-range)#channel-group 1 mode active

Result:
FreeBSD side:
Code:
lagg0:  ...............
        status: active
        laggproto lacp
        laggport: re1 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
        laggport: re0 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
Cisco side:
Code:
cisco#show etherchannel 1 summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 4
Number of aggregators:           4

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa0/17(P)   Fa0/18(Pd) 

cisco#show lacp neighbor 
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     

Channel group 1 neighbors

Partner's information:

                  LACP port                        Oper    Port     Port
Port      Flags   Priority  Dev ID         Age     Key     Number   State
Fa0/17    SA      32768     00e0.d8ff.ae8e   7s    0x1A6   0x5      0x3D  
Fa0/18    SA      32768     00e0.d8ff.ae8e   6s    0x1A6   0x6      0x3D

===========================================================================================


FEC Mode
FreeBSD Configurations:
Code:
ifconfig_lagg0="inet 10.1.2.51/16 laggproto fec laggport re0 laggport re1"
ifconfig_re0="up media autoselect mtu 1500 -wol"
ifconfig_re1="up media autoselect mtu 1500 -wol"
cloned_interfaces="lagg0"

Cisco Configurations:
Code:
cisco#configure terminal 
cisco(config)#interface range fastEthernet 0/17 - 18
cisco(config-if-range)#switchport mode access 
cisco(config-if-range)#channel-group 1 mode active

Result:
FreeBSD side:
Code:
lagg0:  ...............
        status: active
        laggproto fec
        laggport: re1 flags=4<ACTIVE>
        laggport: re0 flags=4<ACTIVE>
Cisco side:
Code:
cisco#show etherchannel 1 summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 4
Number of aggregators:           4

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         LACP      Fa0/17(I)   Fa0/18(I)


I don't know why network can't be performed on FEC mode. My configuration is wrong? Thanks.
 
Last edited by a moderator:
If you use laggproto fec I believe you need to set the ports on Cisco side to channel-group 1 mode on. This enables ether-channeling on both sides without any sort of negotiating protocol.

However, as noted by the Handbook:
Code:
Cisco Fast EtherChannel (FEC), is a static setup and does not negotiate aggregation with the peer or exchange frames to monitor the link. [B]If the switch supports LACP then that should be used instead.[/B]
 
Re:

mannychang said:
Thanks for all.

My switch is a Cisco WS-C2960-24TT-L and can set for @KernelPanic's sample, but how to verify Cisco® Fast EtherChannel mode is activated?

I input the command ifconfig in FreeBSD and can see:

Code:
lagg0:.....
      ......
      status:active
      laggproto:fec
      laggport: re1 flags=4<ACTIVE>
      laggportL re0 flags=4<ACTIVE>

but if I did not set @KernelPanic's sample in the Cisco switch, it still displays the same as above. so how to check network is performing in FEX mode. Thanks.
Code:
cisco#configure terminal     
cisco(config)#interface range f
cisco(config)#interface range fastEthernet 0/17 - 18
cisco(config-if-range)#channel-protocol lacp 
cisco(config-if-range)#channel-group 1 mode active
I got the same problem,I configure Cisco switch like this, but in FreeBSD I have no idea. Have you already solved this?
 
Last edited by a moderator:
Re: How to configure Cisco for Cisco® Fast EtherChannel® mod

Just to chip in here for what it's worth, the Etherchannel mode at which a Cisco switchport communicates with is set by the channel-group 1 mode [u]xxx[/u] command on the physical interface, where xxx is one of the following:

  • passive - speaks LACP if something speaks LACP to it,
  • active - speaks LACP regardless of what is at the other end of the bundleea,
  • auto - speaks PAgP is if something speaks PAgP to it,
  • desirable - speaks PAgP regardless of what is at the other end of the bundle,
  • on - disables both PAgP and LACP conversations and assumes it is in an ether-channel bundle regardless!

Notes:
  • All physical ports in an etherchannel bundle need to be the same "type" at all times,
  • PAgP is (I thought) a Cisco proprietary protocol...

James.
 
Back
Top