Solved ZFS not loading pool in multi-user

Hi,

after reboot I was surprised with a "no pools available to import" error during boottime, leaving my system stuck with a failed /etc/rc script.

I have only one zpool, geli encrypted, pretty much the defaults zfs settings on install.

The problem does not exist in single-user mode and I am able to load my zpool just fine.

Has anybody faced this issue before? Or do you know how to fix this?
 
Is that your encrypted HD from this post?

Did you export the zpool before using it on the new box?
See zpool-export(8) and zpool-import(8).
 
Is that your encrypted HD from this post?

Did you export the zpool before using it on the new box?
See zpool-export(8) and zpool-import(8).
Yes indeed it's the same HD but its not a different box, I just went through these steps and this happened when rebooting.
 
Can you share a photograph?

As many details as possible, please. The exact version of FreeBSD, and so on.

Sure. Version is 13.1-RELEASE, installed recently. This happened after loading vboxdrv kernel modules which caused the kernel to fail on reboot. I fixed it by mounting my filesystem with a live iso then this happened.


IMG_20220530_215030.jpg


Single-user mode works correctly but I need to go multi-user on this laptop.

Here is dmesg, though not very helpful:

IMG_20220530_215351.jpg


/boot/loader.conf is pretty normal
IMG_20220530_215648.jpg
 

This is the last things I've done before rebooting, I simply removed vboxdrv from /boot/loader.conf.

Here's my fstab, but this hasn't changed from when it used to work.
IMG_20220530_225755.jpg
 
For debugging remove step by step all from /etc/fstab what is not necessary.
Start with removing the last line and then the next last line ...



also try to revert this. In a seperate step.
This had no effects it seems.

Mountpoints seems all fine too
IMG_20220530_234044.jpg
 
zroot should be /zroot not /
Well done, this was it! Thank you so much, I would have never figured that out by myself.

I must have changed that while messing with the live ISO just before, trying to learn zfs the hard way. I didn't think changes would have been applied to the actual install zfs pool.
 
zroot should be /zroot not /

Not quite. There should be no mountpoint (or mountpoint none).

From <https://www.freebsd.org/cgi/man.cgi?query=bectl&sektion=8&manpath=FreeBSD+14.0-current>:

Code:
     … a simplified pool may be laid out as such:

           NAME                    CANMOUNT        MOUNTPOINT
           zroot
           zroot/ROOT              noauto          none
           zroot/ROOT/default      noauto          none
           zroot/usr               off             /usr
           zroot/usr/home          on              /usr/home
           zroot/var               on              /var

Here:

Code:
% zfs get mountpoint august
NAME    PROPERTY    VALUE       SOURCE
august  mountpoint  none        local
% zfs list -t filesystem | grep ROOT
august/ROOT                                230G   140G    88K  none
august/ROOT/n250511-5f73b3338ee-d         64.6G   140G  45.8G  none
august/ROOT/n252381-75d20a5e386-b         23.5G   140G  48.7G  none
august/ROOT/n252450-5efa7281a79-a         6.86G   140G  48.7G  none
august/ROOT/n252483-c8f8299a230-b         7.85G   140G  48.0G  none
august/ROOT/n252505-cc68614da82-a         5.24G   140G  48.0G  none
august/ROOT/n252531-0ce7909cd0b-h         10.1G   140G  49.2G  none
august/ROOT/n252997-b6724f7004c-c         8.10G   140G  49.1G  none
august/ROOT/n253116-39a36707bd3-e         7.58G   140G  49.7G  none
august/ROOT/n253343-9835900cb95-c         9.31G   140G  49.6G  none
august/ROOT/n253776-d5ad1713cc3-b         14.1G   140G  51.3G  none
august/ROOT/n253861-92e6b4712b5-e         14.4G   140G  54.1G  none
august/ROOT/n254268-50e244964e9-d         11.0G   140G  56.2G  none
august/ROOT/n254693-d7696096209-f         14.1G   140G  59.2G  none
august/ROOT/n255078-e140d551b78-h         4.80M   140G  60.9G  none
august/ROOT/n255588-01235012e5b-b-c1d     3.31M   140G  63.5G  none
august/ROOT/n255588-01235012e5b-d         15.7G   140G  61.5G  none
august/ROOT/n255769-f16e38162c7-c         4.36M   140G  65.9G  none
august/ROOT/n255769-f16e38162c7-d         17.9G   140G  65.9G  none
% bectl list -c creation
BE                        Active Mountpoint Space Created
n250511-5f73b3338ee-d     -      -          64.6G 2021-11-13 15:43
n252381-75d20a5e386-b     -      -          23.5G 2022-01-12 23:23
n252450-5efa7281a79-a     -      -          6.87G 2022-01-14 19:27
n252483-c8f8299a230-b     -      -          7.85G 2022-01-17 14:24
n252505-cc68614da82-a     -      -          5.24G 2022-01-18 14:26
n252531-0ce7909cd0b-h     -      -          10.1G 2022-02-06 12:24
n252997-b6724f7004c-c     -      -          8.10G 2022-02-11 23:07
n253116-39a36707bd3-e     -      -          7.58G 2022-02-20 07:03
n253343-9835900cb95-c     -      -          9.32G 2022-02-27 14:58
n253776-d5ad1713cc3-b     -      -          14.1G 2022-03-18 09:31
n253861-92e6b4712b5-e     -      -          14.5G 2022-04-02 16:02
n254268-50e244964e9-d     -      -          11.0G 2022-04-09 18:50
n254693-d7696096209-f     -      -          14.2G 2022-04-27 17:41
n255078-e140d551b78-h     -      -          7.09M 2022-05-11 21:18
n255588-01235012e5b-d     -      -          15.7G 2022-05-15 00:29
n255588-01235012e5b-b-c1d -      -          1.16G 2022-05-23 18:11
n255769-f16e38162c7-c     -      -          245M  2022-05-29 05:15
n255769-f16e38162c7-d     NR     /          18.2G 2022-05-30 03:46
%
 
Top