Yet Black Screen at X with NVidia GeForce 410M (GF119M) in Vaio VPC-EG17FB

João Luis

New Member

Reaction score: 1
Messages: 19

Hi Folks,

I'm getting beaten a couple months by my nvidia card.
I got beaten to put it working in FreeBSD 11 and now in FreeBSD 12.
I've installed system and immediately updated via freebsd-update to 12.1-RELEASE-p5 and no success to put nvidia working ever since.
I already tried all suggestions put here and anothers sources. So, i am still using the vesa driver (the only X driver that I got making work) that makes some apps to show me some errors/warnings related to glx and others.
I use just 2 separated files at /usr/local/etc/X11/xorg.conf.d to configure X, the nvidia driver and the files section due to some fonts I'd like to test with nvidia... but I also tested just with the nvidia driver file. No success.
I've tried with nvidia 340 and 390 drivers via packages and nvidia downloaded drives as well. Few days nvidia-driver-390 was updated from 132 to 138 and remains the same.
I can't see any error in X log that can prevent brings screen up.

Could someone light me anything ??
 

Attachments

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,085
Messages: 33,642

Enable the NVidia driver (x11/nvidia-driver-390) and start X. Install misc/pastebinit. After running Xorg run cat /var/log/Xorg.0.log | pastebinit. Post the URL here so we can have a look at your logs.
 

diego

Member

Reaction score: 16
Messages: 53

I would recommend to install hw-probe in order to collect hardware information and logs of your computer. Its really easy and when its uploaded you can find similar computers / resources on the database.
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

Enable the NVidia driver (x11/nvidia-driver-390) and start X. Install misc/pastebinit. After running Xorg run cat /var/log/Xorg.0.log | pastebinit. Post the URL here so we can have a look at your logs.
The attached file has :

- dmesg
- /boot/loader.conf
- /etc/rc.conf
- pciconf -lv
- /usr/local/etc/X11/xorg.conf.d/ (nvidia driver and files section, the only 2 used files to config X)
- /var/log/Xorg.0.log
- /dev/nvidia* (nvidia related files existent in /dev/)
- /dev/input/
- /etc/devfs.rules

Tks in advance !
 

diego

Member

Reaction score: 16
Messages: 53

You haven't installed properly your nvidia driver. See https://bsd-hardware.info/index.php?probe=7d48bd3606&log=xorg.log
Code:
[  2172.874] (II) Module int10: vendor="X.Org Foundation"
[  2172.874]     compiled for 1.20.8, module version = 1.0.0
[  2172.874]     ABI class: X.Org Video Driver, version 24.1
[  2172.874] (II) VESA(0): initializing int10
Your Xorg server is using "vesa" driver instead "nvidia" ;)

For the installation of nvidia drivers, I would recommend this video (4 minutes) and have a look this youtuber content (its great)
View: https://www.youtube.com/watch?v=Q6KxMUY2aTU

Keep posting your progress
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

You haven't installed properly your nvidia driver. See https://bsd-hardware.info/index.php?probe=7d48bd3606&log=xorg.log
Code:
[  2172.874] (II) Module int10: vendor="X.Org Foundation"
[  2172.874]     compiled for 1.20.8, module version = 1.0.0
[  2172.874]     ABI class: X.Org Video Driver, version 24.1
[  2172.874] (II) VESA(0): initializing int10
Your Xorg server is using "vesa" driver instead "nvidia" ;)

For the installation of nvidia drivers, I would recommend this video (4 minutes) and have a look this youtuber content (its great)
View: https://www.youtube.com/watch?v=Q6KxMUY2aTU

Keep posting your progress
Hi, Diego !

You are absolutely right !! My Xorg server is using vesa driver... I cannot put the nvidia up yet. So, i cannot get any graphical app response using nvidia black screen.
About the video, i already try that... with the loader.conf cards of linux and nvidia and commented them out as well.

I am re-attaching the file of my initial post. It is all related to nvidia logs and attempts to bring it up. Maybe you could see any thing that it's making my screen with nvidia driver getting black and unavailable.

The attached file has :

- dmesg
- /boot/loader.conf
- /etc/rc.conf
- pciconf -lv
- /usr/local/etc/X11/xorg.conf.d/ (nvidia driver and files section, the only 2 used files to config X)
- /var/log/Xorg.0.log
- /dev/nvidia* (nvidia related files existent in /dev/)
- /dev/input/
- /etc/devfs.rules

BTW, I redid the procedure following the video... no progress.

I'm really grateful for your attention ... I'm trying to solve it a long time.

TKS in advance,

JL
 

Attachments

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,085
Messages: 33,642

In your rc.conf:
Code:
nvidia_name="nvidia"
nvidia_modeset_name="nvidia-modeset"
Where did you get those from? They don't do anything, just remove them.

According to your Xorg.0.log the driver is correctly loaded and the laptop's display is enabled:
Code:
[   193.666] (II) NVIDIA(0): Requested modes:
[   193.666] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[   193.666] (II) NVIDIA(0): Validated MetaModes:
[   193.666] (II) NVIDIA(0): MetaMode "DFP-0:nvidia-auto-select":
[   193.666] (II) NVIDIA(0):     Size: 1366 x 768
[   193.666] (II) NVIDIA(0):     cPATH (DFP-0): "nvidia-auto-select"
[   193.666] (II) NVIDIA(0):         Size          : 1366 x 768
[   193.666] (II) NVIDIA(0):         Offset        : +0 +0
[   193.666] (II) NVIDIA(0):         Panning
[   193.666] (II) NVIDIA(0):          Domain       : 1366 x 768
[   193.666] (II) NVIDIA(0):          Tracking Area: 1366 x 768 +0 +0
[   193.666] (II) NVIDIA(0):          Border       : 0,0,0,0
[   193.666] (II) NVIDIA(0): Virtual screen size determined to be 1366 x 768
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

In your rc.conf:
Code:
nvidia_name="nvidia"
nvidia_modeset_name="nvidia-modeset"
Where did you get those from? They don't do anything, just remove them.

According to your Xorg.0.log the driver is correctly loaded and the laptop's display is enabled:
Code:
[   193.666] (II) NVIDIA(0): Requested modes:
[   193.666] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[   193.666] (II) NVIDIA(0): Validated MetaModes:
[   193.666] (II) NVIDIA(0): MetaMode "DFP-0:nvidia-auto-select":
[   193.666] (II) NVIDIA(0):     Size: 1366 x 768
[   193.666] (II) NVIDIA(0):     cPATH (DFP-0): "nvidia-auto-select"
[   193.666] (II) NVIDIA(0):         Size          : 1366 x 768
[   193.666] (II) NVIDIA(0):         Offset        : +0 +0
[   193.666] (II) NVIDIA(0):         Panning
[   193.666] (II) NVIDIA(0):          Domain       : 1366 x 768
[   193.666] (II) NVIDIA(0):          Tracking Area: 1366 x 768 +0 +0
[   193.666] (II) NVIDIA(0):          Border       : 0,0,0,0
[   193.666] (II) NVIDIA(0): Virtual screen size determined to be 1366 x 768

Yes, it is... and that's exactly why I came to bother you.

BTW, the nvidia's name in rc.conf were cut off.

I have already tried lots of thing... with FreeBSD 11 i could get success with the post of tobik@ (https://forums.freebsd.org/threads/howto-setup-xorg-with-nvidias-driver.52311/)... but it did not work with FreeBSD 12 anymore. I have worked with drivers 390 and 340, cause both shows my card in it, using pkgs and ports... and "that beautiful" screen still black.

So what do you advise me, guys ?

Except throwing the laptop on the wall, of course.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,085
Messages: 33,642

Have you tried with an external monitor attached to your laptop? Maybe it just tries to switch to an invalid resolution or refreshrate for your internal display.
 

diego

Member

Reaction score: 16
Messages: 53

So what do you advise me, guys ?
The driver is loaded correctly. I have been in similar situation where the driver was loaded but didn't work neither ;)
Saying that I have two ideas...

1) Load the minimal configuration for the nvidia driver and reboot. (freebsd with set the best boardname). See if /var/log/Xorg.0.log is similar that before. (it looks silly but........just try it )
Code:
===> /usr/local/etc/X11/xorg.conf.d/driver-nvidia-minimal.conf
Section "Device"
    Identifier  "Device0"
    Driver      "nvidia"
    BusID      "PCI:1:0:0"
EndSection
2) Dont use the nvidia driver and try modesetting driver. This solution works in my current laptop with similar problem as you (driver properly installed but Xorg didnt work)
Code:
===> /usr/local/etc/X11/xorg.conf.d/driver-nvidia-minimal.conf
Section "Device"
    Identifier  "Device0"
    #Driver      "nvidia"
    Driver      "modesetting"
    BusID      "PCI:1:0:0"
EndSection
I got the feeling that option 2) might work for you using "modesetting" driver......
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

Have you tried with an external monitor attached to your laptop? Maybe it just tries to switch to an invalid resolution or refreshrate for your internal display.
I attached an external monitor on laptop. Report below in two cases:

1. With Vesa driver I still get the main screen (laptop) active but did not get the external monitor working. The xrandr's response at this case just shows one screen device.

2. With nvidia driver I still get the main screen black but i could use the external monitor in VGA mode.
The xrandr however shows two screens and their related resolutions.

Files with the Xorg logs of both cases are attached here, as well as the xrandr output of the nvidia case (2).

At least i see nvidia working in VGA mode.
 

Attachments

OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

The driver is loaded correctly. I have been in similar situation where the driver was loaded but didn't work neither ;)
Saying that I have two ideas...

1) Load the minimal configuration for the nvidia driver and reboot. (freebsd with set the best boardname). See if /var/log/Xorg.0.log is similar that before. (it looks silly but........just try it )
Code:
===> /usr/local/etc/X11/xorg.conf.d/driver-nvidia-minimal.conf
Section "Device"
    Identifier  "Device0"
    Driver      "nvidia"
    BusID      "PCI:1:0:0"
EndSection
2) Dont use the nvidia driver and try modesetting driver. This solution works in my current laptop with similar problem as you (driver properly installed but Xorg didnt work)
Code:
===> /usr/local/etc/X11/xorg.conf.d/driver-nvidia-minimal.conf
Section "Device"
    Identifier  "Device0"
    #Driver      "nvidia"
    Driver      "modesetting"
    BusID      "PCI:1:0:0"
EndSection
I got the feeling that option 2) might work for you using "modesetting" driver......

I have already tried that minimal configuration, Diego... but i did it again. With just Identifier and Driver, and Identifier, Driver and BusID.

Same result as reported to SirDice (2. With nvidia driver I still get the main screen black but i could use the external monitor in VGA mode. The xrandr however shows two screens and their related resolutions.)

And about "modesetting", maybe the system is missing some thing. The log is attached here.

...
 

Attachments

diego

Member

Reaction score: 16
Messages: 53

And about "modesetting", maybe the system is missing some thing. The log is attached here.
[ 603.894] (EE) open /dev/dri/card0: No such file or directory
For using "modesetting" driver you need a metaport for different versions of Linux DRM based on the FreeBSD version named drm-kmod. In the following post I found the solution for my laptop :)
(you could see even my comments there)

try this....
Code:
1) pkg install drm-kmod
2) Add extra modules on /etc/rc.conf:   (instead of /boot/loader.conf)

kld_list="linux linux64 cuse fuse  /boot/modules/i915kms.ko /boot/modules/amdgpu.ko acpi_video"

3) Correct default xorg.conf adding /usr/local/etc/X11/xorg.conf.d/driver-modesetting.conf
Section "Device"
        Identifier  "Card0"
        Driver      "modesetting"
        BusID       "PCI:1:0:0"
EndSection

4) reboot
It is always better to take the original driver (intel, nvidia, amd, etc) instead that "modesetting", but I have seen this driver running on my 2 FreeBSD's laptops and also a lot of Linux machines.

Good luck
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

Hi Folks !

Sorry for the great delay to answer... kids had to use the laptop.

Back to the problem, no progress.

Diego, I got the same error of missing dri devs... so i removed all nvidia packages and reinstalled the xorg and xf86 files. It still missing /dev/dri/card0. The Xorg.0.log and kldstat report is attached here.

I think i gonna wait for new nvidia versions drivers that, possibly, won't support my GF119M.

Thanks a lot, guys !!
JL
 

Attachments

shkhln

Daemon

Reaction score: 549
Messages: 1,521

  1. Modesetting doesn't work with Nvidia.
  2. Switching to a virtual console and back to Xorg helps with some black screen bugs.
  3. What about nvidia-settings?
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

Hi shkhln,

I got using Xorg only with vesa driver... so nvidia-settings answers me with
"ERROR: Unable to load info from any available system".

That's it.
 

shkhln

Daemon

Reaction score: 549
Messages: 1,521

Hi shkhln,

I got using Xorg only with vesa driver... so nvidia-settings answers me with
"ERROR: Unable to load info from any available system".

That's it.
2. With nvidia driver I still get the main screen black but i could use the external monitor in VGA mode.
The xrandr however shows two screens and their related resolutions.
Am I imagining things? (There is no "VGA mode" by the way.)
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

Am I imagining things? (There is no "VGA mode" by the way.)
Sorry shkhln !! How kids also took the monitor from my table when got the laptop, i simply forgot it.
(😂😂😂 It would be comical if it weren't tragic)

BTW, no progress. I tried 2 X setups... both monitors in a one screen and each monitor in a screen (two screens)... Following attached the Xorg logs, xorg confs and nvidia-settings output with options query=all and verbose=all.

Thanks a lot, guys !!!
 

Attachments

OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

Have you tried switching to a console and back, as I suggested above?
I have never accessed to any console neither before nor now... they all have always been black screens, even at the working setup with the external monitor.

First, in a dumb consideration, i thought of laptop's monitor issue but i reconsiderated that because i got it working with vesa driver.

The battle goes on !!

Thanks shkhln, again !
 
OP
João Luis

João Luis

New Member

Reaction score: 1
Messages: 19

What result did you get?
No change. I can use laptop display normally using graphic and text modes with vesa driver.
If i use nvidia driver, i can only have system access from an external monitor (laptop display and all text consoles are black screens).
 
Top