xterm no utf8

I used to use uxterm aka xterm -u8 and it was all good until today, when i updated xterm to latest version [v238] i can't use it.

There is no such key -u8 anymore, also i can't set locale because mine ain't supported by freebsd
Setting other utf8 locale doesn't work for me, as i need.
Instead of getting āēīūžčņļķģš i get some weir characters.
Needless to say that this sux

can anyone help to solve this.
UTF-8 in xterm ain't that vital, but i do write native in cli time to time.

i could restore from backups, but my guess that next version of xterm will probably be the same
heh, was also bitten by that

stas 2009-01-08 14:00:00 UTC

FreeBSD ports repository

Modified files:
x11/xterm Makefile
- Disable wide char support by default, as it breaks 8-bit charset
- Introduce a new knob WITH_WIDE_CHARS to enable wide chars.
killasmurf86 $ sudo make config
===> No options to configure

dam, does this mean i will have to set WITH_WIDE_CHARS each time i update xterm
there is no make config options, and portmaster just compiles xterm.