xterm-256color not set on zsh shell

freefly

New Member


Messages: 4

I have installed FreeBSD 12.1 as a VM in virtualbox which uses VMSVGA video driver. I have configured the `/usr/ports/x11-drivers/xf86-video-vmware` and uses `vt`. I have specified `Depth 24` as color depth in the xorg.conf settings. I use a Dell XPS 15 9570.

kern.vty=vt
kern.vt.fb.default_mode=1920x1080


I am using zsh as my shell and it complains that my terminal appears to support fewer than 256 colors and 'export TERM="xterm-256color" to the .zshrc. I set it on the top of the zshrc file but I still get the warning.
when I check with `tput colors`, it says 80 :(.
How can I fix the issue ? is it something specific to the VMSVGA driver ? or something else ?
 
OP
F

freefly

New Member


Messages: 4

I have installed FreeBSD 12.1 as a VM in virtualbox which uses VMSVGA video driver. I have configured the `/usr/ports/x11-drivers/xf86-video-vmware` and uses `vt`. I have specified `Depth 24` as color depth in the xorg.conf settings. I use a Dell XPS 15 9570.

kern.vty=vt
kern.vt.fb.default_mode=1920x1080


I am using zsh as my shell and it complains that my terminal appears to support fewer than 256 colors and 'export TERM="xterm-256color" to the .zshrc. I set it on the top of the zshrc file but I still get the warning.
when I check with `tput colors`, it says 80 :(.
How can I fix the issue ? is it something specific to the VMSVGA driver ? or something else ?

The problem is with the powerline9k that I installed. The have some unfixed issues with the colors logic it seems.
 
Top