Xsetup get overwritten

Alain De Vos

Daemon

Reaction score: 608
Messages: 2,056

In /usr/local/share/sddm/scripts/Xsetup i have a line to set the keyboard.
Nothing more than,
Code:
setxkbmap be
Because sddm cannot set the keyboard correctly.
When there is new version of sddm the Xsetup file gets blindly overwritten.
 

Alexander88207

Aspiring Daemon

Reaction score: 422
Messages: 642

Hello,

configurations files that are in /usr/local/share are not meant to be changed by a user.

do you like to try the following?

mkdir -p /usr/local/etc/sddm/scripts

there you put your xstart script into that folder.

Then you create an /usr/local/etc/sddm.conf and target your saved script.

Example:

Code:
[X11]
DisplayCommand=/usr/local/etc/sddm/scripts/Xsetup
 

Minbari

Aspiring Daemon

Reaction score: 305
Messages: 564

usr/local/etc/X11/xorg.conf.d/kbd-layout-multi.conf:
Code:
Section    "InputClass"
    Identifier    "All Keyboards"
    MatchIsKeyboard    "yes"
    Option        "XkbLayout" "us,ro,fr,de"
    Option      "XkbVariant" ",std,oss_nodeadkeys,"
    Option      "XkbOptions" "compose:paus,lv3:ralt_switch,grp:ctrl_shift_toggle_bidir"
EndSection
 

mer

Well-Known Member

Reaction score: 277
Messages: 476

So /usr/local/etc i change but not /usr/local/share/
Think of the relationship between /etc and /etc/defaults. Every upgrade is allowed to overwrite something in /etc/defaults, but won't overwrite it in /etc. I'm specifically thinking about rc.conf and periodic.conf
 
OP
Alain De Vos

Alain De Vos

Daemon

Reaction score: 608
Messages: 2,056

Hello,

configurations files that are in /usr/local/share are not meant to be changed by a user.

do you like to try the following?

mkdir -p /usr/local/etc/sddm/scripts

there you put your xstart script into that folder.

Then you create an /usr/local/etc/sddm.conf and target your saved script.

Example:

Code:
[X11]
DisplayCommand=/usr/local/etc/sddm/scripts/Xsetup
I did not worked
 
OP
Alain De Vos

Alain De Vos

Daemon

Reaction score: 608
Messages: 2,056

usr/local/etc/X11/xorg.conf.d/kbd-layout-multi.conf:
Code:
Section    "InputClass"
    Identifier    "All Keyboards"
    MatchIsKeyboard    "yes"
    Option        "XkbLayout" "us,ro,fr,de"
    Option      "XkbVariant" ",std,oss_nodeadkeys,"
    Option      "XkbOptions" "compose:paus,lv3:ralt_switch,grp:ctrl_shift_toggle_bidir"
EndSection
That worked. With it have the correct keyboard after login in.
 
Top