Xorg uses libinput to manage devices but doesn't use libinput settings

mcjames

New Member

Reaction score: 1
Messages: 16

I am on Dell Inspiron core Duo 2 using FreeBSD 12.1 release.
First I did setup synaptics from FreeBSD wiki page but no matter what I did my device was being picked up by libinput as was obvious from Xorg.0.log. Only removing 40-libinput.conf from /usr/share/X11/xorg.conf.d/ removed the libinput from the log. In turn then I had no onboard keyboard and touchpad on my laptop. Puting 40-libinput.conf back I regained the control over my keyboard and touchpad but still no Xorg libinput settings was taken in to effect. (no tap to click and no edge scrolling). I even went one step more and made xorg-xserver from ports and with edevd instead of udev with no luck. Still no libinput Xorg settings would take effect.
Do you know what's going on? libinput and xf86-input-libinput are installed.

xorg log:

wblock@ it was suggested I had to contact you. (sorry but I don't know anything else to try)
thanks.
 

monwarez

Active Member

Reaction score: 60
Messages: 149

As a workaround you could write a script that set each properties needed and then auto start it.
Bash:
xinput set-prop 'ETPS/2 Elantech Touchpad' 'libinput Tapping Enabled' 1

You can use xinput list to get the name of the touchpad (or the id), and then use this information to set each available properties.
 
OP
mcjames

mcjames

New Member

Reaction score: 1
Messages: 16

thanks monwarez
Code:
xinput list

⎡ Virtual core pointer                        id=2    [master pointer  (3)]

⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]

⎜   ↳ System mouse                                id=6    [slave  pointer  (2)]

⎜   ↳ GlidePoint                                  id=9    [slave  pointer  (2)]

⎜   ↳ vendor 0x13ba Barcode Reader                id=12    [slave  pointer  (2)]

⎣ Virtual core keyboard                       id=3    [master keyboard (2)]

    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]

    ↳ System keyboard multiplexer                 id=7    [slave  keyboard (3)]

    ↳ AT keyboard                                 id=8    [slave  keyboard (3)]

    ↳ SIGMACHIP USB Keyboard                      id=10    [slave  keyboard (3)]

    ↳ vendor 0x13ba Barcode Reader                id=11    [slave  keyboard (3)]
 

Phishfry

Beastie's Twin

Reaction score: 2,669
Messages: 5,594

Installing libinput and xf86-input-libinput and this sysctl did the trick for me.

/etc/sysctl.conf
kern.evdev.rcpt_mask=12
 
Top