xorg error

Brutanas

Member

Thanks: 2
Messages: 61

#1
Hello!

I just installed xorg from pkg. I have an AMD radeon HD 6950. Automatic configure is not able to startx. Below is the xorg log. Can someone give me an hint on how to proceed?

Thank you!
Code:
[ 22419.206] 
X.Org X Server 1.18.4
Release Date: 2016-07-19
[ 22419.206] X Protocol Version 11, Revision 0
[ 22419.206] Build Operating System: FreeBSD 11.1-RELEASE-p6 amd64 
[ 22419.206] Current Operating System: FreeBSD bombarra 11.1-STABLE FreeBSD 11.1-STABLE #0 r329320: Thu Feb
 15 21:13:31 UTC 2018     [email]root@releng2.nyi.freebsd.org[/email]:/usr/obj/usr/src/sys/GENERIC amd64
[ 22419.206] Build Date: 27 February 2018  02:18:26AM
[ 22419.206]  
[ 22419.206] Current version of pixman: 0.34.0
[ 22419.206]    Before reporting problems, check [URL]http://wiki.x.org[/URL]
        to make sure that you have the latest version.
[ 22419.206] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 22419.207] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar  3 22:21:59 2018
[ 22419.207] (++) Using config file: "xorg.conf.new"
[ 22419.207] (==) ServerLayout "X.org Configured"
[ 22419.207] (**) |-->Screen "Screen0" (0)
[ 22419.207] (**) |   |-->Monitor "Monitor0"
[ 22419.207] (**) |   |-->Device "Card0"
[ 22419.207] (**) |-->Input Device "Mouse0"
[ 22419.207] (**) |-->Input Device "Keyboard0"
[ 22419.207] (==) Automatically adding devices
[ 22419.207] (==) Automatically enabling devices
[ 22419.207] (==) Not automatically adding GPU devices
[ 22419.207] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 22419.207] (**) FontPath set to:
        /usr/local/share/fonts/misc/,
        /usr/local/share/fonts/TTF/,
        /usr/local/share/fonts/OTF/,
        /usr/local/share/fonts/Type1/,
        /usr/local/share/fonts/100dpi/,
        /usr/local/share/fonts/75dpi/,
        /usr/local/share/fonts/misc/,
        /usr/local/share/fonts/TTF/,
        /usr/local/share/fonts/OTF/,
        /usr/local/share/fonts/Type1/,
        /usr/local/share/fonts/100dpi/,
        /usr/local/share/fonts/75dpi/
[ 22419.207] (**) ModulePath set to "/usr/local/lib/xorg/modules"
[ 22419.207] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 22419.207] (WW) Disabling Mouse0
[ 22419.207] (WW) Disabling Keyboard0
[ 22419.207] (II) Loader magic: 0x80cc10
[ 22419.207] (II) Module ABI versions:
[ 22419.207]    X.Org ANSI C Emulation: 0.4
[ 22419.207]    X.Org Video Driver: 20.0
[ 22419.207]    X.Org XInput driver : 22.1
[ 22419.207]    X.Org Server Extension : 9.0                                                               
[ 22419.207] (--) PCI:*(0:1:0:0) 1002:6719:1458:21fd rev 0, Mem @ 0xc0000000/268435456, 0xfe620000/131072, 
I/O @ 0x0000e000/256, BIOS @ 0x????????/65536
[ 22419.207] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 22419.207] (II) LoadModule: "glx"
[ 22419.207] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[ 22419.208] (II) Module glx: vendor="X.Org Foundation"
[ 22419.208]    compiled for 1.18.4, module version = 1.0.0
[ 22419.208]    ABI class: X.Org Server Extension, version 9.0
[ 22419.208] (==) AIGLX enabled
[ 22419.208] (II) LoadModule: "modesetting"
[ 22419.209] (II) Loading /usr/local/lib/xorg/modules/drivers/modesetting_drv.so
[ 22419.209] (II) Module modesetting: vendor="X.Org Foundation"
[ 22419.209]    compiled for 1.18.4, module version = 1.18.4
[ 22419.209]    Module class: X.Org Video Driver
[ 22419.209]    ABI class: X.Org Video Driver, version 20.0
[ 22419.209] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 22419.209] (--) Using syscons driver with X support (version 2.0)
[ 22419.209] (--) using VT number 9

[ 22419.214] (EE) open /dev/dri/card0: No such file or directory
[ 22419.214] (WW) Falling back to old probe method for modesetting
[ 22419.214] (EE) open /dev/dri/card0: No such file or directory
[ 22419.214] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 22419.214] (EE) Screen 0 deleted because of no matching config section.
[ 22419.214] (II) UnloadModule: "modesetting"
[ 22419.214] (EE) Device(s) detected, but none match those in the config file.
[ 22419.214] (EE) 
Fatal server error:
[ 22419.214] (EE) no screens found(EE) 
[ 22419.214] (EE) 
Please consult the The X.Org Foundation support 
         at [URL]http://wiki.x.org[/URL]
 for help. 
[ 22419.214] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 22419.214] (EE) 
[ 22419.231] (EE) Server terminated with error (1). Closing log file.
 
Last edited by a moderator:
OP
OP
Brutanas

Brutanas

Member

Thanks: 2
Messages: 61

#4
Thank you both!
I was able to startx after:
pkg install xf86-video-ati
 
Last edited by a moderator:
OP
OP
Brutanas

Brutanas

Member

Thanks: 2
Messages: 61

#5
Do someone knows where I can find the xorg configuration file/files?
I searched where the handbook indicates, but cannot find anywhere!
 

Rasaki Temidire

New Member


Messages: 10

#8
HI,

I also have a Radeon HD 6950. I found the performance under xorg in FreebSD 11-STABLE to be quite poor. When playing videos, the refresh rate is not very good. Were you able to get decent performance? I went so far as to install Linux for the first time since the early 2000s just so I could see decent video performance with their radeon drivers. It was better but working around all the nonsense under the Ubuntu distribution just to get simple root zfs and packages and what-not to work made me realize why I love the simplicity and sanity of FreeBSD. Can someone tell me how I can get my Radeon HD 6950 to work well under FreeBSD?
 

Snurg

Aspiring Daemon

Thanks: 327
Messages: 794

#9
I tried Radeon HD 5850 (same driver) once on 11.1 because the FreeBSD devs recommend radeon for some reason unbeknownst to me.
It was horrible. Tearing, bad video performance, and no suspend/resume.
It made me stop the Radeon experiment after 2 days and putting the Nvidia card back into the computer.
 
OP
OP
Brutanas

Brutanas

Member

Thanks: 2
Messages: 61

#10
Hello,

as I told before, after

# pkg install xf86-video-ati

I was able to startx. Already seen serveral videos with vlc and no poor performance. In the next days I will try to play some games... then I will see how it behaves.

Regards.
 

Rasaki Temidire

New Member


Messages: 10

#11
Thanks Brutanas. I had that package installed and loaded radeon_kms yet saw the poor performance. Lt us know how the games experience goes. I will try to bring up FreeBSD 11-STABLE again and see if I missed something. I would prefer to run BSD but not being able to effectively use a 2 GB video card is a bit of a challenge.
 
OP
OP
Brutanas

Brutanas

Member

Thanks: 2
Messages: 61

#12
Hi again.

After some fights... I was able to play half-life 2 with wine... Team fortress 2 with steam on playonbsd... no issues with the video.
And of course: Quake1 (with darkplaces).
I will try a few more during the next weekend...
 
Top