Xorg doesn't catch keypresses anymore

kpect

Member

Reaction score: 8
Messages: 64

Hello.

I've got Lenovo T430 with FreeBSD 11-Current. After recent upgrade up to latest ports among which were:
Code:
libX11-1.6.3,1                     <   needs updating (index has 1.6.4,1)
xkeyboard-config-2.17        <   needs updating (index has 2.19)
xproto-7.0.28                     <   needs updating (index has 7.0.31)
I'm not able to use keyboard anymore. Mouse and tracker are still working, all keystrokes are ignored and after logging out I can see some keyprints(ESC chars) on the console. Googling didn't help. Is there a way to fix keyboard in xorg?

Regards.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,680
Messages: 30,598

There is no 11-CURRENT any more. -CURRENT moved to 12.0 and 11.0 was released not too long ago. Update your system to 11.0-RELEASE or 11.0-STABLE.
 

aragats

Daemon

Reaction score: 515
Messages: 1,246

I'm not able to use keyboard anymore. Mouse and tracker are still working, all keystrokes are ignored and after logging out I can see some keyprints(ESC chars) on the console.
You should provide more details on you issue. I never had such problem in my T430.
So everything works until you run X server. How do you run it? Are you trying to type in a graphical terminal?
You can run xev(1) from another console:
Code:
export DISPLAY=:0
xterm -e xev
to see what's going on.
 
OP
OP
K

kpect

Member

Reaction score: 8
Messages: 64

Yes everything works in vt console. I start xorg using startx command, use fluxbox as a WM. Everything worked fine before upgrade. Below config was working fine. And I do not see anything special in X log file, XINPUT uses kbdmux as a device.


Here is xorg.conf file:

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
	Option         "AutoAddDevices" "false"
EndSection

Section "Files"
	ModulePath   "/usr/local/lib/xorg/modules"
	FontPath     "/usr/local/share/fonts/ParaType/"
	FontPath     "/usr/local/share/fonts/TTF/"
	FontPath     "/usr/local/share/fonts/OTF/"
	FontPath     "/usr/local/share/fonts/dejavu/"
	FontPath     "/usr/local/share/fonts/terminus-font/"
	FontPath     "/usr/local/share/fonts/misc/"
EndSection

Section "Module"
	Load  "extmod"
	Load  "dri2"
	Load  "dri"
	Load  "record"
	Load  "dbe"
	Load  "glx"
	Load  "freetype"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option      "XkbLayout"  "us,ru(winkeys)"
	Option      "XkbVariant" "nodeadkeys"
	Option      "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll,caps:internal,terminate:ctrl_alt_bksp"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option      "Protocol" "auto"
	Option      "Device" "/dev/psm0"
	Option      "Emulate3Buttons" "true"
	Option      "EmulateWheel" "true"
	Option      "EmulateWheelButton" "2"
	Option      "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
	Identifier  "Card0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

I've already tryed xev, it doesn't react to keypresses either, I can see some "scancodes" on console only.
 
OP
OP
K

kpect

Member

Reaction score: 8
Messages: 64

Code:
[   888.446] 
X.Org X Server 1.17.4
Release Date: 2015-10-28
[   888.446] X Protocol Version 11, Revision 0
[   888.446] Build Operating System: FreeBSD 11.0-STABLE amd64 
[   888.446] Current Operating System: FreeBSD KPECT 11.0-STABLE FreeBSD 11.0-STABLE #0: Tue Nov 15 23:37:15 MSK 2016     root@KPECT amd64
[   888.447] Build Date: 15 November 2016  09:38:21PM
[   888.447]  
[   888.447] Current version of pixman: 0.34.0
[   888.447] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   888.447] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   888.447] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 17 22:12:24 2016
[   888.447] (==) Using config file: "/usr/local/etc/X11/xorg.conf"
[   888.448] (==) ServerLayout "X.org Configured"
[   888.448] (**) |-->Screen "Screen0" (0)
[   888.448] (**) |   |-->Monitor "Monitor0"
[   888.448] (**) |   |-->Device "Card0"
[   888.448] (**) |-->Input Device "Mouse0"
[   888.448] (**) |-->Input Device "Keyboard0"
[   888.448] (**) Option "AutoAddDevices" "false"
[   888.448] (**) Not automatically adding devices
[   888.448] (==) Automatically enabling devices
[   888.448] (==) Not automatically adding GPU devices
[   888.449] (**) FontPath set to:
	/usr/local/share/fonts/ParaType/,
	/usr/local/share/fonts/TTF/,
	/usr/local/share/fonts/OTF/,
	/usr/local/share/fonts/dejavu/,
	/usr/local/share/fonts/terminus-font/,
	/usr/local/share/fonts/misc/,
	/usr/local/share/fonts/misc/,
	/usr/local/share/fonts/TTF/,
	/usr/local/share/fonts/OTF/,
	/usr/local/share/fonts/Type1/,
	/usr/local/share/fonts/100dpi/,
	/usr/local/share/fonts/75dpi/
[   888.449] (**) ModulePath set to "/usr/local/lib/xorg/modules"
[   888.449] (II) Loader magic: 0x8141d0
[   888.449] (II) Module ABI versions:
[   888.449] 	X.Org ANSI C Emulation: 0.4
[   888.449] 	X.Org Video Driver: 19.0
[   888.449] 	X.Org XInput driver : 21.0
[   888.449] 	X.Org Server Extension : 9.0
[   888.449] (--) PCI:*(0:0:2:0) 8086:0166:17aa:21f3 rev 9, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00004000/64, BIOS @ 0x????????/65536
[   888.449] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   888.449] (II) LoadModule: "glx"
[   888.449] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   888.454] (II) Module glx: vendor="X.Org Foundation"
[   888.454] 	compiled for 1.17.4, module version = 1.0.0
[   888.454] 	ABI class: X.Org Server Extension, version 9.0
[   888.454] (==) AIGLX enabled
[   888.454] (II) LoadModule: "intel"
[   888.454] (II) Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so
[   888.455] (II) Module intel: vendor="X.Org Foundation"
[   888.455] 	compiled for 1.17.4, module version = 2.21.15
[   888.455] 	Module class: X.Org Video Driver
[   888.455] 	ABI class: X.Org Video Driver, version 19.0
[   888.455] (II) LoadModule: "mouse"
[   888.455] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[   888.456] (II) Module mouse: vendor="X.Org Foundation"
[   888.456] 	compiled for 1.17.4, module version = 1.9.1
[   888.456] 	Module class: X.Org XInput Driver
[   888.456] 	ABI class: X.Org XInput driver, version 21.0
[   888.456] (II) LoadModule: "kbd"
[   888.456] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[   888.456] (II) Module kbd: vendor="X.Org Foundation"
[   888.456] 	compiled for 1.17.4, module version = 1.8.1
[   888.456] 	Module class: X.Org XInput Driver
[   888.456] 	ABI class: X.Org XInput driver, version 21.0
[   888.456] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
	HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
	HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
	HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
	HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[   888.458] (--) Using syscons driver with X support (version 16777218.0)
[   888.458] (--) using VT number 1

[   888.459] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   888.459] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   888.459] (==) intel(0): RGB weight 888
[   888.459] (==) intel(0): Default visual is TrueColor
[   888.459] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4000
[   888.460] (**) intel(0): Relaxed fencing enabled
[   888.460] (**) intel(0): Wait on SwapBuffers? enabled
[   888.460] (**) intel(0): Triple buffering? enabled
[   888.460] (**) intel(0): Framebuffer tiled
[   888.460] (**) intel(0): Pixmaps tiled
[   888.460] (**) intel(0): 3D buffers tiled
[   888.460] (**) intel(0): SwapBuffers wait enabled
[   888.460] (==) intel(0): video overlay key set to 0x101fe
[   888.460] (II) intel(0): Output LVDS1 using monitor section Monitor0
[   888.474] (II) intel(0): Output VGA1 has no monitor section
[   888.544] (II) intel(0): Output HDMI1 has no monitor section
[   888.554] (II) intel(0): Output DP1 has no monitor section
[   888.571] (II) intel(0): Output HDMI2 has no monitor section
[   888.587] (II) intel(0): Output HDMI3 has no monitor section
[   888.597] (II) intel(0): Output DP2 has no monitor section
[   888.607] (II) intel(0): Output DP3 has no monitor section
[   888.607] (II) intel(0): EDID for output LVDS1
[   888.607] (II) intel(0): Manufacturer: LGD  Model: 362  Serial#: 0
[   888.607] (II) intel(0): Year: 2011  Week: 0
[   888.607] (II) intel(0): EDID Version: 1.3
[   888.607] (II) intel(0): Digital Display Input
[   888.607] (II) intel(0): Max Image Size [cm]: horiz.: 31  vert.: 17
[   888.607] (II) intel(0): Gamma: 2.20
[   888.607] (II) intel(0): No DPMS capabilities specified
[   888.607] (II) intel(0): Supported color encodings: RGB 4:4:4 
[   888.608] (II) intel(0): First detailed timing is preferred mode
[   888.608] (II) intel(0): redX: 0.588 redY: 0.350   greenX: 0.332 greenY: 0.558
[   888.608] (II) intel(0): blueX: 0.155 blueY: 0.123   whiteX: 0.313 whiteY: 0.329
[   888.608] (II) intel(0): Manufacturer's mask: 0
[   888.608] (II) intel(0): Supported detailed timing:
[   888.608] (II) intel(0): clock: 107.8 MHz   Image Size:  309 x 174 mm
[   888.608] (II) intel(0): h_active: 1600  h_sync: 1648  h_sync_end 1680 h_blank_end 1920 h_border: 0
[   888.608] (II) intel(0): v_active: 900  v_sync: 903  v_sync_end 908 v_blanking: 936 v_border: 0
[   888.608] (II) intel(0):  LG Display
[   888.608] (II) intel(0):  LP140WD2-TLD2
[   888.608] (II) intel(0): EDID (in hex):
[   888.608] (II) intel(0): 	00ffffffffffff0030e4620300000000
[   888.608] (II) intel(0): 	00150103801f117802a3e59659558e27
[   888.608] (II) intel(0): 	1f505400000001010101010101010101
[   888.608] (II) intel(0): 	0101010101011c2a4040618424303020
[   888.608] (II) intel(0): 	350035ae100000190000000000000000
[   888.608] (II) intel(0): 	00000000000000000000000000fe004c
[   888.608] (II) intel(0): 	4720446973706c61790a2020000000fe
[   888.608] (II) intel(0): 	004c503134305744322d544c44320056
[   888.608] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[   888.608] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[   888.608] (II) intel(0): Printing probed modes for output LVDS1
[   888.608] (II) intel(0): Modeline "1600x900"x60.0  107.80  1600 1648 1680 1920  900 903 908 936 -hsync -vsync (56.1 kHz eP)
[   888.608] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[   888.608] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[   888.608] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[   888.608] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[   888.624] (II) intel(0): EDID for output VGA1
[   888.693] (II) intel(0): EDID for output HDMI1
[   888.704] (II) intel(0): EDID for output DP1
[   888.721] (II) intel(0): EDID for output HDMI2
[   888.737] (II) intel(0): EDID for output HDMI3
[   888.747] (II) intel(0): EDID for output DP2
[   888.757] (II) intel(0): EDID for output DP3
[   888.757] (II) intel(0): Output LVDS1 connected
[   888.757] (II) intel(0): Output VGA1 disconnected
[   888.757] (II) intel(0): Output HDMI1 disconnected
[   888.757] (II) intel(0): Output DP1 disconnected
[   888.757] (II) intel(0): Output HDMI2 disconnected
[   888.757] (II) intel(0): Output HDMI3 disconnected
[   888.757] (II) intel(0): Output DP2 disconnected
[   888.757] (II) intel(0): Output DP3 disconnected
[   888.757] (II) intel(0): Using exact sizes for initial modes
[   888.757] (II) intel(0): Output LVDS1 using initial mode 1600x900
[   888.757] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[   888.757] (II) intel(0): Kernel page flipping support detected, enabling
[   888.758] (==) intel(0): DPI set to (96, 96)
[   888.758] (II) Loading sub module "fb"
[   888.758] (II) LoadModule: "fb"
[   888.758] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[   888.758] (II) Module fb: vendor="X.Org Foundation"
[   888.758] 	compiled for 1.17.4, module version = 1.0.0
[   888.758] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   888.758] (II) Loading sub module "dri2"
[   888.758] (II) LoadModule: "dri2"
[   888.758] (II) Module "dri2" already built-in
[   888.758] (==) Depth 24 pixmap format is 32 bpp
[   888.758] (II) intel(0): [DRI2] Setup complete
[   888.758] (II) intel(0): [DRI2]   DRI driver: i965
[   888.758] (II) intel(0): Allocated new frame buffer 1600x900 stride 6656, tiled
[   888.759] (II) UXA(0): Driver registered support for the following operations:
[   888.759] (II)         solid
[   888.759] (II)         copy
[   888.759] (II)         composite (RENDER acceleration)
[   888.759] (II)         put_image
[   888.759] (II)         get_image
[   888.759] (==) intel(0): Backing store enabled
[   888.759] (==) intel(0): Silken mouse enabled
[   888.759] (II) intel(0): Initializing HW Cursor
[   888.759] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[   888.759] (==) intel(0): DPMS enabled
[   888.759] (==) intel(0): Intel XvMC decoder enabled
[   888.759] (II) intel(0): Set up textured video
[   888.759] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[   888.759] (II) intel(0): direct rendering: DRI2 Enabled
[   888.774] (--) RandR disabled
[   888.782] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[   888.782] (II) AIGLX: enabled GLX_ARB_create_context
[   888.782] (II) AIGLX: enabled GLX_ARB_create_context_profile
[   888.782] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[   888.782] (II) AIGLX: enabled GLX_INTEL_swap_event
[   888.782] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[   888.782] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[   888.782] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[   888.782] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[   888.783] (II) AIGLX: Loaded and initialized i965
[   888.783] (II) GLX: Initialized DRI2 GL provider for screen 0
[   888.783] (II) intel(0): Setting screen physical size to 423 x 238
[   888.849] (II) Using input driver 'mouse' for 'Mouse0'
[   888.849] (**) Option "CorePointer"
[   888.849] (**) Mouse0: always reports core events
[   888.849] (**) Option "Protocol" "auto"
[   888.849] (**) Option "Device" "/dev/psm0"
[   888.849] (**) Mouse0: Protocol: "auto"
[   888.849] (**) Mouse0: always reports core events
[   888.899] (**) Option "Emulate3Buttons" "true"
[   888.899] (**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
[   888.899] (**) Option "ZAxisMapping" "4 5"
[   888.899] (**) Mouse0: ZAxisMapping: buttons 4 and 5
[   888.899] (**) Option "EmulateWheel" "true"
[   888.899] (**) Option "EmulateWheelButton" "2"
[   888.899] (==) Mouse0: YAxisMapping: buttons 4 and 5
[   888.899] (**) Mouse0: EmulateWheel, EmulateWheelButton: 2, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   888.899] (**) Mouse0: Buttons: 5
[   888.899] (II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE, id 6)
[   888.900] (**) Mouse0: (accel) keeping acceleration scheme 1
[   888.900] (**) Mouse0: (accel) acceleration profile 0
[   888.900] (**) Mouse0: (accel) acceleration factor: 2.000
[   888.900] (**) Mouse0: (accel) acceleration threshold: 4
[   888.914] (II) Mouse0: SetupAuto: hw.iftype is 3, hw.model is 0
[   888.914] (II) Mouse0: SetupAuto: protocol is PS/2
[   889.353] (II) Mouse0: ps2EnableDataReporting: succeeded
[   889.353] (II) Using input driver 'kbd' for 'Keyboard0'
[   889.353] (**) Option "CoreKeyboard"
[   889.353] (**) Keyboard0: always reports core events
[   889.353] (**) Keyboard0: always reports core events
[   889.353] (**) Option "Protocol" "standard"
[   889.353] (**) Option "XkbRules" "base"
[   889.353] (**) Option "XkbModel" "pc105"
[   889.353] (**) Option "XkbLayout" "us,ru(winkeys)"
[   889.353] (**) Option "XkbVariant" "nodeadkeys"
[   889.353] (**) Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll,caps:internal,terminate:ctrl_alt_bksp"
[   889.353] (II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD, id 7)
[   889.378] (II) config/devd: probing input devices...
[   889.378] (II) config/devd: adding input device (null) (/dev/kbdmux)
[   889.378] (II) AutoAddDevices is off - not adding device.
[   889.378] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[   889.378] (II) config/devd: adding input device (null) (/dev/sysmouse)
[   889.378] (II) AutoAddDevices is off - not adding device.
[   889.378] (II) config/devd: device /dev/psm0 already opened
 
OP
OP
K

kpect

Member

Reaction score: 8
Messages: 64

Code:
		cpu		HAMMER
		ident		LOCAL
		makeoptions	MKMODULESENV+="WITHOUT_INET6_SUPPORT="
		maxusers	64
		options		SCHED_ULE
		options		PREEMPTION
		options		INET
		options		ZFS
		options		TMPFS
		options		AUTOFS
		options		MSDOSFS
		options		MSDOSFS_ICONV
		options		CD9660
		options		CD9660_ICONV
		options		LIBICONV
		options		GEOM_PART_GPT
		options		GEOM_LABEL
		options		SCSI_DELAY=1000
		options		SCSI_NO_SENSE_STRINGS
		options		SCSI_NO_OP_STRINGS
		options		SYSVSHM
		options		SYSVMSG
		options		SYSVSEM
		options		_KPOSIX_PRIORITY_SCHEDULING
		options		PRINTF_BUFR_SIZE=128
		options		KBD_INSTALL_CDEV
		options		NO_SYSCTL_DESCR
		options		HZ=300
		options		IPSTEALTH
		options		IPFIREWALL
		options		IPFIREWALL_DEFAULT_TO_ACCEPT
		options		SMP
		options		MAXCPU=4
		device		cpufreq
		device		coretemp
		device		acpi
		options		ACPI_DMAR
		device		pci
		device		ahci
		options		ATA_STATIC_ID
		device		scbus
		device		da
		device		cd
		device		pass
		device		ses
		device		atkbdc
		device		atkbd

		device		kbdmux
		device		vt
		device		vt_vga
		options		VT_MAXWINDOWS=4
		options		TERMINAL_NORM_ATTR=(FG_LIGHTGREY|BG_BLACK)
		options		TERMINAL_KERN_ATTR=(FG_RED|BG_BLACK)
		options		IEEE80211_AMPDU_AGE
		device		wlan
		device		wlan_wep
		device		wlan_ccmp
		device		wlan_tkip
		device		wlan_amrr
		device		loop
		device		random
		device		ether
		device		md
		device		firmware
		device		bpf
		device		ehci
		device		usb
		device		umass
		device		sound
		device		crypto
		device		cryptodev
		device		krpc
		device		snd_emu10k1
		device		ath
		device		ath_pci
		device		ath_hal
		device		ath_rate_sample
		options		ATH_ENABLE_11N
		device		uhci
		device		uhid
		device		ukbd
		device		ums
		nooptions	GEOM_PART_BSD
		nooptions	GEOM_PART_EBR
		nooptions	GEOM_PART_EBR_COMPAT
 

aragats

Daemon

Reaction score: 515
Messages: 1,246

I don't use xorg.conf for long time. The only file I have is /usr/local/etc/X11/xorg.conf.d/20-mouse.conf
Code:
Section "ServerLayout"
   Identifier "thinkpad"
   Option "AutoAddDevices" "Off"
EndSection
For the keyboard layouts I've added:
Code:
setxkbmap -layout us,ru,am -variant ",phonetic,phonetic"
to my ~/.xinitrc.
I would recommend trying Xorg without any config file first.
 
OP
OP
K

kpect

Member

Reaction score: 8
Messages: 64

I use xorg.conf because I specify some additional parameters there and do not use/like HAL. Without xorg.conf keypresses are not recognized either, I've already experimented with it. Even more I've recompiled all the ports from scratch which didn't help.
 
OP
OP
K

kpect

Member

Reaction score: 8
Messages: 64

Suppose I've found the reason, it's my custom kernel; which worked fine before upgrade BTW.
 
Top