Xorg configure using radeon x300

Hi all,

I've seem some problems to configure and use xorg.
Some time ago I've used PCBSD 9.1 and I have some problems ( https://forums.freebsd.org/threads/36693/ ), now I want to use directly FreeBSD and I've installed FreeBSD 10.2 and I'm seeing some problems may be related to the other that I said before ... or not.

I've installed Xorg and openbox, I can't run Xorg -configure I got and error (I'm in other machine now, so I don't remember the error), anyway I can run startx and it seems to work without problem... but if I try to change of terminal (CTRL + ALT + [1,2,3,....]) the screen locks in black and I can't return to X term and finally the monitor shutdowns (it doesn't get signal) then I have to restart my machine.

So, I've started to see the loaded modules... when I start my machine, after to boot and before to run startx, if I run kldstat there isn't radeonkms modules loaded... but after to run startx two radeon modules are loaded.

But if I want to load that modules manually without run startx (using kldload radeonkms) the screen put in black again and I see nothing... also I have to poweroff the machine.

So... what do you think? suggestions?

I've had a problem like this for a while. Did you install xorg and related ports from scratch? I think an older version of xorg related ports had a problem.

Also, in the file /boot/loader.conf, add
. This worked for me, but it didn't always work, when I had older ports and packages installed. Go with the full xorg install, instead of the minimal install.

From when my computer had that problem, that you described, sometimes I was able to ctrl-alt-#, to my screen. One instance had a frozen screen, which this worked, and another it was a blank screen, on some of my installs it would come back after a long delay.

Also, importantly, make sure that /etc/ttys is restored to it's original state, which you can copy this file from the install cd, then cautiously re-edit it on your computer.

I can't run Xorg -configure I got and error
Xorg -configure isn't used much anymore. Erase, or change the file-name of the generated file from running this command.