Xorg -configure problem

vodkline

New Member


Messages: 6

Hello ,

I want install FreeBSD on my laptop HP but , iI have problem when iI want install x11/xorg.

iI install Xorg with port (x11/xorg) but startx doesn't work

Graphics cards :
  • Intel® HD 5500
  • AMD Radeon™ R7 M260X
My file xorg.conf.new and errors when iI launch startx
Can you help me ?
Code:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/local/lib/xorg/modules"
    FontPath     "/usr/local/share/fonts/misc/"
    FontPath     "/usr/local/share/fonts/TTF/"
    FontPath     "/usr/local/share/fonts/OTF/"
    FontPath     "/usr/local/share/fonts/Type1/"
    FontPath     "/usr/local/share/fonts/100dpi/"
    FontPath     "/usr/local/share/fonts/75dpi/"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option       "Protocol" "auto"
    Option       "Device" "/dev/sysmouse"
    Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"               # <i>
        #Option     "VideoKey"               # <i>
        #Option     "Tiling"                 # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"           # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"         # [<bool>]
        #Option     "XvMC"                   # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "TearFree"               # [<bool>]
        #Option     "PerCrtcPixmaps"         # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"       # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                 # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "ColorTiling"           # [<bool>]
        #Option     "ColorTiling2D"         # [<bool>]
        #Option     "RenderAccel"           # [<bool>]
        #Option     "SubPixelOrder"         # [<str>]
        #Option     "EXAVSync"               # [<bool>]
        #Option     "EXAPixmaps"             # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
    Identifier  "Card1"
    Driver      "radeon"
    BusID       "PCI:4:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "Monitor1"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
Code:
root@BSD-baptiste:~ # Xorg -configure

X.Org X Server 1.17.4
Release Date: 2015-10-28
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 10.2-RELEASE amd64
Current Operating System: FreeBSD BSD-baptiste 10.2-RELEASE FreeBSD 10.2-RELEASE #0 r286666: Wed Aug 12 15:26:37 UTC 2015     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
Build Date: 04 February 2016  09:35:42PM

Current version of pixman: 0.32.8
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Feb  4 22:07:22 2016
List of video drivers:
        openchrome
        mach64
        nv
        r128
        apm
        ark
        chips
        dummy
        intel
        glint
        i128
        i740
        rendition
        s3
        s3virge
        savage
        siliconmotion
        sis
        tdfx
        trident
        tseng
        vmware
        voodoo
        ati
        radeon
        fbdev
        modesetting
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
Number of created screens does not match number of detected devices.
  Configuration failed.
(EE) Server terminated with error (2). Closing log file.
root@BSD-baptiste:~ #
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,302
Messages: 32,149

Just wondering out loud, but does the Intel/AMD combo suffer from the same issues as the Intel/NVidia Optimus combination? Or does this work differently?
 

shepper

Aspiring Daemon

Reaction score: 295
Messages: 833

Just wondering out loud, but does the Intel/AMD combo suffer from the same issues as the Intel/NVidia Optimus combination? Or does this work differently?
My understanding is that it is not the combo so much as how it is implemented by the BIOS. Some offer the BIOS option to turn off/select one card.
 

tingo

Daemon

Reaction score: 450
Messages: 2,148

FWIW, if your machine boots (U)EFI, you can use the x11-drivers/xf86-video-scfb Xorg driver. I use it on a machine with Broadwell-U (aka Intel HD Graphics 5500) integrated graphics. This laptop doesn't have a discrete graphics card, so I don't know how that will affect things.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,659
Messages: 13,850

It is sometimes enough to just reference the Intel video in the Xorg configuration. If the system really has a full, discrete AMD or Nvidia video adapter, referencing just that one that should work also. However, that is increasingly rare. Usually they just have a second GPU that uses the Intel video RAM.
 
OP
OP
V

vodkline

New Member


Messages: 6

How can I know if this is a dedicated card?

Can I disable the Radeon since FreeBSD?

I think Intel card work .
 

wblock@

Beastie Himself
Developer

Reaction score: 3,659
Messages: 13,850

The manufacturer specifications are the first place to look to see if the card is dedicated. They might call it "discrete", also.

If there is a way to disable the card, it will be in the BIOS or setup screens. Some systems do not provide that.

Again, the other way is to use only the desired card (Intel) in the xorg.conf files. Have only one Device entry for that card, and nothing for the card that is to be ignored.
 
OP
OP
V

vodkline

New Member


Messages: 6

On the site HP , I can see the graphic card R AMD Radeon™ R7 M260X is dedicated
so , I need to configure Xorg, but I do not know how it works
 

wblock@

Beastie Himself
Developer

Reaction score: 3,659
Messages: 13,850

OP
OP
V

vodkline

New Member


Messages: 6

I disable radeon Card because I want to install intel driver.

I created a file (/usr/local/etc/X11/xorg.conf.d/driver-intel.conf)
Code:
Section "Device"
    Identifier "Card0"
    Driver     "intel"
    BusID     "PCI:0:2:0"
EndSection
But , when execute startx, it doesn't work:
Code:
[   178.176]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[   178.177] X Protocol Version 11, Revision 0
[   178.177] Build Operating System: FreeBSD 11.0-CURRENT amd64
[   178.177] Current Operating System: FreeBSD bsd-baptiste 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r295683: Wed Feb 17 02:07:17 UTC 2016     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
[   178.178] Build Date: 03 March 2016  06:18:50AM
[   178.178] 
[   178.178] Current version of pixman: 0.34.0
[   178.178]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   178.178] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   178.178] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar  6 11:50:05 2016
[   178.208] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[   178.214] (==) No Layout section.  Using the first Screen section.
[   178.214] (==) No screen section available. Using defaults.
[   178.214] (**) |-->Screen "Default Screen Section" (0)
[   178.214] (**) |   |-->Monitor "<default monitor>"
[   178.215] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[   178.215] (**) |   |-->Device "Card0"
[   178.215] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   178.215] (==) Automatically adding devices
[   178.215] (==) Automatically enabling devices
[   178.215] (==) Not automatically adding GPU devices
[   178.312] (==) FontPath set to:
    /usr/local/share/fonts/misc/,
    /usr/local/share/fonts/TTF/,
    /usr/local/share/fonts/OTF/,
    /usr/local/share/fonts/Type1/,
    /usr/local/share/fonts/100dpi/,
    /usr/local/share/fonts/75dpi/
[   178.312] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[   178.312] (II) The server relies on devd to provide the list of input devices.
    If no devices become available, reconfigure devd or disable AutoAddDevices.
[   178.312] (II) Loader magic: 0x80a0c0
[   178.312] (II) Module ABI versions:
[   178.312]     X.Org ANSI C Emulation: 0.4
[   178.312]     X.Org Video Driver: 19.0
[   178.312]     X.Org XInput driver : 21.0
[   178.312]     X.Org Server Extension : 9.0
[   178.313] (--) PCI:*(0:0:2:0) 8086:1616:103c:2216 rev 9, Mem @ 0xc0000000/16777216, 0xb0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/65536
[   178.313] (II) LoadModule: "glx"
[   178.325] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   178.408] (II) Module glx: vendor="X.Org Foundation"
[   178.408]     compiled for 1.17.4, module version = 1.0.0
[   178.408]     ABI class: X.Org Server Extension, version 9.0
[   178.408] (==) AIGLX enabled
[   178.409] (II) LoadModule: "intel"
[   178.409] (II) Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so
[   178.438] (II) Module intel: vendor="X.Org Foundation"
[   178.438]     compiled for 1.17.4, module version = 2.21.15
[   178.438]     Module class: X.Org Video Driver
[   178.438]     ABI class: X.Org Video Driver, version 19.0
[   178.438] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
    HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
    HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
    HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
    HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[   178.439] (--) Using syscons driver with X support (version 2.0)
[   178.440] (--) using VT number 9

[   178.837] (EE) No devices detected.
[   178.837] (EE)
Fatal server error:
[   178.837] (EE) no screens found(EE)
[   178.837] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
for help.
[   178.837] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   178.837] (EE)
[   178.847] (EE) Server terminated with error (1). Closing log file.
 
Top