Xorg 7.4 issue: kdm started before hald and so X does not accept kb/mouse input

kiyolee

New Member

Reaction score: 2
Messages: 9

After massive recompile and upgraded everything to use Xorg 7.4, every time after reboot, kdm is started but not accepting and kb/mouse input.
Checked the pids of Xorg and hald and so it seems Xorg is started before hald.
Explicitly killing Xorg and get kdm restarted then everything becomes back to normal.
I understand that Xorg and kdm is started through init and according to /etc/ttys whereas hald is started through /usr/local/etc/rc.d/hald.
So my question is what should be the best way to start the things in proper order. Or am I missing something in the whole upgrade process?
And I am wondering the problem happens because of my PC is old and slow. (PIII 1GHz 386MB)
 

zeiz

Aspiring Daemon

Reaction score: 57
Messages: 691

I am struggling with new Xorg 7.4 already a month. I got it finally working with kbd and mouse but there are many other things are going wrong so I reinstall Xorg 7.3.2 or my main machine and continue on my 7 y.o. (P4-anyway)one that's for kids and experiments. I installed there only basic without any packages and then Xorg 7.4, then firefox3, then fluxbox and icewm and some more packages. Everything is woking just fine in twm, fluxbox and icewm. Next step I'll try Xfce (already lots of complains). I got an idea that problem is not in new Xorg but in desktop environment such as kde and gnome. Something is not ready there for new Xorg. Sorry that I cannot help, just an idea...
 

mickey

Aspiring Daemon

Reaction score: 302
Messages: 747

There are two possible solutions to this problem:

1) Do not start kdm via /etc/ttys. Use a startup script like
/usr/local/etc/rc.d/kdm which will postpone the start of kdm until
after hald and the gettys are up and running. This is the way GNOME
uses to start up gdm. Not sure though, if the kdm port does install
such a script already, since I do not use KDE.

2) Statically configure your mouse/keyboard in your xorg.conf file and
turn off auto-detection via hal, i.e. add the following to the
'ServerFlags' section:

options "AutoAddDevices" "False"

Either way should fix your problem. 1 by waiting for HAL and 2 by not having to wait for HAL.
 

zeiz

Aspiring Daemon

Reaction score: 57
Messages: 691

There is no "ServerFlags" section in xorg.conf (ServerLayout is instead).
Should new Section "ServerFlags" be created or it's the same as ServerLayout?
Is the syntax below correct:
Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen 0       "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        [color="Red"]Option         "AutoAddDevices" "False"[/color]
EndSection
 

mickey

Aspiring Daemon

Reaction score: 302
Messages: 747

Simply create a new section named "ServerFlags", i.e.

Section "ServerFlags"
Option "AutoAddDevices" "False"
EndSection

This section specifies global xorg server options, see xorg.conf(5).
Be warned though, that when setting AutoAddDevices to false, hot-plugging of i.e. USB mice/keyboard will presumably not work.
 
OP
K

kiyolee

New Member

Reaction score: 2
Messages: 9

Adding Option "AllowEmptyInput" "off" does really help. Great!
 
Top