Solved XFE file manager: how to open file in Vim?

meine

Active Member

Reaction score: 106
Messages: 170

I use x11-fm/xfe as a file manager. Since gvim is no longer avaliable, I want text and markdown files opened in Vim. Since Vim only lives in a terminal window, double clicking the file in XFE should start my terminal (xterm) and then Vim with the file.

Can anyone tell me how to force XFE to do so?

TIA,
 

eternal_noob

Daemon

Reaction score: 1,250
Messages: 1,516

T-Daemon

Daemon

Reaction score: 1,106
Messages: 2,016

... double clicking the file in XFE should start my terminal (xterm) and then Vim with the file.

Can anyone tell me how to force XFE to do so?
In xfe's GUI Edit -> Preferences -> Programs -> Text editor: xterm -e vim
 
OP
meine

meine

Active Member

Reaction score: 106
Messages: 170

TNX T-Daemon, that did the trick !

again I'd better read man pages first...
 
OP
meine

meine

Active Member

Reaction score: 106
Messages: 170

Discovered so, wondering some time why text files weren't opened the usual way. Preferred plain editors/vim anyway because it has no frills.
 
Top