Solved xfce4-terminal colour

balanga

Son of Beastie

Reaction score: 163
Messages: 3,377

I've installed x11/xfce4-terminal numerous times as it's my preferred terminal emulator, but I do have a problem on one system...

When I go to Edit -> Preferences -> Colors and then click on Text color: the application closes altogether without any msg.

Anyone know what might be causing this? Or what to look for?

This is on FreeBSD 12.1-RELEASE amd64. xfce4-terminal is v. 0.8.8
 

aragats

Daemon

Reaction score: 610
Messages: 1,508

When I go to Edit -> Preferences -> Colors and then click on Text color: the application closes altogether without any msg.
Run xfce4-terminal from another terminal, so when it crashes you may see messages in the first terminal.
(You may want to use a different terminal application, e.g. xterm, to launch xfce4-terminal from)

Most likely it needs a library which missing or has a mismatched version.
 

T-Daemon

Daemon

Reaction score: 494
Messages: 1,036

xfce4-terminal is v. 0.8.8
Assuming you wrote the correct version, I suggest you upgrade all packages on system first before debugging installed version, xfce4-terminal is at version 0.8.8_1, quarterly and latest.
 
OP
B

balanga

Son of Beastie

Reaction score: 163
Messages: 3,377

Run xfce4-terminal from another terminal, so when it crashes you may see messages in the first terminal.
(You may want to use a different terminal application, e.g. xterm, to launch xfce4-terminal from)
I tried what you suggested but no error was displayed, although I caught the following in /var/log/messages:-
Nov 13 23:07:26 test kernel: pid 1101 (xfce4-terminal), jid 0, uid 0: exited on signal 5 (core dumped)
Nov 13 23:10:10 test kernel: pid 1440 (xfce4-terminal), jid 0, uid 0: exited on signal 5 (core dumped)
Most likely it needs a library which missing or has a mismatched version.
Just ran ldd - and it shows 94! libraries.
 
OP
B

balanga

Son of Beastie

Reaction score: 163
Messages: 3,377

Assuming you wrote the correct version, I suggest you upgrade all packages on system first before debugging installed version, xfce4-terminal is at version 0.8.8_1, quarterly and latest.
pkg info xfce4-terminal actually shows 0.8.8_1. The Help -> About option in the application shows 0.8.8
 
OP
B

balanga

Son of Beastie

Reaction score: 163
Messages: 3,377

Most likely it needs a library which missing or has a mismatched version.
When I run pkg info xfce4-terminal it shows:-
Code:
Shared Libs required:
    libglib-2.0.so.0
    libgobject-2.0.so.0
    libpango-1.0.so.0
    libcairo.so.2
    libgtk-3.so.0
    libvte-2.91.so.0
    libxfce4util.so.7
    libxfce4ui-2.so.0
    libxfconf-0.so.3
    libgdk_pixbuf-2.0.so.0
    libgio-2.0.so.0
    libgdk-3.so.0
    libX11.so.6
When I run ldd -f '%o\n' /usr/local/bin/xfce4-terminal I get a list of over 90 libraries so not really sure how to find a mismatch. (Not really sure which -f 'format' parameters are available)...
 
OP
B

balanga

Son of Beastie

Reaction score: 163
Messages: 3,377

Finally managed to sort out the problem by running:

pkg upgrade xfce4-terminal
 
Top