Solved Xfce4-settings not taking over gtk3 theme

strider

New Member

Reaction score: 2
Messages: 14

Before you start reading further : yes I know that the current Xfce 4.12 has some trouble with gtk3 themes. However since FreeBSD is now at Gtk 3.22 I do not think the theming API has broken since (but I can be wrong).

The problem I have is related to the Xfce4_settings app itself. Other programs like xfce4-terminal start using the new theme as soon I select it in Xfce4-settings (appearance Window) but Xfce4 settings-itself and it's child windows (like Appearance) fall back to some odd default ... The only themes that do work are Adwaita (which is the gtk3 default theme now) and Greybird (although xfce4-terminal still seems to have a problem with that theme but that's another story).

Anybody an idea ? I notice that the port of Xfce4-settings has had some thorough changes/cleanup on Jan 22, but I do not know if this is related.
 

shkhln

Well-Known Member

Reaction score: 161
Messages: 433

Xfce contains a mix of gtk 2 and gtk 3 applications:
Code:
% ldd `which xfce4-appearance-settings` | grep gtk
    libgtk-x11-2.0.so.0 => /usr/local/lib/libgtk-x11-2.0.so.0 (0x80026b000)
 
OP
OP
strider

strider

New Member

Reaction score: 2
Messages: 14

True but the themes I'm using have a gtk2 and gtk3 variant (so a gtk-2.0 and gtk3.0 directory in .local/share/themes/<my theme>).
 
OP
OP
strider

strider

New Member

Reaction score: 2
Messages: 14

Ok I found the root cause.
I wanted to tweak the evolution theme so I copied it over to ~/.local/share/themes.
After tweaking I selected it via 'appearances' in the settings manager, only to find out that it did exactly the same as before with my other themes for gtk2 applications. In gtk2 it fell back to the (ugly) default. My gtk3 applications still looked good though.
So I decided to move my theme to ~/.themes.
After that all my gtk2 apps looked the way they were supposed to be (and indeed very similar to my gtk3 apps).

I'll contact the port maintainer to see if he can get rid of this 'linuxism' in xfce4-settings ...
 
Top